ZigBeeNet Stack Documentation: Data Structures

  • Main Page
  • Data Structures
  • Files
  • Alphabetical List
  • Data Structures
  • Data Fields

ZigBeeNet Stack Documentation Data Structures

Here are the data structures with brief descriptions:
APS_Address_t | Common APS Address type
APS_AibAttribute_t | Types of parameters which can be set to the APS AIB
APS_AibPermissionsConfiguration_t | APS SubLayer Constants
APS_DataConf_t | Parameters structure of the APS_DataConf() function. The APSDE-DATA.confirm primitive
APS_DataInd_t | Parameters structure of the APS_DataInd() function The function is determined by certain End Point. The APSDE-DATA.indication primitive
APS_DataReq_t | Parameters structure of the APS_DataReq() function. The APSDE-DATA.request primitive
APS_GetConf_t | Parameters structure of the APS_GetConf() function. The APSME-GET.confirm primitive
APS_GetReq_t | Parameters structure of the APS_GetReq() function. The APSME-GET.request primitive
APS_RegisterEndpointReq_t | Parameters structure of the APS_RegisterEndpointReq() function. APSME-REGISTER-ENDPOINT.request primitive
APS_SetConf_t | Parameters structure of the APS_SetConf() function The APSME-SET.confirm primitive
APS_SetReq_t | Parameters structure of the APS_SetReq() function The APSME-SET.request primitive
APS_TxOptions_t | Describes the options of data transmission
APS_UnregisterEndpointReq_t | Parameters structure of the APS_UnregisterEndpointReq() function. APSME-UNREGISTER-ENDPOINT.request primitive
EDScan_t |
HAL_EepromParams_t | Eeprom access control structure
HAL_UartDescriptor_t | Uart descriptor
NetworkInf_t |
NodeAddr_t |
ZDO_ActiveEPReq_t |
ZDO_ActiveEPResp_t |
ZDO_ComplexDescReq_t |
ZDO_ComplexDescResp_t |
ZDO_DeviceAnnceReq_t |
ZDO_EndToEndAppKeyConf_t |
ZDO_EndToEndAppKeyReq_t |
ZDO_GetChildrenAddr_t | Describes the parameters of the ZDO_ChildrenAddrReq() function
ZDO_GetLqiRssi_t | Describes the parameters of the ZDO_LqiRssiReq() function
ZDO_IeeeAddrReq_t |
ZDO_IeeeAddrResp_t |
ZDO_MgmtLeaveReq_t |
ZDO_MgmtNwkUpdateNotf_t |
ZDO_MgmtNwkUpdateReq_t |
ZDO_MgmtPermitJoiningReq_t |
ZDO_NodeDescReq_t |
ZDO_NodeDescResp_t |
ZDO_NwkAddrReq_t |
ZDO_NwkAddrResp_t |
ZDO_PowerDescReq_t |
ZDO_PowerDescResp_t |
ZDO_ResetNetworkConf_t | Desribes the parameters of the ZDO_ResetNetworkConf() function
ZDO_ResetNetworkReq_t | Describes the parameters of the ZDO_ResetNetworkReq() function
ZDO_SetTxPowerConf_t | Describes the parameters of the ZDO_SetTxPowerConf() function
ZDO_SetTxPowerReq_t | Describes the parameters of the ZDO_SetTxPowerReq() function
ZDO_SimpleDescReq_t |
ZDO_SimpleDescResp_t |
ZDO_SleepConf_t |
ZDO_SleepReq_t |
ZDO_StartNetworkConf_t | Describes the parameters of the ZDO_StartNetworkConf() function
ZDO_StartNetworkReq_t | Describes the parameters of the ZDO_StartNetworkReq() function
ZDO_SystemServerDiscoveryReq_t |
ZDO_SystemServerDiscoveryResp_t |
ZDO_UserDescConfResp_t |
ZDO_UserDescReq_t |
ZDO_UserDescResp_t |
ZDO_UserDescSetReq_t |
ZDO_WakeUpConf_t |
ZDO_WakeUpReq_t |
ZDO_ZdpFrame_t |
ZDO_ZdpReq_t |
ZDO_ZdpReqFrame_t |
ZDO_ZdpResp_t |
ZDO_ZdpRespFrame_t |
ZdpSimpleDescriptor_t |
Generated on Wed Apr 9 17:48:41 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: APS_Address_t Union Reference

  • Alphabetical List
  • Data Fields

APS_Address_t Union Reference

Common APS Address type. More...

#include <aps.h>

Data Fields

ShortAddr_t | shortAddress
16-bit network address
ExtAddr_t | extAddress
64-bit extended IEEE address

Detailed Description

Common APS Address type.

Used as the part of standard APS primitives

Definition at line 114 of file aps.h.

Field Documentation

ShortAddr_t APS_Address_t::shortAddress

16-bit network address

Definition at line 116 of file aps.h.

ExtAddr_t APS_Address_t::extAddress

64-bit extended IEEE address

Definition at line 120 of file aps.h.

The documentation for this union was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_AibAttribute_t Union Reference

APS_AibAttribute_t Union Reference

Types of parameters which can be set to the APS AIB. More...

#include <aps.h>

Data Fields

void * | apsBindingTable
apsBindingTable pointer
bool | apsDesignatedCoordinator
apsDesignatedCoordinator value
uint32_t | apsChannelMask
apsChannelMask value
uint64_t | apsUseExtendedPANID
apsUseExtendedPANID value
APS_GroupTable_t * | apsGroupTable
apsGroupTable pointer
uint8_t | apsNonmemberRadius
apsNonmemberRadius value
APS_AibPermissionsConfiguration_t * apsPermissionsConfiguration
apsPermissionsConfiguration pointer
bool | apsUseInsecureJoin
apsUseInsecureJoin value
uint16_t | apsInterframeDelay
apsInterframeDelay value
void * | apsDeviceKeyPairSet
apsDeviceKeyPairSet pointer
uint64_t | apsTrustCenterAddress
apsTrustCenterAddress value
uint16_t | apsSecurityTimeOutPeriod
apsSecurityTimeOutPeriod value

Detailed Description

Types of parameters which can be set to the APS AIB.

Types of parameters which can be set to the APS AIB

This union used in AIB management primitives to interpret the particular parameter values

Definition at line 284 of file aps.h.

Field Documentation

void* APS_AibAttribute_t::apsBindingTable

apsBindingTable pointer

Definition at line 288 of file aps.h.

bool APS_AibAttribute_t::apsDesignatedCoordinator

apsDesignatedCoordinator value

Definition at line 289 of file aps.h.

uint32_t APS_AibAttribute_t::apsChannelMask

apsChannelMask value

Definition at line 290 of file aps.h.

uint64_t APS_AibAttribute_t::apsUseExtendedPANID

apsUseExtendedPANID value

Definition at line 291 of file aps.h.

APS_GroupTable_t* APS_AibAttribute_t::apsGroupTable

apsGroupTable pointer

Definition at line 292 of file aps.h.

uint8_t APS_AibAttribute_t::apsNonmemberRadius

apsNonmemberRadius value

Definition at line 293 of file aps.h.

APS_AibPermissionsConfiguration_t* APS_AibAttribute_t::apsPermissionsConfiguration

apsPermissionsConfiguration pointer

Definition at line 296 of file aps.h.

bool APS_AibAttribute_t::apsUseInsecureJoin

apsUseInsecureJoin value

Definition at line 298 of file aps.h.

uint16_t APS_AibAttribute_t::apsInterframeDelay

apsInterframeDelay value

Definition at line 299 of file aps.h.

void* APS_AibAttribute_t::apsDeviceKeyPairSet

apsDeviceKeyPairSet pointer

Definition at line 302 of file aps.h.

uint64_t APS_AibAttribute_t::apsTrustCenterAddress

apsTrustCenterAddress value

Definition at line 303 of file aps.h.

uint16_t APS_AibAttribute_t::apsSecurityTimeOutPeriod

apsSecurityTimeOutPeriod value

Definition at line 304 of file aps.h.

The documentation for this union was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_AibPermissionsConfiguration_t Struct Reference

APS_AibPermissionsConfiguration_t Struct Reference

APS SubLayer Constants. More...

#include <aps.h>

Data Fields

uint8_t | apscMaxDescriptorSize
apscMaxDescriptorSize
uint8_t | apscMaxFrameRetries
apscMaxFrameRetries
uint32_t | apscAckWaitDuration
apscAckWaitDuration
uint8_t | apscMinDuplicateRejectionTableSize
apscMinDuplicateRejectionTableSize
uint8_t | apscMaxWindowSize
apscMaxWindowSize
uint16_t | apscInterframeDelay
apscInterframeDelay
uint8_t | apscMinHeaderOverHead
apscMinHeaderOverHead

Detailed Description

APS SubLayer Constants.

APS constants stored in AIB

The constants defining the characteristics of the APS sub-layer

Definition at line 236 of file aps.h.

Field Documentation

uint8_t APS_AibPermissionsConfiguration_t::apscMaxDescriptorSize

apscMaxDescriptorSize

Definition at line 238 of file aps.h.

uint8_t APS_AibPermissionsConfiguration_t::apscMaxFrameRetries

apscMaxFrameRetries

Definition at line 239 of file aps.h.

uint32_t APS_AibPermissionsConfiguration_t::apscAckWaitDuration

apscAckWaitDuration

Definition at line 240 of file aps.h.

uint8_t APS_AibPermissionsConfiguration_t::apscMinDuplicateRejectionTableSize

apscMinDuplicateRejectionTableSize

Definition at line 241 of file aps.h.

uint8_t APS_AibPermissionsConfiguration_t::apscMaxWindowSize

apscMaxWindowSize

Definition at line 242 of file aps.h.

uint16_t APS_AibPermissionsConfiguration_t::apscInterframeDelay

apscInterframeDelay

Definition at line 243 of file aps.h.

uint8_t APS_AibPermissionsConfiguration_t::apscMinHeaderOverHead

apscMinHeaderOverHead

Definition at line 244 of file aps.h.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_DataConf_t Struct Reference

APS_DataConf_t Struct Reference

Parameters structure of the APS_DataConf() function. The APSDE-DATA.confirm primitive. More...

#include <aps.h>

Data Fields

APS_Status_t status
The status of the corresponding request.
uint32_t txTime
Timestamp for the transmitted packet based on the local clock, as provided by the NWK layer.

Detailed Description

Parameters structure of the APS_DataConf() function. The APSDE-DATA.confirm primitive.

Definition at line 318 of file aps.h.

Field Documentation

APS_Status_t APS_DataConf_t::status

The status of the corresponding request.

Definition at line 325 of file aps.h.

uint32_t APS_DataConf_t::txTime

Timestamp for the transmitted packet based on the local clock, as provided by the NWK layer.

Definition at line 328 of file aps.h.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_DataInd_t Struct Reference

APS_DataInd_t Struct Reference

Parameters structure of the APS_DataInd() function The function is determined by certain End Point. The APSDE-DATA.indication primitive. More...

#include <aps.h>

Data Fields

APS_AddrMode_t dstAddrMode
APS_Address_t dstAddress
Endpoint_t | dstEndpoint
APS_AddrMode_t srcAddrMode
APS_Address_t srcAddress
Endpoint_t | srcEndpoint
ProfileId_t | profileId
ClusterId_t | clusterId
uint8_t | asduLength
uint8_t * | asdu
APS_Status_t status
APS_Status_t securityStatus
uint8_t | linkQuality
uint32_t | rxTime

Detailed Description

Parameters structure of the APS_DataInd() function The function is determined by certain End Point. The APSDE-DATA.indication primitive.

Definition at line 422 of file aps.h.

Field Documentation

APS_AddrMode_t APS_DataInd_t::dstAddrMode

The addressing mode for the destination address used in this primitive and of the APDU that has been received. May possess any non-reserved value from the following list:
0x00 = reserved
0x01 = 16-bit group address for DstAddress; DstEndpoint is missing
0x02 = 16-bit address for DstAddress, DstEndpoint is present
0x03 - 0xff = reserved
Note: Note: It will be convenient to use the APS_AddrMode_t values

Definition at line 431 of file aps.h.

APS_Address_t APS_DataInd_t::dstAddress

The individual device address or group address to which the ASDU is directed. Value size depends on the dstAddrMode parameter

Definition at line 434 of file aps.h.

Endpoint_t APS_DataInd_t::dstEndpoint

The target endpoint on the local entity to which the ASDU is directed.

Definition at line 436 of file aps.h.

APS_AddrMode_t APS_DataInd_t::srcAddrMode

The addressing mode for the source address used in this primitive and of the APDU that has been received. May possess any non-reserved value from the following list:
0x00 = reserved
0x01 = reserved
0x02 = 16-bit short address for SrcAddress, SrcEndpoint is present
0x03 = 64-bit extended address for SrcAddress, SrcEndpoint is present
0x04 - 0xff = reserved
Note: It will be convenient to use the APS_AddrMode_t values

Definition at line 445 of file aps.h.

APS_Address_t APS_DataInd_t::srcAddress

The individual device address of the entity from which the ASDU has been received. Value type and size is depend of the srcAddrMode parameter

Definition at line 448 of file aps.h.

Endpoint_t APS_DataInd_t::srcEndpoint

The number of the individual endpoint of the entity from which the ASDU has been received.

Definition at line 451 of file aps.h.

ProfileId_t APS_DataInd_t::profileId

The identifier of the profile from which this frame originates.

Definition at line 453 of file aps.h.

ClusterId_t APS_DataInd_t::clusterId

The identifier of the received object.

Definition at line 455 of file aps.h.

uint8_t APS_DataInd_t::asduLength

The number of octets comprising the ASDU being indicated by the APSDE.

Definition at line 457 of file aps.h.

uint8_t* APS_DataInd_t::asdu

The set of octets comprising the ASDU being indicated by the APSDE.

Definition at line 459 of file aps.h.

APS_Status_t APS_DataInd_t::status

The status of the incoming frame processing.

Definition at line 461 of file aps.h.

APS_Status_t APS_DataInd_t::securityStatus

UNSECURED if the ASDU was received without any security. SECURED_NWK_KEY if the received ASDU was secured with the NWK key. SECURED_LINK_KEY if the ASDU was secured with a link key.

Definition at line 464 of file aps.h.

uint8_t APS_DataInd_t::linkQuality

The link quality indication delivered by the NLDE.

Definition at line 466 of file aps.h.

uint32_t APS_DataInd_t::rxTime

Timestamp for the received packet based on the local clock, as provided by the NWK layer.

Definition at line 469 of file aps.h.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_DataReq_t Struct Reference

APS_DataReq_t Struct Reference

Parameters structure of the APS_DataReq() function. The APSDE-DATA.request primitive. More...

#include <aps.h>

Data Fields

struct {
void * next
} service
APS_AddrMode_t dstAddrMode
APS_Address_t dstAddress
Endpoint_t | dstEndpoint
ProfileId_t | profileId
ClusterId_t | clusterId
Endpoint_t | srcEndpoint
uint8_t | asduLength
uint8_t * | asdu
APS_TxOptions_t txOptions
uint8_t | radius
void(* | APS_DataConf )(APS_DataConf_t *conf)
APS_DataConf_t confirm
Confirm primitive as a parameter of the callback function.

Detailed Description

Parameters structure of the APS_DataReq() function. The APSDE-DATA.request primitive.

Definition at line 351 of file aps.h.

Field Documentation

void* APS_DataReq_t::next

Definition at line 357 of file aps.h.

struct { ... } APS_DataReq_t::service

Used for queue support

APS_AddrMode_t APS_DataReq_t::dstAddrMode

The addressing mode for the destination address used in this primitive and the APDU to be transferred. May possess any non-reserved value from the following list:
0x00 = DstAddress and DstEndpoint are missing
0x01 = 16-bit group address for DstAddress, DstEndpoint is missing
0x02 = 16-bit address for DstAddress, DstEndpoint is present
0x03 = 64-bit extended address for DstAddress, DstEndpoint is present
0x04 - 0xff = reserved
Note: It will be convenient to use the APS_AddrMode_t values

Definition at line 371 of file aps.h.

APS_Address_t APS_DataReq_t::dstAddress

The address of the individual device or group address of the entity to which the ASDU is being transferred.

Definition at line 375 of file aps.h.

Endpoint_t APS_DataReq_t::dstEndpoint

This parameter shall be present if and only if the DstAddrMode parameter value is 0x02 or 0x03 and, if present, shall contain either the number of individual endpoints of the entity to which the ASDU is being transferred, or the broadcast endpoint (0xff).

Definition at line 381 of file aps.h.

ProfileId_t APS_DataReq_t::profileId

The identifier of the profile for which this frame is intended.

Definition at line 383 of file aps.h.

ClusterId_t APS_DataReq_t::clusterId

The identifier of the object for which this frame is intended.

Definition at line 385 of file aps.h.

Endpoint_t APS_DataReq_t::srcEndpoint

The individual endpoint of the entity from which the ASDU is being transferred.

Definition at line 387 of file aps.h.

uint8_t APS_DataReq_t::asduLength

The number of octets comprising the ASDU to be transferred. The maximum length of an individual APS frame payload is given as NsduLength-apscMinHeaderOverhead. Assuming the possibility of fragmentation, a maximum-sized single ASDU consists of 256 such blocks.

Definition at line 392 of file aps.h.

uint8_t* APS_DataReq_t::asdu

The set of octets comprising the ASDU to be transferred.

Definition at line 394 of file aps.h.

APS_TxOptions_t APS_DataReq_t::txOptions

<0000 xxxx> (Where x can be 0 or 1) The transmission options for the ASDU to be transferred. Must be selected among the following values:
0x01 = Security enabled transmission,
0x02 = Use NWK key,
0x04 = Acknowledged transmission,
0x08 = Fragmentation permitted,
probably combined by logical OR.
It is fine to use the APS_TxOptions_t enumerations.

Definition at line 404 of file aps.h.

uint8_t APS_DataReq_t::radius

The distance, in hops, that a transmitted frame will be allowed to travel via the network.

Definition at line 408 of file aps.h.

void(* APS_DataReq_t::APS_DataConf)(APS_DataConf_t *conf)

Callback function pointer as a handler of corresponding confirm primitive

APS_DataConf_t APS_DataReq_t::confirm

Confirm primitive as a parameter of the callback function.

Definition at line 412 of file aps.h.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_GetConf_t Struct Reference

APS_GetConf_t Struct Reference

Parameters structure of the APS_GetConf() function. The APSME-GET.confirm primitive. More...

#include <aps.h>

Data Fields

APS_Status_t status
uint16_t aibAttributeLength
APS_AibAttribute_t aibAttributeValue

Detailed Description

Parameters structure of the APS_GetConf() function. The APSME-GET.confirm primitive.

Definition at line 551 of file aps.h.

Field Documentation

APS_Status_t APS_GetConf_t::status

The results of the request to read an AIB attribute value.

Definition at line 555 of file aps.h.

uint16_t APS_GetConf_t::aibAttributeLength

The length, in octets, of the attribute value being returned.

Definition at line 557 of file aps.h.

APS_AibAttribute_t APS_GetConf_t::aibAttributeValue

The value of the AIB attribute that was read.

Definition at line 559 of file aps.h.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_GetReq_t Struct Reference

APS_GetReq_t Struct Reference

Parameters structure of the APS_GetReq() function. The APSME-GET.request primitive. More...

#include <aps.h>

Data Fields

APS_AibAttributeId_t aibAttribute
APS_GetConf_t confirm

Detailed Description

Parameters structure of the APS_GetReq() function. The APSME-GET.request primitive.

Definition at line 568 of file aps.h.

Field Documentation

APS_AibAttributeId_t APS_GetReq_t::aibAttribute

The identifier of the AIB attribute to read.

Definition at line 572 of file aps.h.

APS_GetConf_t APS_GetReq_t::confirm

The confirm primitive as transaction result

Definition at line 576 of file aps.h.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_RegisterEndpointReq_t Struct Reference

APS_RegisterEndpointReq_t Struct Reference

Parameters structure of the APS_RegisterEndpointReq() function. APSME-REGISTER-ENDPOINT.request primitive. More...

#include <aps.h>

Data Fields

struct {
void * next
struct {
uint8_t noIndication:1
uint8_t reserved:7
}
} service
SimpleDescriptor_t * | simpleDescriptor
void(* | APS_DataInd )(APS_DataInd_t *ind)

Detailed Description

Parameters structure of the APS_RegisterEndpointReq() function. APSME-REGISTER-ENDPOINT.request primitive.

Definition at line 1293 of file aps.h.

Field Documentation

void* APS_RegisterEndpointReq_t::next

Definition at line 1299 of file aps.h.

uint8_t APS_RegisterEndpointReq_t::noIndication

Definition at line 1302 of file aps.h.

uint8_t APS_RegisterEndpointReq_t::reserved

Definition at line 1303 of file aps.h.

struct { ... } APS_RegisterEndpointReq_t::service

Used for queue support

SimpleDescriptor_t* APS_RegisterEndpointReq_t::simpleDescriptor

Simple descriptor pointer

Definition at line 1309 of file aps.h.

void(* APS_RegisterEndpointReq_t::APS_DataInd)(APS_DataInd_t *ind)

The APSDE-DATA.indication handler pointer for endpoint should be registered.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_SetConf_t Struct Reference

APS_SetConf_t Struct Reference

Parameters structure of the APS_SetConf() function The APSME-SET.confirm primitive. More...

#include <aps.h>

Data Fields

APS_Status_t status

Detailed Description

Parameters structure of the APS_SetConf() function The APSME-SET.confirm primitive.

Definition at line 585 of file aps.h.

Field Documentation

APS_Status_t APS_SetConf_t::status

The result of the request to write the AIB Attribute.

Definition at line 589 of file aps.h.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_SetReq_t Struct Reference

APS_SetReq_t Struct Reference

Parameters structure of the APS_SetReq() function The APSME-SET.request primitive. More...

#include <aps.h>

Data Fields

APS_AibAttributeId_t aibAttribute
uint16_t aibAttributeLength
APS_AibAttribute_t aibAttributeValue
APS_SetConf_t confirm

Detailed Description

Parameters structure of the APS_SetReq() function The APSME-SET.request primitive.

Definition at line 598 of file aps.h.

Field Documentation

APS_AibAttributeId_t APS_SetReq_t::aibAttribute

The identifier of the AIB attribute to be written.

Definition at line 602 of file aps.h.

uint16_t APS_SetReq_t::aibAttributeLength

The length, in octets, of the attribute value being set.

Definition at line 604 of file aps.h.

APS_AibAttribute_t APS_SetReq_t::aibAttributeValue

The value of the AIB attribute that should be written.

Definition at line 606 of file aps.h.

APS_SetConf_t APS_SetReq_t::confirm

The confirm primitive as transaction result

Definition at line 610 of file aps.h.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_TxOptions_t Struct Reference

APS_TxOptions_t Struct Reference

Describes the options of data transmission. More...

#include <aps.h>

Data Fields

uint8_t | securityEnabledTransmission:1
Security enabled transmission.
uint8_t | useNwkKey:1
Use NWK key.
uint8_t | acknowledgedTransmission:1
Acknowledged transmission.
uint8_t | fragmentationPermitted:1
Fragmentation permitted.
uint8_t | reserved:4
Reserved. Should always be zero.

Detailed Description

Describes the options of data transmission.

Definition at line 337 of file aps.h.

Field Documentation

uint8_t APS_TxOptions_t::securityEnabledTransmission

Security enabled transmission.

Definition at line 339 of file aps.h.

uint8_t APS_TxOptions_t::useNwkKey

Use NWK key.

Definition at line 340 of file aps.h.

uint8_t APS_TxOptions_t::acknowledgedTransmission

Acknowledged transmission.

Definition at line 341 of file aps.h.

uint8_t APS_TxOptions_t::fragmentationPermitted

Fragmentation permitted.

Definition at line 342 of file aps.h.

uint8_t APS_TxOptions_t::reserved

Reserved. Should always be zero.

Definition at line 343 of file aps.h.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: APS_UnregisterEndpointReq_t Struct Reference

APS_UnregisterEndpointReq_t Struct Reference

Parameters structure of the APS_UnregisterEndpointReq() function. APSME-UNREGISTER-ENDPOINT.request primitive. More...

#include <aps.h>

Data Fields

Endpoint_t endpoint

Detailed Description

Parameters structure of the APS_UnregisterEndpointReq() function. APSME-UNREGISTER-ENDPOINT.request primitive.

Definition at line 1319 of file aps.h.

Field Documentation

Endpoint_t APS_UnregisterEndpointReq_t::endpoint

The endpoint which should be unregistered.

Definition at line 1323 of file aps.h.

The documentation for this struct was generated from the following file:
  • aps.h


ZigBeeNet Stack Documentation: EDScan_t Struct Reference

EDScan_t Struct Reference

#include <zdo.h>

Data Fields

uint32_t | scannedChannels
uint16_t | totalTransmissions
uint16_t | transmissionsFailures
uint8_t | scannedChannelsListCount
uint8_t | energyValues [32]

Detailed Description

Definition at line 209 of file zdo.h.

Field Documentation

uint32_t EDScan_t::scannedChannels

Definition at line 211 of file zdo.h.

uint16_t EDScan_t::totalTransmissions

Definition at line 212 of file zdo.h.

uint16_t EDScan_t::transmissionsFailures

Definition at line 213 of file zdo.h.

uint8_t EDScan_t::scannedChannelsListCount

Definition at line 214 of file zdo.h.

uint8_t EDScan_t::energyValues[32]

Definition at line 215 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: HAL_EepromParams_t Struct Reference

HAL_EepromParams_t Struct Reference

eeprom access control structure More...

#include <eeprom.h>

Data Fields

uint16_t | address
EEPROM address.
uint8_t * | data
pointer to data memory
uint16_t | length
number of bytes

Detailed Description

eeprom access control structure

Definition at line 24 of file eeprom.h.

Field Documentation

uint16_t HAL_EepromParams_t::address

EEPROM address.

Definition at line 27 of file eeprom.h.

uint8_t* HAL_EepromParams_t::data

pointer to data memory

Definition at line 29 of file eeprom.h.

uint16_t HAL_EepromParams_t::length

number of bytes

Definition at line 31 of file eeprom.h.

The documentation for this struct was generated from the following file:
  • eeprom.h


ZigBeeNet Stack Documentation: HAL_UartDescriptor_t Struct Reference

HAL_UartDescriptor_t Struct Reference

Uart descriptor. More...

#include <uart.h>

Data Fields

uint8_t | tty
tty - One of the defines UART_CHANNEL_0 or UART_CHANNEL_1. Defines a number of UART.
UartMode_t | mode
Sets synchronous or asynchronous routine.
Must be chosen from:
ASYNC
SYNC
.
UartBaudRate_t | baudrate
baudrate - UART baud rate. Must be chosen from:
UART_BAUDRATE_1200
UART_BAUDRATE_9600
UART_BAUDRATE_19200
UART_BAUDRATE_38400
UART_SYNC_BAUDRATE_1200
UART_SYNC_BAUDRATE_9600
UART_SYNC_BAUDRATE_38400
UART_SYNC_BAUDRATE_57600
UART_SYNC_BAUDRATE_115200

UartData_t | dataLength
data - UART data length. Must be chosen from:
UART_DATA5
UART_DATA6
UART_DATA7
UART_DATA8

UartParity_t | parity
parity - UART parity mode. Must be chosen from:
UART_PARITY_NONE
UART_PARITY_EVEN
UART_PARITY_ODD

UartStopBits_t | stopbits
stopbits - UART stop bits number. Must be chosen from:
UART_STOPBIT_1
UART_STOPBIT_2

UartSyncMode_t | edge
edge - data received edge (only for usart). Must be chosen from:
RISING_EDGE
FALLING_EDGE

UartClckMode_t | syncMode
master or slave on usart (only for usart)
uint8_t * | rxBuffer
Pointer to receive buffer.
If rxBuffer is NULL then transactions are discarded.
Size of buffer depends on user application.
uint16_t | rxBufferLength
length of receive buffer
uint8_t * | txBuffer
Pointer to transmit buffer.
If txBuffer is NULL then callback method is used.
If txBuffer is not NULL then polling method is used.
uint16_t | txBufferLength
length of transmit buffer
void(* | rxCallback )(uint8_t)
Receive uart callback.
If rxCallback is NULL then polling method is used.
If rxCallback is not NULL then callback method is used.
void(* | txCallback )()
Transmission complete uart callback.
If txBuffer is not NULL then txCallback notify about end of bytes sending.
uint8_t | flowControl
flow control of uart. One of the defines UART_FLOW_CONTROL_NONE, UART_FLOW_CONTROL_HARDWARE, UART_DTR_CONTROL, probably combined by logical OR.

Detailed Description

Uart descriptor.

Definition at line 39 of file uart.h.

Field Documentation

uint8_t HAL_UartDescriptor_t::tty

tty - One of the defines UART_CHANNEL_0 or UART_CHANNEL_1. Defines a number of UART.

Definition at line 43 of file uart.h.

UartMode_t HAL_UartDescriptor_t::mode

Sets synchronous or asynchronous routine.
Must be chosen from:
ASYNC
SYNC
.

Definition at line 48 of file uart.h.

UartBaudRate_t HAL_UartDescriptor_t::baudrate

baudrate - UART baud rate. Must be chosen from:
UART_BAUDRATE_1200
UART_BAUDRATE_9600
UART_BAUDRATE_19200
UART_BAUDRATE_38400
UART_SYNC_BAUDRATE_1200
UART_SYNC_BAUDRATE_9600
UART_SYNC_BAUDRATE_38400
UART_SYNC_BAUDRATE_57600
UART_SYNC_BAUDRATE_115200

Definition at line 59 of file uart.h.

UartData_t HAL_UartDescriptor_t::dataLength

data - UART data length. Must be chosen from:
UART_DATA5
UART_DATA6
UART_DATA7
UART_DATA8

Definition at line 65 of file uart.h.

UartParity_t HAL_UartDescriptor_t::parity

parity - UART parity mode. Must be chosen from:
UART_PARITY_NONE
UART_PARITY_EVEN
UART_PARITY_ODD

Definition at line 70 of file uart.h.

UartStopBits_t HAL_UartDescriptor_t::stopbits

stopbits - UART stop bits number. Must be chosen from:
UART_STOPBIT_1
UART_STOPBIT_2

Definition at line 74 of file uart.h.

UartSyncMode_t HAL_UartDescriptor_t::edge

edge - data received edge (only for usart). Must be chosen from:
RISING_EDGE
FALLING_EDGE

Definition at line 78 of file uart.h.

UartClckMode_t HAL_UartDescriptor_t::syncMode

master or slave on usart (only for usart)

Definition at line 80 of file uart.h.

uint8_t* HAL_UartDescriptor_t::rxBuffer

Pointer to receive buffer.
If rxBuffer is NULL then transactions are discarded.
Size of buffer depends on user application.

Definition at line 84 of file uart.h.

uint16_t HAL_UartDescriptor_t::rxBufferLength

length of receive buffer

Definition at line 86 of file uart.h.

uint8_t* HAL_UartDescriptor_t::txBuffer

Pointer to transmit buffer.
If txBuffer is NULL then callback method is used.
If txBuffer is not NULL then polling method is used.

Definition at line 90 of file uart.h.

uint16_t HAL_UartDescriptor_t::txBufferLength

length of transmit buffer

Definition at line 92 of file uart.h.

void(* HAL_UartDescriptor_t::rxCallback)(uint8_t)

Receive uart callback.
If rxCallback is NULL then polling method is used.
If rxCallback is not NULL then callback method is used.

void(* HAL_UartDescriptor_t::txCallback)()

Transmission complete uart callback.
If txBuffer is not NULL then txCallback notify about end of bytes sending.

uint8_t HAL_UartDescriptor_t::flowControl

flow control of uart. One of the defines UART_FLOW_CONTROL_NONE, UART_FLOW_CONTROL_HARDWARE, UART_DTR_CONTROL, probably combined by logical OR.

Definition at line 101 of file uart.h.

The documentation for this struct was generated from the following file:
  • uart.h


ZigBeeNet Stack Documentation: NetworkInf_t Struct Reference

NetworkInf_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t | parentShortAddr
PanId_t | panId
uint8_t | currentChannel
ShortAddr_t | shortAddr

Detailed Description

Definition at line 218 of file zdo.h.

Field Documentation

ShortAddr_t NetworkInf_t::parentShortAddr

Definition at line 220 of file zdo.h.

PanId_t NetworkInf_t::panId

Definition at line 221 of file zdo.h.

uint8_t NetworkInf_t::currentChannel

Definition at line 222 of file zdo.h.

ShortAddr_t NetworkInf_t::shortAddr

Definition at line 223 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: NodeAddr_t Struct Reference

NodeAddr_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t | shortAddr
ExtAddr_t | extAddr

Detailed Description

Definition at line 546 of file zdo.h.

Field Documentation

ShortAddr_t NodeAddr_t::shortAddr

Definition at line 548 of file zdo.h.

ExtAddr_t NodeAddr_t::extAddr

Definition at line 549 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ActiveEPReq_t Struct Reference

ZDO_ActiveEPReq_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t nwkAddrOfInterest

Detailed Description

Definition at line 283 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_ActiveEPReq_t::nwkAddrOfInterest

Definition at line 285 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ActiveEPResp_t Struct Reference

ZDO_ActiveEPResp_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t | nwkAddrOfInterest
uint8_t | activeEPCount
uint8_t | activeEPList [MAX_ACTIVE_EP_NUMBER]

Detailed Description

Definition at line 404 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_ActiveEPResp_t::nwkAddrOfInterest

Definition at line 406 of file zdo.h.

uint8_t ZDO_ActiveEPResp_t::activeEPCount

Definition at line 407 of file zdo.h.

uint8_t ZDO_ActiveEPResp_t::activeEPList[MAX_ACTIVE_EP_NUMBER]

Definition at line 408 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ComplexDescReq_t Struct Reference

ZDO_ComplexDescReq_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t nwkAddrOfInterest

Detailed Description

Definition at line 288 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_ComplexDescReq_t::nwkAddrOfInterest

Definition at line 290 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ComplexDescResp_t Struct Reference

ZDO_ComplexDescResp_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t nwkAddrOfInterest

Detailed Description

Definition at line 389 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_ComplexDescResp_t::nwkAddrOfInterest

Definition at line 391 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_DeviceAnnceReq_t Struct Reference

ZDO_DeviceAnnceReq_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t | nwkAddrLocal
ExtAddr_t | ieeeAddrLocal
uint8_t | macCapability

Detailed Description

Definition at line 309 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_DeviceAnnceReq_t::nwkAddrLocal

Definition at line 311 of file zdo.h.

ExtAddr_t ZDO_DeviceAnnceReq_t::ieeeAddrLocal

Definition at line 312 of file zdo.h.

uint8_t ZDO_DeviceAnnceReq_t::macCapability

Definition at line 313 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_EndToEndAppKeyConf_t Struct Reference

ZDO_EndToEndAppKeyConf_t Struct Reference

#include <zdo.h>

Data Fields

ZDO_Status_t status

Detailed Description

Definition at line 599 of file zdo.h.

Field Documentation

ZDO_Status_t ZDO_EndToEndAppKeyConf_t::status

Definition at line 601 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_EndToEndAppKeyReq_t Struct Reference

ZDO_EndToEndAppKeyReq_t Struct Reference

#include <zdo.h>

Data Fields

ExtAddr_t | deviceAddr
void(* | ZDO_EndToEndAppKeyConf )(ZDO_EndToEndAppKeyConf_t *conf)
ZDO_EndToEndAppKeyConf_t confirm

Detailed Description

Definition at line 604 of file zdo.h.

Field Documentation

ExtAddr_t ZDO_EndToEndAppKeyReq_t::deviceAddr

Definition at line 606 of file zdo.h.

void(* ZDO_EndToEndAppKeyReq_t::ZDO_EndToEndAppKeyConf)(ZDO_EndToEndAppKeyConf_t *conf)

ZDO_EndToEndAppKeyConf_t ZDO_EndToEndAppKeyReq_t::confirm

Definition at line 608 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_GetChildrenAddr_t Struct Reference

ZDO_GetChildrenAddr_t Struct Reference

Describes the parameters of the ZDO_ChildrenAddrReq() function. More...

#include <zdo.h>

Data Fields

uint8_t childrenCount
number of children
NodeAddr_t * childrenTable
pointer to the memory allocated for children information

Detailed Description

Describes the parameters of the ZDO_ChildrenAddrReq() function.

Definition at line 566 of file zdo.h.

Field Documentation

uint8_t ZDO_GetChildrenAddr_t::childrenCount

number of children

Definition at line 568 of file zdo.h.

NodeAddr_t* ZDO_GetChildrenAddr_t::childrenTable

pointer to the memory allocated for children information

Definition at line 569 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_GetLqiRssi_t Struct Reference

ZDO_GetLqiRssi_t Struct Reference

Describes the parameters of the ZDO_LqiRssiReq() function. More...

#include <zdo.h>

Data Fields

ShortAddr_t | nodeAddr
the address of the requested node
ZDO_Status_t status
result of the operation
uint8_t | lqi
pointer to the memory allocated for LQI
uint8_t | rssi
pointer to the memory allocated for RSSI

Detailed Description

Describes the parameters of the ZDO_LqiRssiReq() function.

Definition at line 555 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_GetLqiRssi_t::nodeAddr

the address of the requested node

Definition at line 557 of file zdo.h.

ZDO_Status_t ZDO_GetLqiRssi_t::status

result of the operation

Definition at line 558 of file zdo.h.

uint8_t ZDO_GetLqiRssi_t::lqi

pointer to the memory allocated for LQI

Definition at line 559 of file zdo.h.

uint8_t ZDO_GetLqiRssi_t::rssi

pointer to the memory allocated for RSSI

Definition at line 560 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_IeeeAddrReq_t Struct Reference

ZDO_IeeeAddrReq_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t | nwkAddrOfInterest
uint8_t | reqType
uint8_t | startIndex

Detailed Description

Definition at line 266 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_IeeeAddrReq_t::nwkAddrOfInterest

Definition at line 268 of file zdo.h.

uint8_t ZDO_IeeeAddrReq_t::reqType

Definition at line 269 of file zdo.h.

uint8_t ZDO_IeeeAddrReq_t::startIndex

Definition at line 270 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_IeeeAddrResp_t Struct Reference

ZDO_IeeeAddrResp_t Struct Reference

#include <zdo.h>

Data Fields

ExtAddr_t | ieeeAddrRemote
ShortAddr_t | nwkAddrRemote
uint8_t | numAssocDev
uint8_t | startIndex
ShortAddr_t | nwkAddrAssocDevList [CS_MAX_CHILDREN_AMOUNT]

Detailed Description

Definition at line 368 of file zdo.h.

Field Documentation

ExtAddr_t ZDO_IeeeAddrResp_t::ieeeAddrRemote

Definition at line 370 of file zdo.h.

ShortAddr_t ZDO_IeeeAddrResp_t::nwkAddrRemote

Definition at line 371 of file zdo.h.

uint8_t ZDO_IeeeAddrResp_t::numAssocDev

Definition at line 372 of file zdo.h.

uint8_t ZDO_IeeeAddrResp_t::startIndex

Definition at line 373 of file zdo.h.

ShortAddr_t ZDO_IeeeAddrResp_t::nwkAddrAssocDevList[CS_MAX_CHILDREN_AMOUNT]

Definition at line 374 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_MgmtLeaveReq_t Struct Reference

ZDO_MgmtLeaveReq_t Struct Reference

#include <zdo.h>

Data Fields

ExtAddr_t | deviceAddr
uint8_t | reserved: 6
uint8_t | removeChildren: 1
uint8_t | rejoin: 1

Detailed Description

Definition at line 333 of file zdo.h.

Field Documentation

ExtAddr_t ZDO_MgmtLeaveReq_t::deviceAddr

Definition at line 335 of file zdo.h.

uint8_t ZDO_MgmtLeaveReq_t::reserved

Definition at line 336 of file zdo.h.

uint8_t ZDO_MgmtLeaveReq_t::removeChildren

Definition at line 337 of file zdo.h.

uint8_t ZDO_MgmtLeaveReq_t::rejoin

Definition at line 338 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_MgmtNwkUpdateNotf_t Struct Reference

ZDO_MgmtNwkUpdateNotf_t Struct Reference

#include <zdo.h>

Data Fields

uint8_t status
union {
EDScan_t scanResult
NetworkInf_t nwkUpdateInf
};

Detailed Description

Definition at line 226 of file zdo.h.

Field Documentation

uint8_t ZDO_MgmtNwkUpdateNotf_t::status

Definition at line 229 of file zdo.h.

EDScan_t ZDO_MgmtNwkUpdateNotf_t::scanResult

Definition at line 232 of file zdo.h.

NetworkInf_t ZDO_MgmtNwkUpdateNotf_t::nwkUpdateInf

Definition at line 233 of file zdo.h.

union { ... }

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_MgmtNwkUpdateReq_t Struct Reference

ZDO_MgmtNwkUpdateReq_t Struct Reference

#include <zdo.h>

Data Fields

uint32_t | scanChannels
uint8_t | scanDuration
union {
uint8_t scanCount
uint8_t nwkUpdateId
};
ShortAddr_t | nwkManagerAddr

Detailed Description

Definition at line 347 of file zdo.h.

Field Documentation

uint32_t ZDO_MgmtNwkUpdateReq_t::scanChannels

Definition at line 349 of file zdo.h.

uint8_t ZDO_MgmtNwkUpdateReq_t::scanDuration

Definition at line 350 of file zdo.h.

uint8_t ZDO_MgmtNwkUpdateReq_t::scanCount

Definition at line 353 of file zdo.h.

uint8_t ZDO_MgmtNwkUpdateReq_t::nwkUpdateId

Definition at line 354 of file zdo.h.

union { ... }

ShortAddr_t ZDO_MgmtNwkUpdateReq_t::nwkManagerAddr

Definition at line 356 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_MgmtPermitJoiningReq_t Struct Reference

ZDO_MgmtPermitJoiningReq_t Struct Reference

#include <zdo.h>

Data Fields

uint8_t | permitDuration
uint8_t | tcSignificance

Detailed Description

Definition at line 341 of file zdo.h.

Field Documentation

uint8_t ZDO_MgmtPermitJoiningReq_t::permitDuration

Definition at line 343 of file zdo.h.

uint8_t ZDO_MgmtPermitJoiningReq_t::tcSignificance

Definition at line 344 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_NodeDescReq_t Struct Reference

ZDO_NodeDescReq_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t nwkAddrOfInterest

Detailed Description

Definition at line 273 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_NodeDescReq_t::nwkAddrOfInterest

Definition at line 275 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_NodeDescResp_t Struct Reference

ZDO_NodeDescResp_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t | nwkAddrOfInterest
NodeDescriptor_t | nodeDescriptor

Detailed Description

Definition at line 377 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_NodeDescResp_t::nwkAddrOfInterest

Definition at line 379 of file zdo.h.

NodeDescriptor_t ZDO_NodeDescResp_t::nodeDescriptor

Definition at line 380 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_NwkAddrReq_t Struct Reference

ZDO_NwkAddrReq_t Struct Reference

#include <zdo.h>

Data Fields

ExtAddr_t | ieeeAddrOfInterest
uint8_t | reqType
uint8_t | startIndex

Detailed Description

Definition at line 259 of file zdo.h.

Field Documentation

ExtAddr_t ZDO_NwkAddrReq_t::ieeeAddrOfInterest

Definition at line 261 of file zdo.h.

uint8_t ZDO_NwkAddrReq_t::reqType

Definition at line 262 of file zdo.h.

uint8_t ZDO_NwkAddrReq_t::startIndex

Definition at line 263 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_NwkAddrResp_t Struct Reference

ZDO_NwkAddrResp_t Struct Reference

#include <zdo.h>

Data Fields

ExtAddr_t | ieeeAddrRemote
ShortAddr_t | nwkAddrRemote
uint8_t | numAssocDev
uint8_t | startIndex
ShortAddr_t | nwkAddrAssocDevList [CS_MAX_CHILDREN_AMOUNT]

Detailed Description

Definition at line 359 of file zdo.h.

Field Documentation

ExtAddr_t ZDO_NwkAddrResp_t::ieeeAddrRemote

Definition at line 361 of file zdo.h.

ShortAddr_t ZDO_NwkAddrResp_t::nwkAddrRemote

Definition at line 362 of file zdo.h.

uint8_t ZDO_NwkAddrResp_t::numAssocDev

Definition at line 363 of file zdo.h.

uint8_t ZDO_NwkAddrResp_t::startIndex

Definition at line 364 of file zdo.h.

ShortAddr_t ZDO_NwkAddrResp_t::nwkAddrAssocDevList[CS_MAX_CHILDREN_AMOUNT]

Definition at line 365 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_PowerDescReq_t Struct Reference

ZDO_PowerDescReq_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t nwkAddrOfInterest

Detailed Description

Definition at line 278 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_PowerDescReq_t::nwkAddrOfInterest

Definition at line 280 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_PowerDescResp_t Struct Reference

ZDO_PowerDescResp_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t | nwkAddrOfInterest
PowerDescriptor_t | powerDescriptor

Detailed Description

Definition at line 383 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_PowerDescResp_t::nwkAddrOfInterest

Definition at line 385 of file zdo.h.

PowerDescriptor_t ZDO_PowerDescResp_t::powerDescriptor

Definition at line 386 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ResetNetworkConf_t Struct Reference

ZDO_ResetNetworkConf_t Struct Reference

Desribes the parameters of the ZDO_ResetNetworkConf() function. More...

#include <zdo.h>

Data Fields

ZDO_Status_t status
The result of the reset request.

Detailed Description

Desribes the parameters of the ZDO_ResetNetworkConf() function.

Definition at line 195 of file zdo.h.

Field Documentation

ZDO_Status_t ZDO_ResetNetworkConf_t::status

The result of the reset request.

Definition at line 197 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ResetNetworkReq_t Struct Reference

ZDO_ResetNetworkReq_t Struct Reference

Describes the parameters of the ZDO_ResetNetworkReq() function. More...

#include <zdo.h>

Data Fields

ZDO_ResetNetworkConf_t confParams
Parameters of the confirm being returned in ZDO_ResetNetworkConf().
void(* ZDO_ResetNetworkConf )(ZDO_ResetNetworkConf_t *conf)
The function called to confirm the request.

Detailed Description

Describes the parameters of the ZDO_ResetNetworkReq() function.

Definition at line 203 of file zdo.h.

Field Documentation

ZDO_ResetNetworkConf_t ZDO_ResetNetworkReq_t::confParams

Parameters of the confirm being returned in ZDO_ResetNetworkConf().

Definition at line 205 of file zdo.h.

void(* ZDO_ResetNetworkReq_t::ZDO_ResetNetworkConf)(ZDO_ResetNetworkConf_t *conf)

The function called to confirm the request.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_SetTxPowerConf_t Struct Reference

ZDO_SetTxPowerConf_t Struct Reference

Describes the parameters of the ZDO_SetTxPowerConf() function. More...

#include <zdo.h>

Data Fields

ZDO_Status_t status
the result of transmitter power setting

Detailed Description

Describes the parameters of the ZDO_SetTxPowerConf() function.

Definition at line 575 of file zdo.h.

Field Documentation

ZDO_Status_t ZDO_SetTxPowerConf_t::status

the result of transmitter power setting

Definition at line 577 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_SetTxPowerReq_t Struct Reference

ZDO_SetTxPowerReq_t Struct Reference

Describes the parameters of the ZDO_SetTxPowerReq() function. More...

#include <zdo.h>

Data Fields

uint8_t | txPower
power of transmitter
void(* | ZDO_SetTxPowerConf )(ZDO_SetTxPowerConf_t *conf)
The function called to confirm the request.
ZDO_SetTxPowerConf_t confirm
Parameters of the confirm being returned in ZDO_SetTxPowerConf().

Detailed Description

Describes the parameters of the ZDO_SetTxPowerReq() function.

Definition at line 583 of file zdo.h.

Field Documentation

uint8_t ZDO_SetTxPowerReq_t::txPower

power of transmitter

Definition at line 585 of file zdo.h.

void(* ZDO_SetTxPowerReq_t::ZDO_SetTxPowerConf)(ZDO_SetTxPowerConf_t *conf)

The function called to confirm the request.

ZDO_SetTxPowerConf_t ZDO_SetTxPowerReq_t::confirm

Parameters of the confirm being returned in ZDO_SetTxPowerConf().

Definition at line 587 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_SimpleDescReq_t Struct Reference

ZDO_SimpleDescReq_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t | nwkAddrOfInterest
Endpoint_t | endpoint

Detailed Description

Definition at line 303 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_SimpleDescReq_t::nwkAddrOfInterest

Definition at line 305 of file zdo.h.

Endpoint_t ZDO_SimpleDescReq_t::endpoint

Definition at line 306 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_SimpleDescResp_t Struct Reference

ZDO_SimpleDescResp_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t | nwkAddrOfInterest
uint8_t | length
ZdpSimpleDescriptor_t simpleDescriptor

Detailed Description

Definition at line 425 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_SimpleDescResp_t::nwkAddrOfInterest

Definition at line 427 of file zdo.h.

uint8_t ZDO_SimpleDescResp_t::length

Definition at line 428 of file zdo.h.

ZdpSimpleDescriptor_t ZDO_SimpleDescResp_t::simpleDescriptor

Definition at line 429 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_SleepConf_t Struct Reference

ZDO_SleepConf_t Struct Reference

#include <zdo.h>

Data Fields

ZDO_Status_t status

Detailed Description

Definition at line 237 of file zdo.h.

Field Documentation

ZDO_Status_t ZDO_SleepConf_t::status

Definition at line 239 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_SleepReq_t Struct Reference

ZDO_SleepReq_t Struct Reference

#include <zdo.h>

Data Fields

ZDO_SleepConf_t confirm
void(* ZDO_SleepConf )(ZDO_SleepConf_t *conf)

Detailed Description

Definition at line 242 of file zdo.h.

Field Documentation

ZDO_SleepConf_t ZDO_SleepReq_t::confirm

Definition at line 244 of file zdo.h.

void(* ZDO_SleepReq_t::ZDO_SleepConf)(ZDO_SleepConf_t *conf)

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_StartNetworkConf_t Struct Reference

ZDO_StartNetworkConf_t Struct Reference

Describes the parameters of the ZDO_StartNetworkConf() function. More...

#include <zdo.h>

Data Fields

uint8_t | activeChannel
Current channel the device has connected on.
ShortAddr_t | shortAddr
Received short address.
PanId_t | PANId
Received short PANId.
uint64_t | extPANId
Received extended PANId if it was not determined during startup.
ShortAddr_t | parentAddr
Parent address.
ZDO_Status_t status
The result of network start.

Detailed Description

Describes the parameters of the ZDO_StartNetworkConf() function.

Definition at line 173 of file zdo.h.

Field Documentation

uint8_t ZDO_StartNetworkConf_t::activeChannel

Current channel the device has connected on.

Definition at line 175 of file zdo.h.

ShortAddr_t ZDO_StartNetworkConf_t::shortAddr

Received short address.

Definition at line 176 of file zdo.h.

PanId_t ZDO_StartNetworkConf_t::PANId

Received short PANId.

Definition at line 177 of file zdo.h.

uint64_t ZDO_StartNetworkConf_t::extPANId

Received extended PANId if it was not determined during startup.

Definition at line 178 of file zdo.h.

ShortAddr_t ZDO_StartNetworkConf_t::parentAddr

Parent address.

Definition at line 179 of file zdo.h.

ZDO_Status_t ZDO_StartNetworkConf_t::status

The result of network start.

Definition at line 180 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_StartNetworkReq_t Struct Reference

ZDO_StartNetworkReq_t Struct Reference

Describes the parameters of the ZDO_StartNetworkReq() function. More...

#include <zdo.h>

Data Fields

ZDO_StartNetworkConf_t confParams
Parameters of the confirm being returned in ZDO_StartNetworkConf().
void(* ZDO_StartNetworkConf )(ZDO_StartNetworkConf_t *conf)
The function called to confirm the request.

Detailed Description

Describes the parameters of the ZDO_StartNetworkReq() function.

Definition at line 186 of file zdo.h.

Field Documentation

ZDO_StartNetworkConf_t ZDO_StartNetworkReq_t::confParams

Parameters of the confirm being returned in ZDO_StartNetworkConf().

Definition at line 188 of file zdo.h.

void(* ZDO_StartNetworkReq_t::ZDO_StartNetworkConf)(ZDO_StartNetworkConf_t *conf)

The function called to confirm the request.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_SystemServerDiscoveryReq_t Struct Reference

ZDO_SystemServerDiscoveryReq_t Struct Reference

#include <zdo.h>

Data Fields

uint16_t serverMask

Detailed Description

Definition at line 316 of file zdo.h.

Field Documentation

uint16_t ZDO_SystemServerDiscoveryReq_t::serverMask

Definition at line 318 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_SystemServerDiscoveryResp_t Struct Reference

ZDO_SystemServerDiscoveryResp_t Struct Reference

#include <zdo.h>

Data Fields

uint16_t serverMask

Detailed Description

Definition at line 432 of file zdo.h.

Field Documentation

uint16_t ZDO_SystemServerDiscoveryResp_t::serverMask

Definition at line 434 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_UserDescConfResp_t Struct Reference

ZDO_UserDescConfResp_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t nwkAddrOfInterest

Detailed Description

Definition at line 399 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_UserDescConfResp_t::nwkAddrOfInterest

Definition at line 401 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_UserDescReq_t Struct Reference

ZDO_UserDescReq_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t nwkAddrOfInterest

Detailed Description

Definition at line 293 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_UserDescReq_t::nwkAddrOfInterest

Definition at line 295 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_UserDescResp_t Struct Reference

ZDO_UserDescResp_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t nwkAddrOfInterest

Detailed Description

Definition at line 394 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_UserDescResp_t::nwkAddrOfInterest

Definition at line 396 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_UserDescSetReq_t Struct Reference

ZDO_UserDescSetReq_t Struct Reference

#include <zdo.h>

Data Fields

ShortAddr_t nwkAddrOfInterest

Detailed Description

Definition at line 298 of file zdo.h.

Field Documentation

ShortAddr_t ZDO_UserDescSetReq_t::nwkAddrOfInterest

Definition at line 300 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_WakeUpConf_t Struct Reference

ZDO_WakeUpConf_t Struct Reference

#include <zdo.h>

Data Fields

ZDO_Status_t status

Detailed Description

Definition at line 248 of file zdo.h.

Field Documentation

ZDO_Status_t ZDO_WakeUpConf_t::status

Definition at line 250 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_WakeUpReq_t Struct Reference

ZDO_WakeUpReq_t Struct Reference

#include <zdo.h>

Data Fields

ZDO_WakeUpConf_t confirm
void(* ZDO_WakeUpConf )(ZDO_WakeUpConf_t *conf)

Detailed Description

Definition at line 253 of file zdo.h.

Field Documentation

ZDO_WakeUpConf_t ZDO_WakeUpReq_t::confirm

Definition at line 255 of file zdo.h.

void(* ZDO_WakeUpReq_t::ZDO_WakeUpConf)(ZDO_WakeUpConf_t *conf)

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ZdpFrame_t Struct Reference

ZDO_ZdpFrame_t Struct Reference

#include <zdo.h>

Data Fields

uint8_t header [APS_ASDU_OFFSET]
union {
ZDO_ZdpRespFrame_t respPayload
ZDO_ZdpReqFrame_t reqPayload
};

Detailed Description

Definition at line 497 of file zdo.h.

Field Documentation

uint8_t ZDO_ZdpFrame_t::header[APS_ASDU_OFFSET]

Definition at line 500 of file zdo.h.

ZDO_ZdpRespFrame_t ZDO_ZdpFrame_t::respPayload

Definition at line 503 of file zdo.h.

ZDO_ZdpReqFrame_t ZDO_ZdpFrame_t::reqPayload

Definition at line 504 of file zdo.h.

union { ... }

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ZdpReq_t Struct Reference

ZDO_ZdpReq_t Struct Reference

#include <zdo.h>

Data Fields

struct {
void * next
} service
ZDO_ZdpClusterId_t reqCluster
AddrMode_t dstAddrMode
union {
ShortAddr_t dstNwkAddr
ExtAddr_t dstExtAddr
};
ZDO_ZdpFrame_t req
void(* ZDO_ZdpResp )(ZDO_ZdpResp_t *zdpResp)
ZDO_ZdpResp_t resp

Detailed Description

Definition at line 519 of file zdo.h.

Field Documentation

void* ZDO_ZdpReq_t::next

Definition at line 524 of file zdo.h.

struct { ... } ZDO_ZdpReq_t::service

ZDO_ZdpClusterId_t ZDO_ZdpReq_t::reqCluster

Definition at line 528 of file zdo.h.

AddrMode_t ZDO_ZdpReq_t::dstAddrMode

Definition at line 529 of file zdo.h.

ShortAddr_t ZDO_ZdpReq_t::dstNwkAddr

Definition at line 533 of file zdo.h.

ExtAddr_t ZDO_ZdpReq_t::dstExtAddr

Definition at line 534 of file zdo.h.

union { ... }

ZDO_ZdpFrame_t ZDO_ZdpReq_t::req

Definition at line 538 of file zdo.h.

void(* ZDO_ZdpReq_t::ZDO_ZdpResp)(ZDO_ZdpResp_t *zdpResp)

ZDO_ZdpResp_t ZDO_ZdpReq_t::resp

Definition at line 542 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ZdpReqFrame_t Struct Reference

ZDO_ZdpReqFrame_t Struct Reference

#include <zdo.h>

Data Fields

uint8_t seqNum
union {
ZDO_NwkAddrReq_t nwkAddrReq
ZDO_IeeeAddrReq_t ieeeAddrReq
ZDO_NodeDescReq_t nodeDescReq
ZDO_PowerDescReq_t powerDescReq
ZDO_SimpleDescReq_t simpleDescReq
ZDO_DeviceAnnceReq_t deviceAnnce
ZDO_ActiveEPReq_t activeEPReq
ZDO_ComplexDescReq_t complexDescReq
ZDO_UserDescReq_t userDescReq
ZDO_UserDescSetReq_t userDescSetReq
ZDO_SystemServerDiscoveryReq_t systemServerDiscoveryReq
ZDO_MgmtLeaveReq_t mgmtLeaveReq
ZDO_MgmtPermitJoiningReq_t mgmtPermitJoiningReq
ZDO_MgmtNwkUpdateReq_t mgmtNwkUpdateReq
ZDO_MgmtNwkUpdateNotf_t mgmtNwkUpdateNotf
};

Detailed Description

Definition at line 470 of file zdo.h.

Field Documentation

uint8_t ZDO_ZdpReqFrame_t::seqNum

Definition at line 472 of file zdo.h.

ZDO_NwkAddrReq_t ZDO_ZdpReqFrame_t::nwkAddrReq

Definition at line 476 of file zdo.h.

ZDO_IeeeAddrReq_t ZDO_ZdpReqFrame_t::ieeeAddrReq

Definition at line 477 of file zdo.h.

ZDO_NodeDescReq_t ZDO_ZdpReqFrame_t::nodeDescReq

Definition at line 478 of file zdo.h.

ZDO_PowerDescReq_t ZDO_ZdpReqFrame_t::powerDescReq

Definition at line 479 of file zdo.h.

ZDO_SimpleDescReq_t ZDO_ZdpReqFrame_t::simpleDescReq

Definition at line 480 of file zdo.h.

ZDO_DeviceAnnceReq_t ZDO_ZdpReqFrame_t::deviceAnnce

Definition at line 481 of file zdo.h.

ZDO_ActiveEPReq_t ZDO_ZdpReqFrame_t::activeEPReq

Definition at line 482 of file zdo.h.

ZDO_ComplexDescReq_t ZDO_ZdpReqFrame_t::complexDescReq

Definition at line 483 of file zdo.h.

ZDO_UserDescReq_t ZDO_ZdpReqFrame_t::userDescReq

Definition at line 484 of file zdo.h.

ZDO_UserDescSetReq_t ZDO_ZdpReqFrame_t::userDescSetReq

Definition at line 485 of file zdo.h.

ZDO_SystemServerDiscoveryReq_t ZDO_ZdpReqFrame_t::systemServerDiscoveryReq

Definition at line 486 of file zdo.h.

ZDO_MgmtLeaveReq_t ZDO_ZdpReqFrame_t::mgmtLeaveReq

Definition at line 490 of file zdo.h.

ZDO_MgmtPermitJoiningReq_t ZDO_ZdpReqFrame_t::mgmtPermitJoiningReq

Definition at line 491 of file zdo.h.

ZDO_MgmtNwkUpdateReq_t ZDO_ZdpReqFrame_t::mgmtNwkUpdateReq

Definition at line 492 of file zdo.h.

ZDO_MgmtNwkUpdateNotf_t ZDO_ZdpReqFrame_t::mgmtNwkUpdateNotf

Definition at line 493 of file zdo.h.

union { ... }

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ZdpResp_t Struct Reference

ZDO_ZdpResp_t Struct Reference

#include <zdo.h>

Data Fields

AddrMode_t srcAddrMode
union {
ShortAddr_t srcNwkAddr
ExtAddr_t srcExtAddr
};
ZDO_ZdpRespFrame_t respPayload

Detailed Description

Definition at line 508 of file zdo.h.

Field Documentation

AddrMode_t ZDO_ZdpResp_t::srcAddrMode

Definition at line 510 of file zdo.h.

ShortAddr_t ZDO_ZdpResp_t::srcNwkAddr

Definition at line 513 of file zdo.h.

ExtAddr_t ZDO_ZdpResp_t::srcExtAddr

Definition at line 514 of file zdo.h.

union { ... }

ZDO_ZdpRespFrame_t ZDO_ZdpResp_t::respPayload

Definition at line 516 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZDO_ZdpRespFrame_t Struct Reference

ZDO_ZdpRespFrame_t Struct Reference

#include <zdo.h>

Data Fields

uint8_t | seqNum
uint8_t | status
union {
ZDO_NwkAddrResp_t nwkAddrResp
ZDO_IeeeAddrResp_t ieeeAddrResp
ZDO_NodeDescResp_t nodeDescResp
ZDO_PowerDescResp_t powerDescResp
ZDO_SimpleDescResp_t simpleDescResp
ZDO_ComplexDescResp_t complexDescResp
ZDO_UserDescResp_t userDescResp
ZDO_ActiveEPResp_t activeEPResp
ZDO_UserDescConfResp_t userDescConfResp
ZDO_SystemServerDiscoveryResp_t systemServerDiscoveryResp
ZDO_MgmtNwkUpdateNotf_t mgmtNwkUpdateNotf
};

Detailed Description

Definition at line 446 of file zdo.h.

Field Documentation

uint8_t ZDO_ZdpRespFrame_t::seqNum

Definition at line 448 of file zdo.h.

uint8_t ZDO_ZdpRespFrame_t::status

Definition at line 450 of file zdo.h.

ZDO_NwkAddrResp_t ZDO_ZdpRespFrame_t::nwkAddrResp

Definition at line 453 of file zdo.h.

ZDO_IeeeAddrResp_t ZDO_ZdpRespFrame_t::ieeeAddrResp

Definition at line 454 of file zdo.h.

ZDO_NodeDescResp_t ZDO_ZdpRespFrame_t::nodeDescResp

Definition at line 455 of file zdo.h.

ZDO_PowerDescResp_t ZDO_ZdpRespFrame_t::powerDescResp

Definition at line 456 of file zdo.h.

ZDO_SimpleDescResp_t ZDO_ZdpRespFrame_t::simpleDescResp

Definition at line 457 of file zdo.h.

ZDO_ComplexDescResp_t ZDO_ZdpRespFrame_t::complexDescResp

Definition at line 458 of file zdo.h.

ZDO_UserDescResp_t ZDO_ZdpRespFrame_t::userDescResp

Definition at line 459 of file zdo.h.

ZDO_ActiveEPResp_t ZDO_ZdpRespFrame_t::activeEPResp

Definition at line 460 of file zdo.h.

ZDO_UserDescConfResp_t ZDO_ZdpRespFrame_t::userDescConfResp

Definition at line 461 of file zdo.h.

ZDO_SystemServerDiscoveryResp_t ZDO_ZdpRespFrame_t::systemServerDiscoveryResp

Definition at line 462 of file zdo.h.

ZDO_MgmtNwkUpdateNotf_t ZDO_ZdpRespFrame_t::mgmtNwkUpdateNotf

Definition at line 466 of file zdo.h.

union { ... }

The documentation for this struct was generated from the following file:
  • zdo.h


ZigBeeNet Stack Documentation: ZdpSimpleDescriptor_t Struct Reference

ZdpSimpleDescriptor_t Struct Reference

#include <zdo.h>

Data Fields

Endpoint_t | endpoint
ProfileId_t | AppProfileId
uint16_t | AppDeviceId
uint8_t | AppDeviceVersion: 4
uint8_t | Reserved: 4
uint8_t | AppInClustersCount
ClusterId_t | AppInClustersList [MAX_REQUESTED_CLUSTER_NUMBER]
uint8_t | AppOutClustersCount
ClusterId_t | AppOutClustersList [MAX_REQUESTED_CLUSTER_NUMBER]

Detailed Description

Definition at line 411 of file zdo.h.

Field Documentation

Endpoint_t ZdpSimpleDescriptor_t::endpoint

Definition at line 413 of file zdo.h.

ProfileId_t ZdpSimpleDescriptor_t::AppProfileId

Definition at line 414 of file zdo.h.

uint16_t ZdpSimpleDescriptor_t::AppDeviceId

Definition at line 415 of file zdo.h.

uint8_t ZdpSimpleDescriptor_t::AppDeviceVersion

Definition at line 416 of file zdo.h.

uint8_t ZdpSimpleDescriptor_t::Reserved

Definition at line 417 of file zdo.h.

uint8_t ZdpSimpleDescriptor_t::AppInClustersCount

Definition at line 418 of file zdo.h.

ClusterId_t ZdpSimpleDescriptor_t::AppInClustersList[MAX_REQUESTED_CLUSTER_NUMBER]

Definition at line 419 of file zdo.h.

uint8_t ZdpSimpleDescriptor_t::AppOutClustersCount

Definition at line 420 of file zdo.h.

ClusterId_t ZdpSimpleDescriptor_t::AppOutClustersList[MAX_REQUESTED_CLUSTER_NUMBER]

Definition at line 421 of file zdo.h.

The documentation for this struct was generated from the following file:
  • zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • acknowledgedTransmission : APS_TxOptions_t
  • activeChannel : ZDO_StartNetworkConf_t
  • activeEPCount : ZDO_ActiveEPResp_t
  • activeEPList : ZDO_ActiveEPResp_t
  • activeEPReq : ZDO_ZdpReqFrame_t
  • activeEPResp : ZDO_ZdpRespFrame_t
  • address : HAL_EepromParams_t
  • aibAttribute : APS_GetReq_t , APS_SetReq_t
  • aibAttributeLength : APS_GetConf_t , APS_SetReq_t
  • aibAttributeValue : APS_GetConf_t , APS_SetReq_t
  • AppDeviceId : ZdpSimpleDescriptor_t
  • AppDeviceVersion : ZdpSimpleDescriptor_t
  • AppInClustersCount : ZdpSimpleDescriptor_t
  • AppInClustersList : ZdpSimpleDescriptor_t
  • AppOutClustersCount : ZdpSimpleDescriptor_t
  • AppOutClustersList : ZdpSimpleDescriptor_t
  • AppProfileId : ZdpSimpleDescriptor_t
  • APS_DataConf : APS_DataReq_t
  • APS_DataInd : APS_RegisterEndpointReq_t
  • apsBindingTable : APS_AibAttribute_t
  • apscAckWaitDuration : APS_AibPermissionsConfiguration_t
  • apsChannelMask : APS_AibAttribute_t
  • apscInterframeDelay : APS_AibPermissionsConfiguration_t
  • apscMaxDescriptorSize : APS_AibPermissionsConfiguration_t
  • apscMaxFrameRetries : APS_AibPermissionsConfiguration_t
  • apscMaxWindowSize : APS_AibPermissionsConfiguration_t
  • apscMinDuplicateRejectionTableSize : APS_AibPermissionsConfiguration_t
  • apscMinHeaderOverHead : APS_AibPermissionsConfiguration_t
  • apsDesignatedCoordinator : APS_AibAttribute_t
  • apsDeviceKeyPairSet : APS_AibAttribute_t
  • apsGroupTable : APS_AibAttribute_t
  • apsInterframeDelay : APS_AibAttribute_t
  • apsNonmemberRadius : APS_AibAttribute_t
  • apsPermissionsConfiguration : APS_AibAttribute_t
  • apsSecurityTimeOutPeriod : APS_AibAttribute_t
  • apsTrustCenterAddress : APS_AibAttribute_t
  • apsUseExtendedPANID : APS_AibAttribute_t
  • apsUseInsecureJoin : APS_AibAttribute_t
  • asdu : APS_DataInd_t , APS_DataReq_t
  • asduLength : APS_DataReq_t , APS_DataInd_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • length : ZDO_SimpleDescResp_t , HAL_EepromParams_t
  • linkQuality : APS_DataInd_t
  • lqi : ZDO_GetLqiRssi_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • macCapability : ZDO_DeviceAnnceReq_t
  • mgmtLeaveReq : ZDO_ZdpReqFrame_t
  • mgmtNwkUpdateNotf : ZDO_ZdpRespFrame_t , ZDO_ZdpReqFrame_t
  • mgmtNwkUpdateReq : ZDO_ZdpReqFrame_t
  • mgmtPermitJoiningReq : ZDO_ZdpReqFrame_t
  • mode : HAL_UartDescriptor_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • next : APS_DataReq_t , APS_RegisterEndpointReq_t , ZDO_ZdpReq_t
  • nodeAddr : ZDO_GetLqiRssi_t
  • nodeDescReq : ZDO_ZdpReqFrame_t
  • nodeDescResp : ZDO_ZdpRespFrame_t
  • nodeDescriptor : ZDO_NodeDescResp_t
  • noIndication : APS_RegisterEndpointReq_t
  • numAssocDev : ZDO_NwkAddrResp_t , ZDO_IeeeAddrResp_t
  • nwkAddrAssocDevList : ZDO_NwkAddrResp_t , ZDO_IeeeAddrResp_t
  • nwkAddrLocal : ZDO_DeviceAnnceReq_t
  • nwkAddrOfInterest : ZDO_UserDescSetReq_t , ZDO_ComplexDescResp_t , ZDO_IeeeAddrReq_t , ZDO_UserDescConfResp_t , ZDO_ActiveEPReq_t , ZDO_ComplexDescReq_t , ZDO_UserDescResp_t , ZDO_UserDescReq_t , ZDO_PowerDescReq_t , ZDO_SimpleDescResp_t , ZDO_NodeDescReq_t , ZDO_NodeDescResp_t , ZDO_SimpleDescReq_t , ZDO_PowerDescResp_t , ZDO_ActiveEPResp_t
  • nwkAddrRemote : ZDO_NwkAddrResp_t , ZDO_IeeeAddrResp_t
  • nwkAddrReq : ZDO_ZdpReqFrame_t
  • nwkAddrResp : ZDO_ZdpRespFrame_t
  • nwkManagerAddr : ZDO_MgmtNwkUpdateReq_t
  • nwkUpdateId : ZDO_MgmtNwkUpdateReq_t
  • nwkUpdateInf : ZDO_MgmtNwkUpdateNotf_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- z -

  • ZDO_EndToEndAppKeyConf : ZDO_EndToEndAppKeyReq_t
  • ZDO_ResetNetworkConf : ZDO_ResetNetworkReq_t
  • ZDO_SetTxPowerConf : ZDO_SetTxPowerReq_t
  • ZDO_SleepConf : ZDO_SleepReq_t
  • ZDO_StartNetworkConf : ZDO_StartNetworkReq_t
  • ZDO_WakeUpConf : ZDO_WakeUpReq_t
  • ZDO_ZdpResp : ZDO_ZdpReq_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • baudrate : HAL_UartDescriptor_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • childrenCount : ZDO_GetChildrenAddr_t
  • childrenTable : ZDO_GetChildrenAddr_t
  • clusterId : APS_DataInd_t , APS_DataReq_t
  • complexDescReq : ZDO_ZdpReqFrame_t
  • complexDescResp : ZDO_ZdpRespFrame_t
  • confirm : APS_SetReq_t , ZDO_WakeUpReq_t , ZDO_SleepReq_t , APS_GetReq_t , ZDO_EndToEndAppKeyReq_t , APS_DataReq_t , ZDO_SetTxPowerReq_t
  • confParams : ZDO_StartNetworkReq_t , ZDO_ResetNetworkReq_t
  • currentChannel : NetworkInf_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • data : HAL_EepromParams_t
  • dataLength : HAL_UartDescriptor_t
  • deviceAddr : ZDO_EndToEndAppKeyReq_t , ZDO_MgmtLeaveReq_t
  • deviceAnnce : ZDO_ZdpReqFrame_t
  • dstAddress : APS_DataInd_t , APS_DataReq_t
  • dstAddrMode : APS_DataInd_t , ZDO_ZdpReq_t , APS_DataReq_t
  • dstEndpoint : APS_DataReq_t , APS_DataInd_t
  • dstExtAddr : ZDO_ZdpReq_t
  • dstNwkAddr : ZDO_ZdpReq_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • edge : HAL_UartDescriptor_t
  • endpoint : APS_UnregisterEndpointReq_t , ZDO_SimpleDescReq_t , ZdpSimpleDescriptor_t
  • energyValues : EDScan_t
  • extAddr : NodeAddr_t
  • extAddress : APS_Address_t
  • extPANId : ZDO_StartNetworkConf_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • flowControl : HAL_UartDescriptor_t
  • fragmentationPermitted : APS_TxOptions_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • header : ZDO_ZdpFrame_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • ieeeAddrLocal : ZDO_DeviceAnnceReq_t
  • ieeeAddrOfInterest : ZDO_NwkAddrReq_t
  • ieeeAddrRemote : ZDO_IeeeAddrResp_t , ZDO_NwkAddrResp_t
  • ieeeAddrReq : ZDO_ZdpReqFrame_t
  • ieeeAddrResp : ZDO_ZdpRespFrame_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • PANId : ZDO_StartNetworkConf_t
  • panId : NetworkInf_t
  • parentAddr : ZDO_StartNetworkConf_t
  • parentShortAddr : NetworkInf_t
  • parity : HAL_UartDescriptor_t
  • permitDuration : ZDO_MgmtPermitJoiningReq_t
  • powerDescReq : ZDO_ZdpReqFrame_t
  • powerDescResp : ZDO_ZdpRespFrame_t
  • powerDescriptor : ZDO_PowerDescResp_t
  • profileId : APS_DataInd_t , APS_DataReq_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • radius : APS_DataReq_t
  • rejoin : ZDO_MgmtLeaveReq_t
  • removeChildren : ZDO_MgmtLeaveReq_t
  • req : ZDO_ZdpReq_t
  • reqCluster : ZDO_ZdpReq_t
  • reqPayload : ZDO_ZdpFrame_t
  • reqType : ZDO_NwkAddrReq_t , ZDO_IeeeAddrReq_t
  • reserved : APS_RegisterEndpointReq_t , APS_TxOptions_t
  • Reserved : ZdpSimpleDescriptor_t
  • reserved : ZDO_MgmtLeaveReq_t
  • resp : ZDO_ZdpReq_t
  • respPayload : ZDO_ZdpFrame_t , ZDO_ZdpResp_t
  • rssi : ZDO_GetLqiRssi_t
  • rxBuffer : HAL_UartDescriptor_t
  • rxBufferLength : HAL_UartDescriptor_t
  • rxCallback : HAL_UartDescriptor_t
  • rxTime : APS_DataInd_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • scanChannels : ZDO_MgmtNwkUpdateReq_t
  • scanCount : ZDO_MgmtNwkUpdateReq_t
  • scanDuration : ZDO_MgmtNwkUpdateReq_t
  • scannedChannels : EDScan_t
  • scannedChannelsListCount : EDScan_t
  • scanResult : ZDO_MgmtNwkUpdateNotf_t
  • securityEnabledTransmission : APS_TxOptions_t
  • securityStatus : APS_DataInd_t
  • seqNum : ZDO_ZdpRespFrame_t , ZDO_ZdpReqFrame_t
  • serverMask : ZDO_SystemServerDiscoveryResp_t , ZDO_SystemServerDiscoveryReq_t
  • service : APS_DataReq_t , ZDO_ZdpReq_t , APS_RegisterEndpointReq_t
  • shortAddr : NetworkInf_t , NodeAddr_t , ZDO_StartNetworkConf_t
  • shortAddress : APS_Address_t
  • simpleDescReq : ZDO_ZdpReqFrame_t
  • simpleDescResp : ZDO_ZdpRespFrame_t
  • simpleDescriptor : ZDO_SimpleDescResp_t , APS_RegisterEndpointReq_t
  • srcAddress : APS_DataInd_t
  • srcAddrMode : ZDO_ZdpResp_t , APS_DataInd_t
  • srcEndpoint : APS_DataInd_t , APS_DataReq_t
  • srcExtAddr : ZDO_ZdpResp_t
  • srcNwkAddr : ZDO_ZdpResp_t
  • startIndex : ZDO_IeeeAddrResp_t , ZDO_NwkAddrReq_t , ZDO_IeeeAddrReq_t , ZDO_NwkAddrResp_t
  • status : ZDO_SetTxPowerConf_t , ZDO_MgmtNwkUpdateNotf_t , APS_DataConf_t , APS_GetConf_t , ZDO_EndToEndAppKeyConf_t , ZDO_SleepConf_t , ZDO_WakeUpConf_t , ZDO_GetLqiRssi_t , APS_SetConf_t , ZDO_ZdpRespFrame_t , ZDO_StartNetworkConf_t , ZDO_ResetNetworkConf_t , APS_DataInd_t
  • stopbits : HAL_UartDescriptor_t
  • syncMode : HAL_UartDescriptor_t
  • systemServerDiscoveryReq : ZDO_ZdpReqFrame_t
  • systemServerDiscoveryResp : ZDO_ZdpRespFrame_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • tcSignificance : ZDO_MgmtPermitJoiningReq_t
  • totalTransmissions : EDScan_t
  • transmissionsFailures : EDScan_t
  • tty : HAL_UartDescriptor_t
  • txBuffer : HAL_UartDescriptor_t
  • txBufferLength : HAL_UartDescriptor_t
  • txCallback : HAL_UartDescriptor_t
  • txOptions : APS_DataReq_t
  • txPower : ZDO_SetTxPowerReq_t
  • txTime : APS_DataConf_t


ZigBeeNet Stack Documentation: Data Fields

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • useNwkKey : APS_TxOptions_t
  • userDescConfResp : ZDO_ZdpRespFrame_t
  • userDescReq : ZDO_ZdpReqFrame_t
  • userDescResp : ZDO_ZdpRespFrame_t
  • userDescSetReq : ZDO_ZdpReqFrame_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- a -

  • acknowledgedTransmission : APS_TxOptions_t
  • activeChannel : ZDO_StartNetworkConf_t
  • activeEPCount : ZDO_ActiveEPResp_t
  • activeEPList : ZDO_ActiveEPResp_t
  • activeEPReq : ZDO_ZdpReqFrame_t
  • activeEPResp : ZDO_ZdpRespFrame_t
  • address : HAL_EepromParams_t
  • aibAttribute : APS_GetReq_t , APS_SetReq_t
  • aibAttributeLength : APS_GetConf_t , APS_SetReq_t
  • aibAttributeValue : APS_GetConf_t , APS_SetReq_t
  • AppDeviceId : ZdpSimpleDescriptor_t
  • AppDeviceVersion : ZdpSimpleDescriptor_t
  • AppInClustersCount : ZdpSimpleDescriptor_t
  • AppInClustersList : ZdpSimpleDescriptor_t
  • AppOutClustersCount : ZdpSimpleDescriptor_t
  • AppOutClustersList : ZdpSimpleDescriptor_t
  • AppProfileId : ZdpSimpleDescriptor_t
  • APS_DataConf : APS_DataReq_t
  • APS_DataInd : APS_RegisterEndpointReq_t
  • apsBindingTable : APS_AibAttribute_t
  • apscAckWaitDuration : APS_AibPermissionsConfiguration_t
  • apsChannelMask : APS_AibAttribute_t
  • apscInterframeDelay : APS_AibPermissionsConfiguration_t
  • apscMaxDescriptorSize : APS_AibPermissionsConfiguration_t
  • apscMaxFrameRetries : APS_AibPermissionsConfiguration_t
  • apscMaxWindowSize : APS_AibPermissionsConfiguration_t
  • apscMinDuplicateRejectionTableSize : APS_AibPermissionsConfiguration_t
  • apscMinHeaderOverHead : APS_AibPermissionsConfiguration_t
  • apsDesignatedCoordinator : APS_AibAttribute_t
  • apsDeviceKeyPairSet : APS_AibAttribute_t
  • apsGroupTable : APS_AibAttribute_t
  • apsInterframeDelay : APS_AibAttribute_t
  • apsNonmemberRadius : APS_AibAttribute_t
  • apsPermissionsConfiguration : APS_AibAttribute_t
  • apsSecurityTimeOutPeriod : APS_AibAttribute_t
  • apsTrustCenterAddress : APS_AibAttribute_t
  • apsUseExtendedPANID : APS_AibAttribute_t
  • apsUseInsecureJoin : APS_AibAttribute_t
  • asdu : APS_DataInd_t , APS_DataReq_t
  • asduLength : APS_DataReq_t , APS_DataInd_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- l -

  • length : ZDO_SimpleDescResp_t , HAL_EepromParams_t
  • linkQuality : APS_DataInd_t
  • lqi : ZDO_GetLqiRssi_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- m -

  • macCapability : ZDO_DeviceAnnceReq_t
  • mgmtLeaveReq : ZDO_ZdpReqFrame_t
  • mgmtNwkUpdateNotf : ZDO_ZdpRespFrame_t , ZDO_ZdpReqFrame_t
  • mgmtNwkUpdateReq : ZDO_ZdpReqFrame_t
  • mgmtPermitJoiningReq : ZDO_ZdpReqFrame_t
  • mode : HAL_UartDescriptor_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- n -

  • next : APS_DataReq_t , APS_RegisterEndpointReq_t , ZDO_ZdpReq_t
  • nodeAddr : ZDO_GetLqiRssi_t
  • nodeDescReq : ZDO_ZdpReqFrame_t
  • nodeDescResp : ZDO_ZdpRespFrame_t
  • nodeDescriptor : ZDO_NodeDescResp_t
  • noIndication : APS_RegisterEndpointReq_t
  • numAssocDev : ZDO_NwkAddrResp_t , ZDO_IeeeAddrResp_t
  • nwkAddrAssocDevList : ZDO_NwkAddrResp_t , ZDO_IeeeAddrResp_t
  • nwkAddrLocal : ZDO_DeviceAnnceReq_t
  • nwkAddrOfInterest : ZDO_UserDescSetReq_t , ZDO_ComplexDescResp_t , ZDO_IeeeAddrReq_t , ZDO_UserDescConfResp_t , ZDO_ActiveEPReq_t , ZDO_ComplexDescReq_t , ZDO_UserDescResp_t , ZDO_UserDescReq_t , ZDO_PowerDescReq_t , ZDO_SimpleDescResp_t , ZDO_NodeDescReq_t , ZDO_NodeDescResp_t , ZDO_SimpleDescReq_t , ZDO_PowerDescResp_t , ZDO_ActiveEPResp_t
  • nwkAddrRemote : ZDO_NwkAddrResp_t , ZDO_IeeeAddrResp_t
  • nwkAddrReq : ZDO_ZdpReqFrame_t
  • nwkAddrResp : ZDO_ZdpRespFrame_t
  • nwkManagerAddr : ZDO_MgmtNwkUpdateReq_t
  • nwkUpdateId : ZDO_MgmtNwkUpdateReq_t
  • nwkUpdateInf : ZDO_MgmtNwkUpdateNotf_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- z -

  • ZDO_EndToEndAppKeyConf : ZDO_EndToEndAppKeyReq_t
  • ZDO_ResetNetworkConf : ZDO_ResetNetworkReq_t
  • ZDO_SetTxPowerConf : ZDO_SetTxPowerReq_t
  • ZDO_SleepConf : ZDO_SleepReq_t
  • ZDO_StartNetworkConf : ZDO_StartNetworkReq_t
  • ZDO_WakeUpConf : ZDO_WakeUpReq_t
  • ZDO_ZdpResp : ZDO_ZdpReq_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- b -

  • baudrate : HAL_UartDescriptor_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- c -

  • childrenCount : ZDO_GetChildrenAddr_t
  • childrenTable : ZDO_GetChildrenAddr_t
  • clusterId : APS_DataInd_t , APS_DataReq_t
  • complexDescReq : ZDO_ZdpReqFrame_t
  • complexDescResp : ZDO_ZdpRespFrame_t
  • confirm : APS_SetReq_t , ZDO_WakeUpReq_t , ZDO_SleepReq_t , APS_GetReq_t , ZDO_EndToEndAppKeyReq_t , APS_DataReq_t , ZDO_SetTxPowerReq_t
  • confParams : ZDO_StartNetworkReq_t , ZDO_ResetNetworkReq_t
  • currentChannel : NetworkInf_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- d -

  • data : HAL_EepromParams_t
  • dataLength : HAL_UartDescriptor_t
  • deviceAddr : ZDO_EndToEndAppKeyReq_t , ZDO_MgmtLeaveReq_t
  • deviceAnnce : ZDO_ZdpReqFrame_t
  • dstAddress : APS_DataInd_t , APS_DataReq_t
  • dstAddrMode : APS_DataInd_t , ZDO_ZdpReq_t , APS_DataReq_t
  • dstEndpoint : APS_DataReq_t , APS_DataInd_t
  • dstExtAddr : ZDO_ZdpReq_t
  • dstNwkAddr : ZDO_ZdpReq_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- e -

  • edge : HAL_UartDescriptor_t
  • endpoint : APS_UnregisterEndpointReq_t , ZDO_SimpleDescReq_t , ZdpSimpleDescriptor_t
  • energyValues : EDScan_t
  • extAddr : NodeAddr_t
  • extAddress : APS_Address_t
  • extPANId : ZDO_StartNetworkConf_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- f -

  • flowControl : HAL_UartDescriptor_t
  • fragmentationPermitted : APS_TxOptions_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- h -

  • header : ZDO_ZdpFrame_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- i -

  • ieeeAddrLocal : ZDO_DeviceAnnceReq_t
  • ieeeAddrOfInterest : ZDO_NwkAddrReq_t
  • ieeeAddrRemote : ZDO_IeeeAddrResp_t , ZDO_NwkAddrResp_t
  • ieeeAddrReq : ZDO_ZdpReqFrame_t
  • ieeeAddrResp : ZDO_ZdpRespFrame_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- p -

  • PANId : ZDO_StartNetworkConf_t
  • panId : NetworkInf_t
  • parentAddr : ZDO_StartNetworkConf_t
  • parentShortAddr : NetworkInf_t
  • parity : HAL_UartDescriptor_t
  • permitDuration : ZDO_MgmtPermitJoiningReq_t
  • powerDescReq : ZDO_ZdpReqFrame_t
  • powerDescResp : ZDO_ZdpRespFrame_t
  • powerDescriptor : ZDO_PowerDescResp_t
  • profileId : APS_DataInd_t , APS_DataReq_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- r -

  • radius : APS_DataReq_t
  • rejoin : ZDO_MgmtLeaveReq_t
  • removeChildren : ZDO_MgmtLeaveReq_t
  • req : ZDO_ZdpReq_t
  • reqCluster : ZDO_ZdpReq_t
  • reqPayload : ZDO_ZdpFrame_t
  • reqType : ZDO_NwkAddrReq_t , ZDO_IeeeAddrReq_t
  • reserved : APS_RegisterEndpointReq_t , APS_TxOptions_t
  • Reserved : ZdpSimpleDescriptor_t
  • reserved : ZDO_MgmtLeaveReq_t
  • resp : ZDO_ZdpReq_t
  • respPayload : ZDO_ZdpFrame_t , ZDO_ZdpResp_t
  • rssi : ZDO_GetLqiRssi_t
  • rxBuffer : HAL_UartDescriptor_t
  • rxBufferLength : HAL_UartDescriptor_t
  • rxCallback : HAL_UartDescriptor_t
  • rxTime : APS_DataInd_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- s -

  • scanChannels : ZDO_MgmtNwkUpdateReq_t
  • scanCount : ZDO_MgmtNwkUpdateReq_t
  • scanDuration : ZDO_MgmtNwkUpdateReq_t
  • scannedChannels : EDScan_t
  • scannedChannelsListCount : EDScan_t
  • scanResult : ZDO_MgmtNwkUpdateNotf_t
  • securityEnabledTransmission : APS_TxOptions_t
  • securityStatus : APS_DataInd_t
  • seqNum : ZDO_ZdpRespFrame_t , ZDO_ZdpReqFrame_t
  • serverMask : ZDO_SystemServerDiscoveryResp_t , ZDO_SystemServerDiscoveryReq_t
  • service : APS_DataReq_t , ZDO_ZdpReq_t , APS_RegisterEndpointReq_t
  • shortAddr : NetworkInf_t , NodeAddr_t , ZDO_StartNetworkConf_t
  • shortAddress : APS_Address_t
  • simpleDescReq : ZDO_ZdpReqFrame_t
  • simpleDescResp : ZDO_ZdpRespFrame_t
  • simpleDescriptor : ZDO_SimpleDescResp_t , APS_RegisterEndpointReq_t
  • srcAddress : APS_DataInd_t
  • srcAddrMode : ZDO_ZdpResp_t , APS_DataInd_t
  • srcEndpoint : APS_DataInd_t , APS_DataReq_t
  • srcExtAddr : ZDO_ZdpResp_t
  • srcNwkAddr : ZDO_ZdpResp_t
  • startIndex : ZDO_IeeeAddrResp_t , ZDO_NwkAddrReq_t , ZDO_IeeeAddrReq_t , ZDO_NwkAddrResp_t
  • status : ZDO_SetTxPowerConf_t , ZDO_MgmtNwkUpdateNotf_t , APS_DataConf_t , APS_GetConf_t , ZDO_EndToEndAppKeyConf_t , ZDO_SleepConf_t , ZDO_WakeUpConf_t , ZDO_GetLqiRssi_t , APS_SetConf_t , ZDO_ZdpRespFrame_t , ZDO_StartNetworkConf_t , ZDO_ResetNetworkConf_t , APS_DataInd_t
  • stopbits : HAL_UartDescriptor_t
  • syncMode : HAL_UartDescriptor_t
  • systemServerDiscoveryReq : ZDO_ZdpReqFrame_t
  • systemServerDiscoveryResp : ZDO_ZdpRespFrame_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- t -

  • tcSignificance : ZDO_MgmtPermitJoiningReq_t
  • totalTransmissions : EDScan_t
  • transmissionsFailures : EDScan_t
  • tty : HAL_UartDescriptor_t
  • txBuffer : HAL_UartDescriptor_t
  • txBufferLength : HAL_UartDescriptor_t
  • txCallback : HAL_UartDescriptor_t
  • txOptions : APS_DataReq_t
  • txPower : ZDO_SetTxPowerReq_t
  • txTime : APS_DataConf_t


ZigBeeNet Stack Documentation: Data Fields - Variables

  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- u -

  • useNwkKey : APS_TxOptions_t
  • userDescConfResp : ZDO_ZdpRespFrame_t
  • userDescReq : ZDO_ZdpReqFrame_t
  • userDescResp : ZDO_ZdpRespFrame_t
  • userDescSetReq : ZDO_ZdpReqFrame_t


ZigBeeNet Stack Documentation: File Index

  • File List
  • Globals

ZigBeeNet Stack Documentation File List

Here is a list of all files with brief descriptions:
adc.h [code] | Description of the ADC interface
appTimer.h [code] | Declarations of the appTimer interface
aps.h [code] | The header file describes the public APS interface
atomic.h [code] | Header file defines the defines for working with atomic sections
buttons.h [code] | Declaration of buttons interface
configServer.h [code] | The header file describes the public ConfigServer interface
eeprom.h [code] | Provides access to EEPROM
i2cPacket.h [code] | Declaration of the i2cPacket interface
irq.h [code] | Declaration of the IRQ interface
leds.h [code] | Declaration of leds interface
pdsDataServer.h [code] | The header file describes the interface of Persistence Data Server
resetReason.h [code] | Declaration of the reset reason interface
sensors.h [code] | Declarations of sensor types and sensors interface
sleepTimer.h [code] | Declarations of sleepTimer interface
sliders.h [code] | Interface of sliders
spi.h [code] | Declaration of USART SPI mode, hardware-independent module
taskManager.h [code] | The header file describes the public stack Task Manager interface
uart.h [code] | Declaration of the uart interface
uid.h [code] | Declaration of the UID interface
w1.h [code] | Declaration of the 1-Wire interface
wdtCtrl.h [code] | Declaration of the WDT interface
zdo.h [code] | The header file describes the public ZDO interface
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: adc.h File Reference

  • File List
  • Globals

adc.h File Reference

Description of the ADC interface. More...

Go to the source code of this file.

Functions

int | HAL_OpenAdc (HAL_AdcDivisionFactor_t factor, void(*callback)(uint16_t data))
Opens the ADC to make the measurement on the ADC channel.
int | HAL_ReadAdc (uint8_t channel)
Starts ADC with the parameters defined in HAL_OpenAdc.
int | HAL_CloseAdc ()
Closes the ADC.

Detailed Description

Description of the ADC interface.

Definition in file adc.h.

Function Documentation

int HAL_CloseAdc ( )

Closes the ADC.

Returns:
-1 - the module was not open.
0 - success.

int HAL_OpenAdc | ( | HAL_AdcDivisionFactor_t | factor,
 |  | void(*)(uint16_t data) | callback
 | ) |  |

Opens the ADC to make the measurement on the ADC channel.

Parameters:
[in] factor - division factor for the input clock frequency. Must be chosen from:
ADC_DIVISION_FACTOR_2
ADC_DIVISION_FACTOR_4
ADC_DIVISION_FACTOR_8
ADC_DIVISION_FACTOR_16
ADC_DIVISION_FACTOR_32
ADC_DIVISION_FACTOR_64
ADC_DIVISION_FACTOR_128
[in] callback - pointer to the function that will notify about measurement completion.
Returns:
-1 - ADC is busy.
0 - success.

int HAL_ReadAdc ( uint8_t channel )

Starts ADC with the parameters defined in HAL_OpenAdc.

Parameters:
[in] channel - number of ADC channel. Must be chosen from:
HAL_ADC_CHANNEL0
HAL_ADC_CHANNEL1
HAL_ADC_CHANNEL2
HAL_ADC_CHANNEL3
Returns:
-1 - unable to open ADC (unsupported channel number).
0 - success.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: adc.h Source File

  • File List
  • Globals

adc.h

Go to the documentation of this file.
00001
00010 #ifndef ADC_H_
00011 #define ADC_H_
00012
00013 // \cond
00014 #include <halAdc.h>
00015
00016 #define HAL_NUMBER_ADC_CHANNELS 4
00017
00018 #define HAL_ADC_CHANNEL0 0
00019 #define HAL_ADC_CHANNEL1 1
00020 #define HAL_ADC_CHANNEL2 2
00021 #define HAL_ADC_CHANNEL3 3
00022
00023 typedef enum
00024 {
00025   ADC_DIVISION_FACTOR_2 =   ((0 << ADPS2) | (0 << ADPS1) | (1 << ADPS0)),
00026   ADC_DIVISION_FACTOR_4 =   ((0 << ADPS2) | (1 << ADPS1) | (0 << ADPS0)),
00027   ADC_DIVISION_FACTOR_8 =   ((0 << ADPS2) | (1 << ADPS1) | (1 << ADPS0)),
00028   ADC_DIVISION_FACTOR_16 =  ((1 << ADPS2) | (0 << ADPS1) | (0 << ADPS0)),
00029   ADC_DIVISION_FACTOR_32 =  ((1 << ADPS2) | (0 << ADPS1) | (1 << ADPS0)),
00030   ADC_DIVISION_FACTOR_64 =  ((1 << ADPS2) | (1 << ADPS1) | (0 << ADPS0)),
00031   ADC_DIVISION_FACTOR_128 = ((1 << ADPS2) | (1 << ADPS1) | (1 << ADPS0))
00032 }HAL_AdcDivisionFactor_t;
00033 // \endcond
00034
00035 /**************************************************************************/
00052 int HAL_OpenAdc(HAL_AdcDivisionFactor_t factor , void (*callback)(uint16_t data));
00053
00054
00055 /**************************************************************************/
00068 int HAL_ReadAdc(uint8_t channel);
00069
00070 /**************************************************************************/
00077 int HAL_CloseAdc();
00078
00079 #endif
00080 // eof adc.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: appTimer.h File Reference

  • File List
  • Globals

appTimer.h File Reference

Declarations of the appTimer interface. More...

#include <halAppClock.h>
#include <timer.h>

Go to the source code of this file.

Typedefs

typedef Timer_t | HAL_AppTimer_t
fields of structure:
uint32_t interval - timer firing interval. Interval must be more than 10 ms.(set by user)
TimerMode_t mode - timer work mode (set by user). Must be chosen from:
TIMER_REPEAT_MODE
TIMER_ONE_SHOT_MODE
void (*callback)() - pointer to timer callback function (set by user).

Functions

INLINE uint32_t | HAL_GetSystemTime (void)
Get system time.
int | HAL_StartAppTimer (HAL_AppTimer_t *appTimer)
Starts to count an interval (starts user timer).
int | HAL_StopAppTimer (HAL_AppTimer_t *appTimer)
Stops the user timer.

Detailed Description

Declarations of the appTimer interface.

Definition in file appTimer.h.

Typedef Documentation

typedef Timer_t HAL_AppTimer_t

fields of structure:
uint32_t interval - timer firing interval. Interval must be more than 10 ms.(set by user)
TimerMode_t mode - timer work mode (set by user). Must be chosen from:
TIMER_REPEAT_MODE
TIMER_ONE_SHOT_MODE
void (*callback)() - pointer to timer callback function (set by user).

Definition at line 41 of file appTimer.h.

Function Documentation

INLINE uint32_t HAL_GetSystemTime ( void )

Get system time.

Returns:
time since power up in milliseconds.

Definition at line 30 of file appTimer.h.

int HAL_StartAppTimer ( HAL_AppTimer_t * appTimer )

Starts to count an interval (starts user timer).

Parameters:
[in] appTimer - pointer to the timer structure (HAL_AppTimer_t is typedef Timer_t)
Returns:
-1 - pointer is NULL 0 - success

int HAL_StopAppTimer ( HAL_AppTimer_t * appTimer )

Stops the user timer.

Parameters:
[in] appTimer - pointer to the timer structure.
Returns:
-1 - there is no appTimer started or pointer is NULL 0 - success

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: appTimer.h Source File

  • File List
  • Globals

appTimer.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #ifndef APPTIMER_H_
00014 #define APPTIMER_H_
00015
00016 // \cond
00017 #include <inttypes.h>
00018 #include <halAppClock.h>
00019 #include <timer.h>
00020 #define halInitAppTimer() halStartAppClock()
00021
00022 extern uint32_t halSystemTime;
00023 // \endcond
00024
00025 /**************************************************************************/
00031 INLINE uint32_t HAL_GetSystemTime(void)
00032 {
00033   return halSystemTime;
00034 }
00035
00042 typedef Timer_t HAL_AppTimer_t;
00043
00044 /**************************************************************************/
00054 int HAL_StartAppTimer(HAL_AppTimer_t *appTimer);
00055
00056 /**************************************************************************/
00066 int HAL_StopAppTimer(HAL_AppTimer_t *appTimer);
00067
00068 #endif
00069 //eof appTimer.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: aps.h File Reference

  • File List
  • Globals

aps.h File Reference

The header file describes the public APS interface. More...

#include <types.h>
#include <nwk.h>
#include <appFramework.h>
#include <macAddr.h>

Go to the source code of this file.

Data Structures

union | APS_Address_t
Common APS Address type. More...
struct | APS_AibPermissionsConfiguration_t
APS SubLayer Constants. More...
union | APS_AibAttribute_t
Types of parameters which can be set to the APS AIB. More...
struct | APS_DataConf_t
Parameters structure of the APS_DataConf() function. The APSDE-DATA.confirm primitive. More...
struct | APS_TxOptions_t
Describes the options of data transmission. More...
struct | APS_DataReq_t
Parameters structure of the APS_DataReq() function. The APSDE-DATA.request primitive. More...
struct | APS_DataInd_t
Parameters structure of the APS_DataInd() function The function is determined by certain End Point. The APSDE-DATA.indication primitive. More...
struct | APS_GetConf_t
Parameters structure of the APS_GetConf() function. The APSME-GET.confirm primitive. More...
struct | APS_GetReq_t
Parameters structure of the APS_GetReq() function. The APSME-GET.request primitive. More...
struct | APS_SetConf_t
Parameters structure of the APS_SetConf() function The APSME-SET.confirm primitive. More...
struct | APS_SetReq_t
Parameters structure of the APS_SetReq() function The APSME-SET.request primitive. More...
struct | APS_RegisterEndpointReq_t
Parameters structure of the APS_RegisterEndpointReq() function. APSME-REGISTER-ENDPOINT.request primitive. More...
struct | APS_UnregisterEndpointReq_t
Parameters structure of the APS_UnregisterEndpointReq() function. APSME-UNREGISTER-ENDPOINT.request primitive. More...

Defines

#define | APS_MAX_DATA_FRAME_HEADER_LENGTH 12
#define | APS_MAX_DATA_FRAME_FOOTER_LENGTH 0
#define | APS_AFFIX_LENGTH (APS_MAX_DATA_FRAME_HEADER_LENGTH + APS_MAX_DATA_FRAME_FOOTER_LENGTH + NWK_AFFIX_LENGTH)
#define | APS_MAX_ASDU_SIZE (NWK_MAX_NSDU_SIZE - APS_MAX_DATA_FRAME_HEADER_LENGTH - APS_MAX_DATA_FRAME_FOOTER_LENGTH)
#define | APS_ASDU_OFFSET (NWK_NSDU_OFFSET + APS_MAX_DATA_FRAME_HEADER_LENGTH)
#define | APS_BROADCAST_ENDPOINT 0xff
#define | APS_ZDO_ENDPOINT 0x00
#define | APS_MIN_USER_ENDPOINT 0x01
#define | APS_MAX_USER_ENDPOINT 0xf0
#define | APS_MIN_RESERVED_ENDPOINT 0xf1
#define | APS_MAX_RESERVED_ENDPOINT 0xfe
#define | APS_MAX_UNICAST_SHORT_ADDRESS 0xfff7

Enumerations

enum | APS_AddrMode_t { APS_NO_ADDRESS = 0x00, APS_SHORT_ADDRESS = 0x02, APS_EXT_ADDRESS = 0x03 }
APS addressing modes. More...
enum APS_Status_t {
APS_SUCCESS_STATUS = 0x00, APS_ASDU_TOO_LONG_STATUS = 0xa0, APS_DEFRAG_DEFERRED_STATUS = 0xa1, APS_DEFRAG_UNSUPPORTED_STATUS = 0xa2,
APS_ILLEGAL_REQUEST_STATUS = 0xa3, APS_INVALID_BINDING_STATUS = 0xa4, APS_INVALID_GROUP_STATUS = 0xa5, APS_INVALID_PARAMETER_STATUS = 0xa6,
APS_NO_ACK_STATUS = 0xa7, APS_NO_BOUND_DEVICE_STATUS = 0xa8, APS_NO_SHORT_ADDRESS_STATUS = 0xa9, APS_NOT_SUPPORTED_STATUS = 0xaa,
APS_SECURED_LINK_KEY_STATUS = 0xab, APS_SECURED_NWK_KEY_STATUS = 0xac, APS_SECURITY_FAIL_STATUS = 0xad, APS_TABLE_FULL_STATUS = 0xae,
APS_UNSECURED_STATUS = 0xaf, APS_UNSUPPORTED_ATTRIBUTE_STATUS = 0xb0, APS_NOT_INDICATED_STATUS = 0xb1
}
APS status values. More...
enum APS_AibAttributeId_t {
APS_AIB_BINDING_TABLE = 0xc1, APS_AIB_DESIGNATED_COORDINATOR = 0xc2, APS_AIB_CHANNEL_MASK = 0xc3, APS_AIB_USE_EXTENDED_PANID = 0xc4,
APS_AIB_GROUP_TABLE = 0xc5, APS_AIB_NONMEMBER_RADIUS = 0xc6, APS_AIB_PERMISSIONS_CONFIGURATION = 0xc7, APS_AIB_USE_INSECURE_JOIN = 0xc8,
APS_AIB_INTERFRAME_DELAY = 0xc9, APS_AIB_DEVICE_KEY_PAIR_SET = 0xaa, APS_AIB_TRUST_CENTER_ADDRESS = 0xab, APS_AIB_SECURITY_TIME_OUT_PERIOD = 0xac
}
APS Information base attributes IDs. More...

Functions

void | APS_GetReq (APS_GetReq_t *req)
Gets a parameter from AIB.
void | APS_SetReq (APS_SetReq_t *req)
Sets a parameter to AIB.
void | APS_RegisterEndpointReq (APS_RegisterEndpointReq_t *req)
Registers endpoint to APS.
void | APS_UnregisterEndpointReq (APS_UnregisterEndpointReq_t *req)
Unregisters endPoint from APS.
APS_RegisterEndpointReq_t * | APS_GetEndpointList (void)
Returns the pointer to APS EndPointList.
void | APS_StopEndpointIndication (Endpoint_t endpoint)
Stops APS Data indications to specific endpoint number.
void | APS_ResumeEndpointIndication (Endpoint_t endpoint)
Resumes APS Data indications to specific endpoint number.

Detailed Description

The header file describes the public APS interface.

aps.h

The file describes the public interface and types of APS

Definition in file aps.h.

Define Documentation

#define APS_AFFIX_LENGTH (APS_MAX_DATA_FRAME_HEADER_LENGTH + APS_MAX_DATA_FRAME_FOOTER_LENGTH + NWK_AFFIX_LENGTH)

Definition at line 64 of file aps.h.

#define APS_ASDU_OFFSET (NWK_NSDU_OFFSET + APS_MAX_DATA_FRAME_HEADER_LENGTH)

Definition at line 68 of file aps.h.

#define APS_BROADCAST_ENDPOINT 0xff

Definition at line 77 of file aps.h.

#define APS_MAX_ASDU_SIZE (NWK_MAX_NSDU_SIZE - APS_MAX_DATA_FRAME_HEADER_LENGTH - APS_MAX_DATA_FRAME_FOOTER_LENGTH)

Definition at line 66 of file aps.h.

#define APS_MAX_DATA_FRAME_FOOTER_LENGTH 0

Definition at line 55 of file aps.h.

#define APS_MAX_DATA_FRAME_HEADER_LENGTH 12

Definition at line 52 of file aps.h.

#define APS_MAX_RESERVED_ENDPOINT 0xfe

Definition at line 88 of file aps.h.

#define APS_MAX_UNICAST_SHORT_ADDRESS 0xfff7

Definition at line 95 of file aps.h.

#define APS_MAX_USER_ENDPOINT 0xf0

Definition at line 84 of file aps.h.

#define APS_MIN_RESERVED_ENDPOINT 0xf1

Definition at line 87 of file aps.h.

#define APS_MIN_USER_ENDPOINT 0x01

Definition at line 83 of file aps.h.

#define APS_ZDO_ENDPOINT 0x00

Definition at line 80 of file aps.h.

Enumeration Type Documentation

enum APS_AddrMode_t

APS addressing modes.

Address mode is used in some of APS primitives

Defines APS addressing modes used in some standard primitives

Enumerator:
APS_NO_ADDRESS | Indirect addressing mode via binding future.
APS_SHORT_ADDRESS | Unicast addressing mode by 16-bit network address.
APS_EXT_ADDRESS | Unicast addressing mode by 64-bit IEEE address.

Definition at line 132 of file aps.h.

enum APS_AibAttributeId_t

APS Information base attributes IDs.

AIB Attribute's ID definition

APS Information base attribute IDs used for AIB management with standard AIB maintenance primitives

Enumerator:
APS_AIB_BINDING_TABLE | apsBindingTable
APS_AIB_DESIGNATED_COORDINATOR | apsDesignatedCoordinator
APS_AIB_CHANNEL_MASK | apsChannelMask
APS_AIB_USE_EXTENDED_PANID | apsUseExtendedPANID
APS_AIB_GROUP_TABLE | apsGroupTable
APS_AIB_NONMEMBER_RADIUS | apsNonmemberRadius
APS_AIB_PERMISSIONS_CONFIGURATION | apsPermissionsConfiguration
APS_AIB_USE_INSECURE_JOIN | apsUseInsecureJoin
APS_AIB_INTERFRAME_DELAY | apsInterframeDelay
APS_AIB_DEVICE_KEY_PAIR_SET | apsDeviceKeyPairSet
APS_AIB_TRUST_CENTER_ADDRESS | apsTrustCenterAddress
APS_AIB_SECURITY_TIME_OUT_PERIOD | apsSecurityTimeOutPeriod

Definition at line 209 of file aps.h.

enum APS_Status_t

APS status values.

Status values in some of the APS primitives

APS status values used in the most part of standard primives except for the security service primitives where APS_SecurityStatus_t is used instead

Enumerator:
APS_SUCCESS_STATUS | SUCCESS.
APS_ASDU_TOO_LONG_STATUS | ASDU_TOO_LONG.
APS_DEFRAG_DEFERRED_STATUS | DEFRAG_DEFERRED.
APS_DEFRAG_UNSUPPORTED_STATUS | DEFRAG_UNSUPPORTED.
APS_ILLEGAL_REQUEST_STATUS | ILLEGAL_REQUEST.
APS_INVALID_BINDING_STATUS | INVALID_BINDING.
APS_INVALID_GROUP_STATUS | INVALID_GROUP.
APS_INVALID_PARAMETER_STATUS | INVALID_PARAMETER.
APS_NO_ACK_STATUS | NO_ACK.
APS_NO_BOUND_DEVICE_STATUS | NO_BOUND_DEVICE.
APS_NO_SHORT_ADDRESS_STATUS | NO_SHORT_ADDRESS.
APS_NOT_SUPPORTED_STATUS | NOT_SUPPORTED.
APS_SECURED_LINK_KEY_STATUS | SECURED_LINK_KEY.
APS_SECURED_NWK_KEY_STATUS | SECURED_NWK_KEY.
APS_SECURITY_FAIL_STATUS | SECURITY_FAIL.
APS_TABLE_FULL_STATUS | TABLE_FULL.
APS_UNSECURED_STATUS | UNSECURED.
APS_UNSUPPORTED_ATTRIBUTE_STATUS | UNSUPPORTED_ATTRIBUTE.
APS_NOT_INDICATED_STATUS | NOT_INDICATED (nonstandard status value).

Definition at line 151 of file aps.h.

Function Documentation

APS_RegisterEndpointReq_t* APS_GetEndpointList ( void )

Returns the pointer to APS EndPointList.

Parameters:
[in] None.
Returns:
Valid APS EndpointList pointer or NULL if there are no registered endpoints.

void APS_GetReq ( APS_GetReq_t * req )

Gets a parameter from AIB.

Parameters:
[in] req The APSME-GET.request (APS_GetReq_t) primitive pointer.
Returns:
None.

void APS_RegisterEndpointReq ( APS_RegisterEndpointReq_t * req )

Registers endpoint to APS.

Parameters:
[in] req The register endpoint primitive pointer.
Returns:
None.

void APS_ResumeEndpointIndication ( Endpoint_t endpoint )

Resumes APS Data indications to specific endpoint number.

Parameters:
[in] endpoint The registered endpoint number. The 0xff special value means all registered endpoints.
Returns:
None.

void APS_SetReq ( APS_SetReq_t * req )

Sets a parameter to AIB.

Function returns the result of transaction via callback call with confirm (APS_SetConf_t) primitive pointer as parameter

Parameters:
[in] req The APSME-SET.request (APS_SetReq_t) primitive pointer.
Returns:
None.

void APS_StopEndpointIndication ( Endpoint_t endpoint )

Stops APS Data indications to specific endpoint number.

Parameters:
[in] endpoint The registered endpoint number. The 0xff special value means all registered endpoints.
Returns:
None.

void APS_UnregisterEndpointReq ( APS_UnregisterEndpointReq_t * req )

Unregisters endPoint from APS.

Parameters:
[in] req The unregister endpoint primitive pointer.
Returns:
None.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: aps.h Source File

  • File List
  • Globals

aps.h

Go to the documentation of this file.
00001 /*************************************************************************/
00017 #ifndef _APS_H
00018 #define _APS_H
00019
00020 /******************************************************************************
00021                    Includes section
00022 ******************************************************************************/
00023 #include <types.h>
00024 #include <nwk.h>
00025 #include <appFramework.h>
00026 #include <macAddr.h>
00027
00028
00029 /******************************************************************************
00030                    Define(s) section
00031 ******************************************************************************/
00032
00033 // \cond internal
00034 #ifndef APS_MAX_TRANSMISSION_WINDOW_SIZE
00035 #define APS_MAX_TRANSMISSION_WINDOW_SIZE        3
00036 #endif
00037 // \endcond
00038
00039 // \cond internal
00040 #ifndef APS_MAX_BLOCKS_AMOUNT
00041 #define APS_MAX_BLOCKS_AMOUNT                   3
00042 #endif
00043 // \endcond
00044
00045
00046
00047 /*****************************************************************************
00048   APDU Frame
00049 *****************************************************************************/
00050 //APS APDU Max Header size
00051 #ifndef _HIGH_SECURITY_
00052 #define APS_MAX_DATA_FRAME_HEADER_LENGTH  12
00053
00054 //APS APDU Max Footer size
00055 #define APS_MAX_DATA_FRAME_FOOTER_LENGTH  0
00056 #else
00057 #define APS_MAX_DATA_FRAME_HEADER_LENGTH  (12 + 6) /*6 bytes - auxiliary header*/
00058
00059 //APS APDU Max Footer size
00060 #define APS_MAX_DATA_FRAME_FOOTER_LENGTH  8        /*8 bytes - Message Integrity Code (MIC)*/
00061 #endif
00062
00063
00064 #define APS_AFFIX_LENGTH                  (APS_MAX_DATA_FRAME_HEADER_LENGTH + APS_MAX_DATA_FRAME_FOOTER_LENGTH + NWK_AFFIX_LENGTH)
00065
00066 #define APS_MAX_ASDU_SIZE                 (NWK_MAX_NSDU_SIZE - APS_MAX_DATA_FRAME_HEADER_LENGTH - APS_MAX_DATA_FRAME_FOOTER_LENGTH)
00067
00068 #define APS_ASDU_OFFSET                   (NWK_NSDU_OFFSET + APS_MAX_DATA_FRAME_HEADER_LENGTH)
00069
00070
00071
00072 /*****************************************************************************
00073   APS endpoints defines
00074 *****************************************************************************/
00075
00076 //APS Broadcast Endpoint
00077 #define APS_BROADCAST_ENDPOINT      0xff
00078
00079 //ZDO Endpoint
00080 #define APS_ZDO_ENDPOINT            0x00
00081
00082 //User endpoints
00083 #define APS_MIN_USER_ENDPOINT       0x01
00084 #define APS_MAX_USER_ENDPOINT       0xf0
00085
00086 //Reserved endpoints
00087 #define APS_MIN_RESERVED_ENDPOINT   0xf1
00088 #define APS_MAX_RESERVED_ENDPOINT   0xfe
00089 //============================================================================
00090
00091
00092 /*****************************************************************************
00093   APS short address defines
00094 *****************************************************************************/
00095 #define APS_MAX_UNICAST_SHORT_ADDRESS     0xfff7
00096
00097
00098
00099 /******************************************************************************
00100                    Types section
00101 ******************************************************************************/
00102
00103
00104 /*****************************************************************************
00105   Special APS Level data types definition
00106 *****************************************************************************/
00107
00108 /*************************************************************************/
00114 typedef union
00115 {
00116   ShortAddr_t shortAddress;
00117 #ifdef _APS_MULTICAST_
00118   GroupAddr_t groupAddress;
00119 #endif                            //
00120   ExtAddr_t extAddress;
00121 } APS_Address_t;
00122
00123
00124
00125 /*************************************************************************/
00132 typedef enum
00133 {
00134   APS_NO_ADDRESS                          = 0x00,
00135 #ifdef _APS_MULTICAST_
00136   APS_GROUP_ADDRESS                       = 0x01,
00137 #endif
00138   APS_SHORT_ADDRESS                       = 0x02,
00139   APS_EXT_ADDRESS                         = 0x03
00140 } APS_AddrMode_t;
00141
00142 /*************************************************************************/
00151 typedef enum
00152 {
00153   APS_SUCCESS_STATUS                      = 0x00,
00154   APS_ASDU_TOO_LONG_STATUS                = 0xa0,
00155   APS_DEFRAG_DEFERRED_STATUS              = 0xa1,
00156   APS_DEFRAG_UNSUPPORTED_STATUS           = 0xa2,
00157   APS_ILLEGAL_REQUEST_STATUS              = 0xa3,
00158   APS_INVALID_BINDING_STATUS              = 0xa4,
00159   APS_INVALID_GROUP_STATUS                = 0xa5,
00160   APS_INVALID_PARAMETER_STATUS            = 0xa6,
00161   APS_NO_ACK_STATUS                       = 0xa7,
00162   APS_NO_BOUND_DEVICE_STATUS              = 0xa8,
00163   APS_NO_SHORT_ADDRESS_STATUS             = 0xa9,
00164   APS_NOT_SUPPORTED_STATUS                = 0xaa,
00165   APS_SECURED_LINK_KEY_STATUS             = 0xab,
00166   APS_SECURED_NWK_KEY_STATUS              = 0xac,
00167   APS_SECURITY_FAIL_STATUS                = 0xad,
00168   APS_TABLE_FULL_STATUS                   = 0xae,
00169   APS_UNSECURED_STATUS                    = 0xaf,
00170   APS_UNSUPPORTED_ATTRIBUTE_STATUS        = 0xb0,
00171
00172   //Proprietary status values
00173   APS_NOT_INDICATED_STATUS                = 0xb1
00174 } APS_Status_t;
00175
00176 #ifdef _SECURITY_
00177 /*************************************************************************/
00186 typedef enum
00187 {
00188   APS_SKKE_SUCCESS_STATUS             = 0x00,
00189   APS_SKKE_INVALID_PARAMETER_STATUS   = 0x01,
00190   APS_SKKE_NO_MASTER_KEY_STATUS       = 0x02,
00191   APS_SKKE_INVALID_CHALLENGE_STATUS   = 0x03,
00192   APS_SKKE_INVALID_SKG_STATUS         = 0x04,
00193   APS_SKKE_INVALID_MAC_STATUS         = 0x05,
00194   APS_SKKE_INVALID_KEY_STATUS         = 0x06,
00195   APS_SKKE_TIMEOUT_STATUS             = 0x07,
00196   APS_SKKE_BAD_FRAME_STATUS           = 0x08,
00197 } APS_SkkeStatus_t;
00198 #endif //#ifdef _SECURITY_
00199
00200 /*************************************************************************/
00209 typedef enum
00210 {
00211   //AIB standard attributes
00212   APS_AIB_BINDING_TABLE                   = 0xc1,
00213   APS_AIB_DESIGNATED_COORDINATOR          = 0xc2,
00214   APS_AIB_CHANNEL_MASK                    = 0xc3,
00215   APS_AIB_USE_EXTENDED_PANID              = 0xc4,
00216   APS_AIB_GROUP_TABLE                     = 0xc5,
00217   APS_AIB_NONMEMBER_RADIUS                = 0xc6,
00218   APS_AIB_PERMISSIONS_CONFIGURATION       = 0xc7,
00219   APS_AIB_USE_INSECURE_JOIN               = 0xc8,
00220   APS_AIB_INTERFRAME_DELAY                = 0xc9,
00221
00222   //AIB security attributes ID
00223   APS_AIB_DEVICE_KEY_PAIR_SET             = 0xaa,
00224   APS_AIB_TRUST_CENTER_ADDRESS            = 0xab,
00225   APS_AIB_SECURITY_TIME_OUT_PERIOD        = 0xac
00226 } APS_AibAttributeId_t;
00227
00228 /*************************************************************************/
00236 typedef struct
00237 {
00238   uint8_t   apscMaxDescriptorSize;
00239   uint8_t   apscMaxFrameRetries;
00240   uint32_t  apscAckWaitDuration;
00241   uint8_t   apscMinDuplicateRejectionTableSize;
00242   uint8_t   apscMaxWindowSize;
00243   uint16_t  apscInterframeDelay;
00244   uint8_t   apscMinHeaderOverHead;
00245 } PACK APS_AibPermissionsConfiguration_t;
00246
00247
00248
00249 /*****************************************************************************
00250   APS Group Table entry type
00251 *****************************************************************************/
00253 typedef struct
00254 {
00255   bool busy;
00256   GroupAddr_t groupAddr;              //Group address
00257   Endpoint_t endpoints[1];            //endpoints (group members)
00258 } PACK APS_GroupTableEntry_t;
00260
00261 /*****************************************************************************
00262   APS Group Table type
00263 *****************************************************************************/
00265 typedef struct
00266 {
00267   uint8_t   groupsAmount;             //Table size in cells (amount of entries)
00268   uint8_t   endpointsAmount;          //Maximum amount of group members
00269                                       //(positive value)
00270   uint16_t  entrySizeof;              //Entry size in bytes
00271   APS_GroupTableEntry_t *entries;     //Table entries buffer pointer
00272 } PACK APS_GroupTable_t;
00274
00275 /*************************************************************************/
00284 typedef union
00285 {
00286   //AIB standard attributes
00287
00288   void      *apsBindingTable;
00289   bool      apsDesignatedCoordinator;
00290   uint32_t  apsChannelMask;
00291   uint64_t  apsUseExtendedPANID;
00292   APS_GroupTable_t *apsGroupTable;
00293   uint8_t   apsNonmemberRadius;
00294
00296   APS_AibPermissionsConfiguration_t *apsPermissionsConfiguration;
00297
00298   bool      apsUseInsecureJoin;
00299   uint16_t  apsInterframeDelay;
00300
00301   //AIB security attributes
00302   void      *apsDeviceKeyPairSet;
00303   uint64_t  apsTrustCenterAddress;
00304   uint16_t  apsSecurityTimeOutPeriod;
00305 } APS_AibAttribute_t;
00306
00307
00308
00309 /*****************************************************************************
00310   APSDE Entity Primitives
00311 *****************************************************************************/
00312
00313 /*************************************************************************/
00318 typedef struct
00319 {
00320   //Standard fields
00321   //APS_AddrMode_t dstAddrMode;
00322   //APS_Address_t dstAddress;
00323   //Endpoint_t dstEndpoint;
00324   //Endpoint_t srcEndpoint;
00325   APS_Status_t status;
00326
00327
00328   uint32_t txTime;
00329
00330 } PACK APS_DataConf_t;
00331
00332
00333 /*************************************************************************/
00337 typedef struct
00338 {
00339   uint8_t   securityEnabledTransmission   :1;
00340   uint8_t   useNwkKey                     :1;
00341   uint8_t   acknowledgedTransmission      :1;
00342   uint8_t   fragmentationPermitted        :1;
00343   uint8_t   reserved                      :4;
00344 } PACK APS_TxOptions_t;
00345
00346 /*************************************************************************/
00351 typedef struct
00352 {
00353   //Service fields
00355   struct
00356   {
00357     void *next;
00358   } service;
00359
00360   //Primitive fields
00371   APS_AddrMode_t dstAddrMode;
00375   APS_Address_t dstAddress;
00381   Endpoint_t dstEndpoint;
00383   ProfileId_t profileId;
00385   ClusterId_t clusterId;
00387   Endpoint_t srcEndpoint;
00392   uint8_t asduLength;
00394   uint8_t *asdu;
00404   APS_TxOptions_t txOptions;
00408   uint8_t radius;
00409   //Callback and Confirm
00411   void (*APS_DataConf)(APS_DataConf_t *conf);
00412   APS_DataConf_t confirm;
00413 } PACK APS_DataReq_t;
00414
00415
00416 /*************************************************************************/
00422 typedef struct
00423 {
00431   APS_AddrMode_t dstAddrMode;
00434   APS_Address_t dstAddress;
00436   Endpoint_t dstEndpoint;
00445   APS_AddrMode_t srcAddrMode;
00448   APS_Address_t srcAddress;
00451   Endpoint_t srcEndpoint;
00453   ProfileId_t profileId;
00455   ClusterId_t clusterId;
00457   uint8_t asduLength;
00459   uint8_t *asdu;
00461   APS_Status_t status;
00464   APS_Status_t securityStatus;
00466   uint8_t linkQuality;
00469   uint32_t rxTime;
00470   //\cond internal
00471   uint8_t rssi;
00472   //\endcond
00473 } PACK APS_DataInd_t;
00474
00475 //============================================================================
00476
00477 #ifdef _BINDING_
00478 /*****************************************************************************
00479   Binding Primitives
00480 *****************************************************************************/
00481 //\cond internal
00482 /*
00483   Parameters structure of the APS_BindConf() function.
00484   The APSME-BIND.confirm primitive.
00485 */
00486 typedef struct
00487 {
00488   //Primitive fields
00489   APS_Status_t status;
00490 } PACK APS_BindConf_t;
00491
00492
00493 /*
00494   Parameters structure of the APS_BindReq() function.
00495   The APSME-BIND.request primitive.
00496 */
00497 typedef struct
00498 {
00499   //Standard fields
00500   ExtAddr_t srcAddr;
00501   Endpoint_t srcEndpoint;
00502   ClusterId_t clusterId;
00503   APS_AddrMode_t dstAddrMode;
00504   APS_Address_t dstAddr;
00505   Endpoint_t dstEndpoint;
00506   //Confirm
00507   APS_BindConf_t confirm;
00508 } PACK APS_BindReq_t;
00509
00510
00511 /*
00512   Parameters structure of the APS_UnbindConf() function.
00513   The APSME-UNBIND.confirm primitive.
00514 */
00515 typedef struct
00516 {
00517   //Standard fields
00518   APS_Status_t status;
00519 } PACK APS_UnbindConf_t;
00520
00521
00522 /*
00523   Parameters structure of the APS_UnbindReq_t() function.
00524   The APSME-UNBIND.request primitive.
00525 */
00526 typedef struct
00527 {
00528   //Standard fields
00529   ExtAddr_t srcAddr;
00530   Endpoint_t srcEndpoint;
00531   ClusterId_t clusterId;
00532   APS_AddrMode_t dstAddrMode;
00533   APS_Address_t dstAddr;
00534   Endpoint_t dstEndpoint;
00535   //Confirm
00536   APS_UnbindConf_t confirm;
00537 } PACK APS_UnbindReq_t;
00538
00539 //\endcond
00540 #endif //#ifdef _BINDING_
00541
00542 /*****************************************************************************
00543   AIB Maintenance Primitives
00544 *****************************************************************************/
00545
00546 /*************************************************************************/
00551 typedef struct
00552 {
00553   //Standard fields
00555   APS_Status_t status;
00557   uint16_t aibAttributeLength;
00559   APS_AibAttribute_t aibAttributeValue;
00560 } PACK APS_GetConf_t;
00561
00562
00563 /*************************************************************************/
00568 typedef struct
00569 {
00570   //Standard fields
00572   APS_AibAttributeId_t aibAttribute;
00573
00574   //Confirm
00576   APS_GetConf_t confirm;
00577 } PACK APS_GetReq_t;
00578
00579
00580 /*************************************************************************/
00585 typedef struct
00586 {
00587   //Standard fields
00589   APS_Status_t status;
00590 } PACK APS_SetConf_t;
00591
00592
00593 /*************************************************************************/
00598 typedef struct
00599 {
00600   //Standard fields
00602   APS_AibAttributeId_t aibAttribute;
00604   uint16_t aibAttributeLength;
00606   APS_AibAttribute_t aibAttributeValue;
00607
00608   //Confirm
00610   APS_SetConf_t confirm;
00611 } PACK APS_SetReq_t;
00612 //============================================================================
00613
00614 #ifdef _APS_MULTICAST_
00615 /*****************************************************************************
00616   APS Group Management Primitives
00617 *****************************************************************************/
00618
00619 /*************************************************************************/
00624 typedef struct
00625 {
00626   //Standard fields
00628   APS_Status_t status;
00629 } PACK APS_AddGroupConf_t;
00630
00631 /*************************************************************************/
00636 typedef struct
00637 {
00638   //Standard fields
00640   GroupAddr_t groupAddress;
00642   Endpoint_t endpoint;
00643
00644   //Confirm
00646   APS_AddGroupConf_t confirm;
00647 } PACK APS_AddGroupReq_t;
00648
00649
00650 /*************************************************************************/
00655 typedef struct
00656 {
00657   //Standard fields
00659   APS_Status_t status;
00660 } PACK APS_RemoveGroupConf_t;
00661
00662 /*************************************************************************/
00667 typedef struct
00668 {
00669   //Standard fields
00671   GroupAddr_t groupAddress;
00673   Endpoint_t endpoint;
00674
00675   //Confirm
00677   APS_RemoveGroupConf_t confirm;
00678 } PACK APS_RemoveGroupReq_t;
00679
00680
00681 /*************************************************************************/
00686 typedef struct
00687 {
00688   //Standard fields
00690   APS_Status_t status;
00691 } PACK APS_RemoveAllGroupsConf_t;
00692
00693 /*************************************************************************/
00698 typedef struct
00699 {
00700   //Standard fields
00702   Endpoint_t endpoint;
00703
00704   //Confirm
00706   APS_RemoveAllGroupsConf_t confirm;
00707 } PACK APS_RemoveAllGroupsReq_t;
00708 //============================================================================
00709 #endif //#ifdef _APS_MULTICAST_
00710
00711
00712 #ifdef _SECURITY_
00713 #ifdef _HIGH_SECURITY_
00714 typedef struct PACK
00715 {
00716   ExtAddr_t deviceAddress;
00717   uint8_t masterKey[16];
00718   uint8_t linkKey[16];
00719   uint32_t outFrameCounter;
00720   uint32_t inFrameCounter;
00721 } ApsKeyPairDescriptor_t;
00722
00723
00724
00725 /*****************************************************************************
00726   APS Security Management Primitives
00727 *****************************************************************************/
00728 //\cond internal
00729 typedef enum
00730 {
00731   APS_SKKE_KEY_ESTABLISHMENT_METHOD = 0x00
00732 } APS_KeyEstablishmentMethod_t;
00733
00734
00735 /*****************************************************************************
00736   APSME-ESTABLISH-KEY.confirm primitive
00737 *****************************************************************************/
00738 typedef struct
00739 {
00740   ExtAddr_t address;
00741   APS_SkkeStatus_t status;
00742 } PACK APS_EstablishKeyConf_t;
00743
00744
00745
00746 /*****************************************************************************
00747   APSME-ESTABLISH-KEY.request primitive
00748 *****************************************************************************/
00749 typedef struct
00750 {
00751   //Service fields
00753   struct
00754   {
00755     void *next;
00756   } service;
00757   //Standards fields
00758   ExtAddr_t responderAddress;
00759   bool useParent;
00760   ExtAddr_t responderParentAddress;
00761   APS_KeyEstablishmentMethod_t keyEstablishmentMethod;
00762   //Confirm and callback
00763   APS_EstablishKeyConf_t confirm;
00764   void (*APS_EstablishKeyConf)(APS_EstablishKeyConf_t *conf);
00765 } PACK APS_EstablishKeyReq_t;
00766
00767
00768 /*****************************************************************************
00769   APSME-ESTABLISH-KEY.response primitive
00770 *****************************************************************************/
00771 typedef struct
00772 {
00773   ExtAddr_t initiatorAddress;
00774   bool accept;
00775   //Confirm and callback
00776   APS_EstablishKeyConf_t confirm;
00777   void (*APS_EstablishKeyConf)(APS_EstablishKeyConf_t *conf);
00778 } PACK APS_EstablishKeyResp_t;
00779
00780
00781 /*****************************************************************************
00782   APSME-ESTABLISH-KEY.indication primitive
00783 *****************************************************************************/
00784 typedef struct
00785 {
00786   //Standards fields
00787   ExtAddr_t initiatorAddress;
00788   APS_KeyEstablishmentMethod_t keyEstablishmentMethod;
00789 } PACK APS_EstablishKeyInd_t;
00790 #endif //#ifdef _HIGH_SECURITY_
00791
00792
00793
00794 //============================================================================
00795 typedef enum
00796 {
00797   APS_TRUST_CENTER_MASTER_KEY_TYPE =      0x00,
00798   APS_STANDARD_NETWORK_KEY_TYPE =         0x01,
00799   APS_APP_MASTER_KEY_TYPE =               0x02,
00800   APS_APP_LINK_KEY_TYPE =                 0x03,
00801   APS_TRUST_CENTER_LINK_KEY_TYPE =        0x04,
00802   APS_HIGH_SECURITY_NETWORK_KEY_TYPE =    0x05
00803 } APS_TransportKeyType_t;
00804
00805
00806 typedef struct
00807 {
00808   ExtAddr_t parentAddress;
00809   uint8_t key[16];
00810 } PACK APS_ReqTrustCenterMasterOrLinkKeyTransportData_t;
00811
00812 typedef struct
00813 {
00814   uint8_t keySeqNumber;
00815   uint8_t networkKey[16];
00816   bool useParent;
00817   ExtAddr_t parentAddress;
00818 } PACK APS_ReqNetworkKeyTransportData_t;
00819
00820 typedef struct
00821 {
00822   ExtAddr_t partnerAddress;
00823   bool initiator;
00824   uint8_t key[16];
00825 } PACK APS_ReqApplicationMasterOrLinkKeyTransportData_t;
00826
00827 typedef union
00828 {
00829   APS_ReqTrustCenterMasterOrLinkKeyTransportData_t trustCenterKey;
00830   APS_ReqNetworkKeyTransportData_t networkKey;
00831   APS_ReqApplicationMasterOrLinkKeyTransportData_t applicationKey;
00832 } APS_ReqTransportKeyData_t;
00833
00834
00835 typedef enum
00836 {
00837   APS_TKR_SUCCESS_STATUS                      = 0x00,
00838   APS_TKR_NO_SHORT_ADDRESS_STATUS             = 0x01,
00839   APS_TKR_SECURITY_FAIL_STATUS                = 0x02,
00840   APS_TKR_NOT_SENT_STATUS                     = 0x03
00841 } APS_TkrStatus_t;
00842
00843 /*****************************************************************************
00844   (Out of ZigBee Standard) APSME-TRANSPORT-KEY.confirm primitive
00845 *****************************************************************************/
00846 typedef struct PACK
00847 {
00848   APS_TkrStatus_t status;
00849 } APS_TransportKeyConf_t;
00850
00851 /*****************************************************************************
00852   APSME-TRANSPORT-KEY.request primitive
00853 *****************************************************************************/
00854 typedef struct
00855 {
00856   //Service fields
00857   struct
00858   {
00859     void *next;
00860   } service;
00861
00862   //Standards fields
00863   ExtAddr_t destAddress;
00864   APS_TransportKeyType_t keyType;
00865   APS_ReqTransportKeyData_t transportKeyData;
00866
00867   //Callback and Confirm
00868   APS_TransportKeyConf_t confirm;
00869   void (*APS_TransportKeyConf)(APS_TransportKeyConf_t *conf);
00870 } PACK APS_TransportKeyReq_t;
00871
00872 //============================================================================
00873
00874 typedef struct
00875 {
00876   uint8_t trustCenterMasterKey[16];
00877 } PACK APS_IndTrustCenterMasterOrLinkKeyTransportData_t;
00878
00879 typedef struct
00880 {
00881   uint8_t keySeqNumber;
00882   uint8_t networkKey[16];
00883 } PACK APS_IndNetworkKeyTransportData_t;
00884
00885 typedef struct
00886 {
00887   ExtAddr_t partnerAddress;
00888   uint8_t key[16];
00889 } PACK APS_IndApplicationMasterOrLinkKeyTransportData_t;
00890
00891 typedef union
00892 {
00893   APS_IndTrustCenterMasterOrLinkKeyTransportData_t trustCenterKey;
00894   APS_IndNetworkKeyTransportData_t networkKey;
00895   APS_IndApplicationMasterOrLinkKeyTransportData_t applicationKey;
00896 } APS_IndTransportKeyData_t;
00897
00898
00899 /*****************************************************************************
00900   APSME-TRANSPORT-KEY.indication primitive
00901 *****************************************************************************/
00902 typedef struct PACK
00903 {
00904   //Standards fields
00905   ExtAddr_t srcAddress;
00906   APS_TransportKeyType_t keyType;
00907   APS_IndTransportKeyData_t transportKeyData;
00908 } APS_TransportKeyInd_t;
00909 //============================================================================
00910
00911 typedef enum
00912 {
00913   APS_STANDARD_DEVICE_SECURED_REJOIN_STATUS =           0x00,
00914   APS_STANDARD_DEVICE_UNSECURED_JOIN_STATUS =           0x01,
00915   APS_DEVICE_LEFT_STATUS =                              0x02,
00916   APS_STANDARD_DEVICE_UNSECURED_REJOIN_STATUS =         0x03,
00917   APS_HIGH_SECURITY_DEVICE_SECURED_REJOIN_STATUS =      0x04,
00918   APS_HIGH_SECURITY_DEVICE_UNSECURED_JOIN_STATUS =      0x05,
00919   APS_RESERVED_STATUS =                                 0x06,
00920   APS_HIGH_SECURITY_DEVICE_UNSECURED_REJOIN_STATUS =    0x07
00921 } APS_UpdateDeviceStatus_t;
00922
00923 typedef enum
00924 {
00925   APS_UDR_SUCCESS_STATUS                      = 0x00,
00926   APS_UDR_NO_SHORT_ADDRESS_STATUS             = 0x01,
00927   APS_UDR_SECURITY_FAIL_STATUS                = 0x02,
00928   APS_UDR_NOT_SENT_STATUS                     = 0x03
00929 } APS_UdrStatus_t;
00930
00931 /*****************************************************************************
00932   (Out of ZigBee Standard) APSME-UPDATE-DEVICE.confirm primitive
00933 *****************************************************************************/
00934 typedef struct PACK
00935 {
00936   APS_UdrStatus_t status;
00937 } APS_UpdateDeviceConf_t;
00938
00939
00940 /*****************************************************************************
00941   APSME-UPDATE-DEVICE.request primitive
00942 *****************************************************************************/
00943 typedef struct
00944 {
00945   //Service fields
00946   struct
00947   {
00948     void *next;
00949   } service;
00950
00951   //Standards fields
00952   ExtAddr_t destAddress;
00953   ExtAddr_t deviceAddress;
00954   APS_UpdateDeviceStatus_t status;
00955   ShortAddr_t deviceShortAddress;
00956
00957   //Callback and Confirm
00958   APS_UpdateDeviceConf_t confirm;
00959   void (*APS_UpdateDeviceConf)(APS_UpdateDeviceConf_t *conf);
00960 } PACK APS_UpdateDeviceReq_t;
00961
00962
00963 /*****************************************************************************
00964   APSME-UPDATE-DEVICE.indication primitive
00965 *****************************************************************************/
00966 typedef struct
00967 {
00968   //Standards fields
00969   ExtAddr_t srcAddress;
00970   ExtAddr_t deviceAddress;
00971   APS_UpdateDeviceStatus_t status;
00972   ShortAddr_t deviceShortAddress;
00973 } PACK APS_UpdateDeviceInd_t;
00974 //============================================================================
00975
00976 typedef enum
00977 {
00978   APS_RDR_SUCCESS_STATUS                      = 0x00,
00979   APS_RDR_NO_SHORT_ADDRESS_STATUS             = 0x01,
00980   APS_RDR_SECURITY_FAIL_STATUS                = 0x02,
00981   APS_RDR_NOT_SENT_STATUS                     = 0x03
00982 } APS_RdrStatus_t;
00983
00984 /*****************************************************************************
00985   (Out of ZigBee Standard) APSME-REMOVE-DEVICE.confirm primitive
00986 *****************************************************************************/
00987 typedef struct PACK
00988 {
00989   APS_RdrStatus_t status;
00990 } APS_RemoveDeviceConf_t;
00991
00992
00993 /*****************************************************************************
00994   APSME-REMOVE-DEVICE.request primitive
00995 *****************************************************************************/
00996 typedef struct
00997 {
00998   //Service fields
00999   struct
01000   {
01001     void *next;
01002   } service;
01003
01004   //Standards fields
01005   ExtAddr_t parentAddress;
01006   ExtAddr_t childAddress;
01007
01008   //Callback and Confirm
01009   APS_RemoveDeviceConf_t confirm;
01010   void (*APS_RemoveDeviceConf)(APS_RemoveDeviceConf_t *conf);
01011 } PACK APS_RemoveDeviceReq_t;
01012
01013
01014 /*****************************************************************************
01015   APSME-REMOVE-DEVICE.indication primitive
01016 *****************************************************************************/
01017 typedef struct
01018 {
01019   //Standards fields
01020   ExtAddr_t srcAddress;
01021   ExtAddr_t childAddress;
01022 } PACK APS_RemoveDeviceInd_t;
01023 //============================================================================
01024
01025
01026 #ifdef _HIGH_SECURITY_
01027
01028 typedef enum
01029 {
01030   APS_NETWORK_KEY_TYPE =      0x01,
01031   APS_APP_KEY_TYPE =          0x02
01032 } APS_RequestKeyType_t;
01033
01034 typedef enum
01035 {
01036   APS_RKR_SUCCESS_STATUS                      = 0x00,
01037   APS_RKR_NO_SHORT_ADDRESS_STATUS             = 0x01,
01038   APS_RKR_SECURITY_FAIL_STATUS                = 0x02,
01039   APS_RKR_NOT_SENT_STATUS                     = 0x03
01040 } APS_RkrStatus_t;
01041 /*****************************************************************************
01042   (Out of ZigBee Standard) APSME-REQUEST-KEY.confirm primitive
01043 *****************************************************************************/
01044 typedef struct PACK
01045 {
01046   APS_RkrStatus_t status;
01047 } APS_RequestKeyConf_t;
01048
01049 /*****************************************************************************
01050   APSME-REQUEST-KEY.request primitive
01051 *****************************************************************************/
01052 typedef struct
01053 {
01054   //Service fields
01055   struct
01056   {
01057     void *next;
01058   } service;
01059
01060   //Standards fields
01061   ExtAddr_t destAddress;
01062   APS_RequestKeyType_t keyType;
01063   ExtAddr_t partnerAddress;
01064
01065   //Callback and Confirm
01066   APS_RequestKeyConf_t confirm;
01067   void (*APS_RequestKeyConf)(APS_RequestKeyConf_t *conf);
01068 } PACK APS_RequestKeyReq_t;
01069
01070 /*****************************************************************************
01071   APSME-REQUEST-KEY.indication primitive
01072 *****************************************************************************/
01073 typedef struct
01074 {
01075   //Standards fields
01076   ExtAddr_t srcAddress;
01077   APS_RequestKeyType_t keyType;
01078   ExtAddr_t partnerAddress;
01079 } PACK APS_RequestKeyInd_t;
01080
01081 #endif //#ifdef _HIGH_SECURITY_
01082
01083 //============================================================================
01084
01085
01086
01087
01088 typedef enum
01089 {
01090   APS_SKR_SUCCESS_STATUS                      = 0x00,
01091   APS_SKR_NO_SHORT_ADDRESS_STATUS             = 0x01,
01092   APS_SKR_SECURITY_FAIL_STATUS                = 0x02,
01093   APS_SKR_NOT_SENT_STATUS                     = 0x03
01094 } APS_SkrStatus_t;
01095
01096 /*****************************************************************************
01097   (Out of ZigBee Standard) APSME-SWITCH-KEY.confirm primitive
01098 *****************************************************************************/
01099 typedef struct PACK
01100 {
01101   APS_SkrStatus_t status;
01102 } APS_SwitchKeyConf_t;
01103
01104
01105 /*****************************************************************************
01106   APSME-SWITCH-KEY.request primitive
01107 *****************************************************************************/
01108 typedef struct
01109 {
01110   //Service fields
01111   struct
01112   {
01113     void *next;
01114   } service;
01115
01116   //Standards fields
01117   ExtAddr_t destAddress;
01118   uint8_t keySeqNumber;
01119
01120   //Callback and Confirm
01121   APS_SwitchKeyConf_t confirm;
01122   void (*APS_SwitchKeyConf)(APS_SwitchKeyConf_t *conf);
01123 } PACK APS_SwitchKeyReq_t;
01124
01125
01126 /*****************************************************************************
01127   APSME-SWITCH-KEY.indication primitive
01128 *****************************************************************************/
01129 typedef struct
01130 {
01131   //Standards fields
01132   ExtAddr_t srcAddress;
01133   uint8_t keySeqNumber;
01134 } PACK APS_SwitchKeyInd_t;
01135 //============================================================================
01136
01137 #ifdef _HIGH_SECURITY_
01138
01139 typedef enum
01140 {
01141   APS_INITIATE_ACTION =               0x00,
01142   APS_RESPOND_ACCEPT_ACTION =         0x01,
01143   APS_RESPOND_REJECT_ACTION =         0x02
01144 } APS_AuthenticateAction_t;
01145
01146 typedef enum
01147 {
01148   APS_AUTH_SUCCESS_STATUS =               0x00,
01149   APS_AUTH_INVALID_PARAMETER_STATUS =     0x01,
01150   APS_AUTH_NO_KEY_STATUS =                0x02,
01151   APS_AUTH_NO_DATA_STATUS =               0x03,
01152   APS_AUTH_INVALID_CHALLENGE_STATUS =     0x04,
01153   APS_AUTH_INVALID_MAC_STATUS =           0x05,
01154   APS_AUTH_INVALID_KEY_STATUS =           0x06,
01155   APS_AUTH_TIMEOUT_STATUS =               0x07
01156 } APS_AuthenticateStatus_t;
01157
01158 /*****************************************************************************
01159   APSME-AUTHENTICATE.confirm primitive
01160 *****************************************************************************/
01161 typedef struct
01162 {
01163   //Standards fields
01164   ExtAddr_t address;
01165   APS_AuthenticateStatus_t status;
01166 } PACK APS_AuthenticateConf_t;
01167
01168
01169 /*****************************************************************************
01170   APSME-AUTHENTICATE.request primitive
01171 *****************************************************************************/
01172 typedef struct
01173 {
01174   //Service fields
01175   struct
01176   {
01177     void *next;
01178   } service;
01179
01180   //Standards fields
01181   ExtAddr_t partnerAddress;
01182   APS_AuthenticateAction_t action;
01183   uint8_t randomChallenge[16];
01184
01185   //Callback and Confirm
01186   void (*APS_AuthenticateConf)(APS_AuthenticateConf_t *conf);
01187   APS_AuthenticateConf_t confirm;
01188 } PACK APS_AuthenticateReq_t;
01189
01190 /*****************************************************************************
01191   APSME-AUTHENTICATE.indication primitive
01192 *****************************************************************************/
01193 typedef struct
01194 {
01195   //Standards fields
01196   ExtAddr_t initiatorAddress;
01197   uint8_t randomChallenge[16];
01198 } PACK APS_AuthenticateInd_t;
01199
01200 #endif //#ifdef _HIGH_SECURITY_
01201
01202 //\endcond
01203 //============================================================================
01204 #endif //#ifdef _SECURITY_
01205
01206
01207
01208 /*****************************************************************************
01209   APS Special Primitives
01210 *****************************************************************************/
01211 //\cond internal
01212
01213
01214 /*****************************************************************************
01215   APSME-RESET.confirm primitive
01216 *****************************************************************************/
01217 typedef struct
01218 {
01219   //Standard fields
01220   APS_Status_t status;
01221 } PACK APS_ResetConf_t;
01222
01223 /*****************************************************************************
01224   APSME-RESET.request primitive
01225 *****************************************************************************/
01226 typedef struct
01227 {
01228   //Standard fields
01229   bool commissioning;
01230   //Callback and Confirm
01231   void (*APS_ResetConf)(APS_ResetConf_t *conf);
01232   APS_ResetConf_t confirm;
01233 } PACK APS_ResetReq_t;
01234
01235 /*****************************************************************************
01236   APSME-START.confirm primitive
01237 *****************************************************************************/
01238 typedef struct
01239 {
01240   //Standard fields
01241   APS_Status_t status;
01242 } PACK APS_StartConf_t;
01243
01244 /*****************************************************************************
01245   APSME-START.request primitive
01246 *****************************************************************************/
01247 typedef struct
01248 {
01249   //Standard fields
01250
01251   //Callback and Confirm
01252   void (*APS_StartConf)(APS_StartConf_t *conf);
01253   APS_StartConf_t confirm;
01254 } PACK APS_StartReq_t;
01255
01256
01257 /*****************************************************************************
01258   APSME-STOP.confirm primitive
01259 *****************************************************************************/
01260 typedef struct
01261 {
01262   //Standard fields
01263   APS_Status_t status;
01264 } PACK APS_StopConf_t;
01265
01266
01267 /*****************************************************************************
01268   APSME-STOP.request primitive
01269 *****************************************************************************/
01270 typedef struct
01271 {
01272   //Standard fields
01273
01274   //Callback and Confirm
01275   void (*APS_StopConf)(APS_StopConf_t *conf);
01276   APS_StopConf_t confirm;
01277 } PACK APS_StopReq_t;
01278 //\endcond
01279 //============================================================================
01280
01281
01282
01283
01284 /*****************************************************************************
01285   APS Endpoint Register/Unregister Primitives
01286 *****************************************************************************/
01287
01288 /*************************************************************************/
01293 typedef struct
01294 {
01295   //Service fields
01297   struct
01298   {
01299     void *next;
01300     struct
01301     {
01302       uint8_t noIndication  :1; //If
01303       uint8_t reserved      :7;
01304     };
01305   } service;
01306
01307   //Standard fields
01309   SimpleDescriptor_t *simpleDescriptor;
01311   void (*APS_DataInd)(APS_DataInd_t *ind);
01312 } PACK APS_RegisterEndpointReq_t;
01313
01314 /*************************************************************************/
01319 typedef struct
01320 {
01321   //Standard fields
01323   Endpoint_t endpoint;
01324 } PACK APS_UnregisterEndpointReq_t;
01325 //============================================================================
01326
01327
01328
01329 /******************************************************************************
01330                    Constants section
01331 ******************************************************************************/
01332
01333 /******************************************************************************
01334                    External variables section
01335 ******************************************************************************/
01336
01337 /******************************************************************************
01338                    Prototypes section
01339 ******************************************************************************/
01340
01341
01342 /*****************************************************************************
01343   APS API Prototypes
01344 *****************************************************************************/
01345
01346 /*****************************************************************************
01347   APS Task Manager API
01348 *****************************************************************************/
01349 // \cond internal
01350 /*****************************************************************************
01351   Peforms APS sublayer processing.
01352   Parameters: None
01353   Returns:    None
01354 *****************************************************************************/
01355 extern void APS_TaskHandler(void);
01356 // \endcond
01357 //============================================================================
01358
01359 #ifdef _BINDING_
01360 /*****************************************************************************
01361   APS Binding API
01362 *****************************************************************************/
01363 void APS_BindReq(APS_BindReq_t *req);
01364 void APS_UnbindReq(APS_UnbindReq_t *req);
01365 #endif //#ifdef _BINDING_
01366
01367 /*****************************************************************************
01368   APS AIB Manager API
01369 *****************************************************************************/
01370
01371 /**************************************************************************/
01378 extern void APS_GetReq(APS_GetReq_t *req);
01379
01380 /**************************************************************************/
01390 extern void APS_SetReq(APS_SetReq_t *req);
01391 //============================================================================
01392
01393 /*****************************************************************************
01394   APS Control Manager API
01395 *****************************************************************************/
01396
01397 /*************************************************************************/
01404 extern void APS_RegisterEndpointReq(APS_RegisterEndpointReq_t *req);
01405
01406 /*************************************************************************/
01413 extern void APS_UnregisterEndpointReq(APS_UnregisterEndpointReq_t *req);
01414
01415 /*************************************************************************/
01422 extern APS_RegisterEndpointReq_t *APS_GetEndpointList(void);
01423
01424 /*************************************************************************/
01431 extern void APS_StopEndpointIndication(Endpoint_t endpoint);
01432
01433 /*************************************************************************/
01440 extern void APS_ResumeEndpointIndication(Endpoint_t endpoint);
01441
01442 //\cond internal
01443 /**************************************************************************/
01451 extern void APS_ResetReq(APS_ResetReq_t *req);
01452
01453 /**************************************************************************/
01462 extern void APS_Init(void);
01463
01464
01465 /**************************************************************************/
01470 extern void APS_StartReq(APS_StartReq_t *req);
01471
01472 /**************************************************************************/
01477 extern void APS_StopReq(APS_StopReq_t *req);
01478 //endcond
01479 //============================================================================
01480
01481 /*****************************************************************************
01482   APS Data Manager API
01483 *****************************************************************************/
01484
01485 /**************************************************************************/
01496 extern void APS_DataReq(APS_DataReq_t *req);
01497
01498
01499 #ifdef _APS_MULTICAST_
01500 /*****************************************************************************
01501   APS Group Manager API
01502 *****************************************************************************/
01503
01504 /**************************************************************************/
01515 extern void APS_AddGroupReq(APS_AddGroupReq_t *req);
01516
01517 /**************************************************************************/
01528 extern void APS_RemoveGroupReq(APS_RemoveGroupReq_t *req);
01529
01530 /**************************************************************************/
01542 extern void APS_RemoveAllGroupsReq(APS_RemoveAllGroupsReq_t *req);
01543
01544 //\cond internal
01545 /***************************************************************************/
01559 APS_GroupTableEntry_t* APS_FindGroup(GroupAddr_t groupAddr, uint8_t *index);
01560 //\endcond
01561 //============================================================================
01562 #endif
01563
01564
01565 //\cond internal
01566 #ifdef _SECURITY_
01567 /*****************************************************************************
01568   APS Security Manager API
01569 *****************************************************************************/
01570 extern void APS_DeleteLinkKeyAndResetCounters(ExtAddr_t *extAddr);
01571
01572 /*****************************************************************************
01573   APS Master Key Set function
01574   Parameters: extAddr - extAddr pointer
01575               ket     - key material pointer
01576   Returns:    true - success
01577               false - no place
01578 *****************************************************************************/
01579 extern bool APS_SetMasterKey(ExtAddr_t *extAddr, uint8_t *key);
01580
01581 /*****************************************************************************
01582   APS Link Key Set function
01583   Parameters: extAddr - extAddr pointer
01584               ket     - key material pointer
01585   Returns:    true - success
01586               false - no place
01587 *****************************************************************************/
01588 extern bool APS_SetLinkKey(ExtAddr_t *extAddr, uint8_t *key);
01589
01590 #ifdef _HIGH_SECURITY_
01591 //Key Establishment feature
01592 extern void APS_EstablishKeyReq(APS_EstablishKeyReq_t *req);
01593 extern void APS_EstablishKeyResp(APS_EstablishKeyResp_t *resp);
01594 /*Must be provided*/
01595 extern void APS_EstablishKeyInd(APS_EstablishKeyInd_t *ind);
01596 //extern void APS_EstablishKeyConf(APS_EstablishKeyConf_t *conf);
01597 #endif //#ifdef _HIGH_SECURITY_
01598
01599
01600 //Transport Key feature
01601 extern void APS_TransportKeyReq(APS_TransportKeyReq_t *req);
01602 /*Must be provided*/
01603 extern void APS_TransportKeyInd(APS_TransportKeyInd_t *ind);
01604
01605 //Update Device feature
01606 extern void APS_UpdateDeviceReq(APS_UpdateDeviceReq_t *req);
01607 /*Must be provided*/
01608 extern void APS_UpdateDeviceInd(APS_UpdateDeviceInd_t *ind);
01609
01610
01611 //Remove Device feature
01612 extern void APS_RemoveDeviceReq(APS_RemoveDeviceReq_t *req);
01613 /*Must be provided*/
01614 extern void APS_RemoveDeviceInd(APS_RemoveDeviceInd_t *ind);
01615
01616 #ifdef _HIGH_SECURITY_
01617 //Request Key feature
01618 extern void APS_RequestKeyReq(APS_RequestKeyReq_t *req);
01619 /*Must be provided*/
01620 extern void APS_RequestKeyInd(APS_RequestKeyInd_t *ind);
01621 #endif //#ifdef _HIGH_SECURITY_
01622
01623 //Switch Key feature
01624 extern void APS_SwitchKeyReq(APS_SwitchKeyReq_t *req);
01625 /*Must be provided*/
01626 extern void APS_SwitchKeyInd(APS_SwitchKeyInd_t *ind);
01627
01628 #ifdef _HIGH_SECURITY_
01629 //Autenticate feature
01630 extern void APS_AuthenticateReq(APS_AuthenticateReq_t *req);
01631 /*Must be provided*/
01632 extern void APS_AuthenticateInd(APS_AuthenticateInd_t *ind);
01633
01634
01635 //ApsKeyPairSet API
01636 extern ApsKeyPairDescriptor_t *APS_GetKeyPairDescriptor(ExtAddr_t *address);
01637 extern uint8_t *APS_GetMasterKey(ApsKeyPairDescriptor_t *keyPairDescriptor);
01638 extern uint8_t *APS_GetLinkKey(ApsKeyPairDescriptor_t *keyPairDescriptor);
01639 extern bool APS_DeleteKeyPair(ExtAddr_t *extAddr);
01640 #endif //#ifdef _HIGH_SECURITY_
01641
01642 #endif
01643
01644
01645
01646
01647
01648 // \cond internal
01649 /*****************************************************************************
01650   NLDE-DATA.indication handler
01651   Parameters: req - primitive pointer
01652   Returns:    None
01653 *****************************************************************************/
01654 extern void NWK_DataInd(NWK_DataInd_t *req);
01655
01656
01657 /*****************************************************************************
01658   NLDE-DATA.confirm handler
01659   Parameters: req - primitive pointer
01660   Returns:    None
01661 *****************************************************************************/
01662 extern void NWK_DataConf(NWK_DataConf_t *req);
01663
01664 /*****************************************************************************
01665   ZDO APSDE-DATA.indication handler
01666   Parameters: ind - primitive pointer
01667   Returns:    None
01668 *****************************************************************************/
01669 extern void APS_ZdoDataInd(APS_DataInd_t *ind);
01670 // \endcond
01671
01672
01673 #endif  //#ifndef _APS_H
01674
01675
01676 //eof aps.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: atomic.h File Reference

  • File List
  • Globals

atomic.h File Reference

Header file defines the defines for working with atomic sections. More...

#include <halAtomic.h>

Go to the source code of this file.

Detailed Description

Header file defines the defines for working with atomic sections.

Definition in file atomic.h.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: atomic.h Source File

  • File List
  • Globals

atomic.h

Go to the documentation of this file.
00001 /****************************************************************************/
00013 #ifndef _ATOMIC_H
00014 #define _ATOMIC_H
00015
00016 #include <halAtomic.h>
00017
00018
00020 #define ATOMIC_SECTION_ENTER {atomic_t __atomic = halStartAtomic();
00022 #define ATOMIC_SECTION_LEAVE halEndAtomic(__atomic);}
00023
00024 #endif /* _ATOMIC_H */
00025 // eof atomic.h
00026
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: buttons.h File Reference

  • File List
  • Globals

buttons.h File Reference

Declaration of buttons interface. More...

Go to the source code of this file.

Functions

result_t | BSP_OpenButtons (void(*pressed)(uint8_t bn), void(*released)(uint8_t bn))
Registers handlers for button events.
result_t | BSP_CloseButtons ()
Cancel buttons handlers.
uint8_t | BSP_ReadButtonsState ()
Reads state of the buttons.

Detailed Description

Declaration of buttons interface.

Definition in file buttons.h.

Function Documentation

result_t BSP_CloseButtons ( )

Cancel buttons handlers.

Returns:
FAIL - buttons module was not opened,
SUCCESS - otherwise.

result_t BSP_OpenButtons | ( | void(*)(uint8_t bn) | pressed,
 |  | void(*)(uint8_t bn) | released
 | ) |  |

Registers handlers for button events.

Parameters:
[in] | pressed | - the handler to process pressing of the button
[in] | released | - the handler to process releasing of the button
[in] | bn | - button number.
Returns:
FAIL - buttons module is busy,
SUCCESS - otherwise.

uint8_t BSP_ReadButtonsState ( )

Reads state of the buttons.

Returns:
Current buttons state in a binary way.
Bit 0 defines the state of button 1, bit 1 defines the state of button 2.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: buttons.h Source File

  • File List
  • Globals

buttons.h

Go to the documentation of this file.
00001 /*******************************************************************************/
00013 #ifndef BSPBUTTONS_H_
00014 #define BSPBUTTONS_H_
00015
00016 // \cond
00017 #include <types.h>
00018 #define BSP_MAX_BUTTONS_COUNT 2
00019
00020 #define BSP_KEY0 ((uint8_t)1 << 0)
00021 #define BSP_KEY1 ((uint8_t)1 << 1)
00022
00023 typedef void (*BSP_ButtonsEventFunk_t)(uint8_t);
00024 // \endcond
00025
00026 /**************************************************************************/
00038 result_t BSP_OpenButtons(void (*pressed)(uint8_t bn), void (*released)(uint8_t bn));
00039
00040 /**************************************************************************/
00046 result_t BSP_CloseButtons();
00047
00048 /**************************************************************************/
00054 uint8_t BSP_ReadButtonsState();
00055
00056 #endif  /* BSPBUTTONS_H_ */
00057 //eof buttons.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: configServer.h File Reference

  • File List
  • Globals

configServer.h File Reference

The header file describes the public ConfigServer interface. More...

#include <types.h>
#include <avr/io.h>
#include <avr/pgmspace.h>

Go to the source code of this file.

Enumerations

enum CS_ParameterId_t {
CS_NEIB_TABLE_SIZE_ID, CS_MAX_CHILDREN_AMOUNT_ID, CS_MAX_CHILDREN_ROUTER_AMOUNT_ID, CS_MAX_NETWORK_DEPTH_ID,
CS_ADDRESS_ASSIGNMENT_METHOD_ID, CS_NWK_DATA_REQ_BUFFER_SIZE_ID, CS_NWK_DATA_IND_BUFFER_SIZE_ID, CS_APS_DATA_REQ_BUFFER_SIZE_ID,
CS_APS_ACK_FRAME_BUFFER_SIZE_ID, CS_PROTOCOL_VERSION_ID, CS_STACK_PROFILE_ID, CS_SCAN_DURATION_ID,
CS_PERMIT_DURATION_ID, CS_NWK_EXT_PANID_ID, CS_EXT_PANID_ID, CS_NWK_ADDR_ID,
CS_NWK_UNIQUE_ADDR_ID, CS_CHANNEL_MASK_ID, CS_UID_ID, CS_INDIRECT_POLL_RATE_ID,
CS_AUTONETWORK_ID, CS_DEVICE_TYPE_ID, CS_DUPLICATE_REJECTION_TABLE_SIZE_ID, CS_ACK_TIMEOUT_ID,
CS_MAC_FRAME_RX_BUFFER_SIZE_ID, CS_APS_GROUP_TABLE_ENDPOINTS_AMOUNT_ID, CS_APS_GROUP_TABLE_GROUPS_AMOUNT_ID, CS_END_DEVICE_ACTIVE_PERIOD_ID,
CS_END_DEVICE_SLEEP_PERIOD_ID, CS_RX_ON_WHEN_IDLE_ID, CS_RF_TX_POWER_ID, CS_SOFT_RESET_REASON_ID,
CS_NWK_USE_MULTICAST_ID, CS_ROUTE_TABLE_SIZE_ID, CS_ADDRESS_MAP_TABLE_SIZE_ID, CS_ROUTE_DISCOVERY_TABLE_SIZE_ID,
CS_MAC_TRANSACTION_TIME_ID, CS_DTR_WAKEUP_ID, CS_NWK_LOGICAL_CHANNEL_ID, CS_NWK_PANID_ID
}
IDs of the parameters in Config Server. More...
enum CS_MemoryId_t {
CS_NEIB_TABLE_ID, CS_NWK_DATA_REQ_BUFFER_ID, CS_NWK_DATA_IND_BUFFER_ID, CS_APS_DATA_REQ_BUFFER_ID,
CS_APS_ACK_FRAME_BUFFER_ID, CS_ASSOCIATE_RESPONSE_BUFFER_ID, CS_NWK_PAN_DESCRIPTOR_BUFFER_ID, CS_MAC_PAN_DESCRIPTOR_BUFFER_ID,
CS_DUPLICATE_REJECTION_TABLE_ID, CS_MAC_FRAME_RX_BUFFER_ID, CS_APS_GROUP_TABLE_ID, CS_ROUTE_TABLE_ID,
CS_ADDRESS_MAP_TABLE_ID, CS_ROUTE_DISCOVERY_TABLE_ID
}
IDs of the memory area in Config Server. More...

Functions

void | CS_Init (void)
Inits the Config Server.
void | CS_GetMemory (CS_MemoryId_t memoryId, void **memoryPtr)
Gets allocated memory specified by memory identifier.
void | CS_ReadParameter (CS_ParameterId_t parameterId, void *parameterValue)
Reads a parameter value specified by parameter identifier from Config Server.
void | CS_WriteParameter (CS_ParameterId_t parameterId, void *parameterValue)
Writes a parameter value specified by parameter identifier to Config Server.
void | CS_PdsDefaultValue (void)
Set persist default value.

Detailed Description

The header file describes the public ConfigServer interface.

The file describes the public interface and parameters of Config Server. It is intended for reading/writing the stack parameters.

Definition in file configServer.h.

Enumeration Type Documentation

enum CS_MemoryId_t

IDs of the memory area in Config Server.

Enumerator:
CS_NEIB_TABLE_ID
CS_NWK_DATA_REQ_BUFFER_ID
CS_NWK_DATA_IND_BUFFER_ID
CS_APS_DATA_REQ_BUFFER_ID
CS_APS_ACK_FRAME_BUFFER_ID
CS_ASSOCIATE_RESPONSE_BUFFER_ID
CS_NWK_PAN_DESCRIPTOR_BUFFER_ID
CS_MAC_PAN_DESCRIPTOR_BUFFER_ID
CS_DUPLICATE_REJECTION_TABLE_ID
CS_MAC_FRAME_RX_BUFFER_ID
CS_APS_GROUP_TABLE_ID
CS_ROUTE_TABLE_ID
CS_ADDRESS_MAP_TABLE_ID
CS_ROUTE_DISCOVERY_TABLE_ID

Definition at line 309 of file configServer.h.

enum CS_ParameterId_t

IDs of the parameters in Config Server.

Enumerator:
CS_NEIB_TABLE_SIZE_ID
CS_MAX_CHILDREN_AMOUNT_ID
CS_MAX_CHILDREN_ROUTER_AMOUNT_ID
CS_MAX_NETWORK_DEPTH_ID
CS_ADDRESS_ASSIGNMENT_METHOD_ID
CS_NWK_DATA_REQ_BUFFER_SIZE_ID
CS_NWK_DATA_IND_BUFFER_SIZE_ID
CS_APS_DATA_REQ_BUFFER_SIZE_ID
CS_APS_ACK_FRAME_BUFFER_SIZE_ID
CS_PROTOCOL_VERSION_ID
CS_STACK_PROFILE_ID
CS_SCAN_DURATION_ID
CS_PERMIT_DURATION_ID
CS_NWK_EXT_PANID_ID
CS_EXT_PANID_ID
CS_NWK_ADDR_ID
CS_NWK_UNIQUE_ADDR_ID
CS_CHANNEL_MASK_ID
CS_UID_ID
CS_INDIRECT_POLL_RATE_ID
CS_AUTONETWORK_ID
CS_DEVICE_TYPE_ID
CS_DUPLICATE_REJECTION_TABLE_SIZE_ID
CS_ACK_TIMEOUT_ID
CS_MAC_FRAME_RX_BUFFER_SIZE_ID
CS_APS_GROUP_TABLE_ENDPOINTS_AMOUNT_ID
CS_APS_GROUP_TABLE_GROUPS_AMOUNT_ID
CS_END_DEVICE_ACTIVE_PERIOD_ID
CS_END_DEVICE_SLEEP_PERIOD_ID
CS_RX_ON_WHEN_IDLE_ID
CS_RF_TX_POWER_ID
CS_SOFT_RESET_REASON_ID
CS_NWK_USE_MULTICAST_ID
CS_ROUTE_TABLE_SIZE_ID
CS_ADDRESS_MAP_TABLE_SIZE_ID
CS_ROUTE_DISCOVERY_TABLE_SIZE_ID
CS_MAC_TRANSACTION_TIME_ID
CS_DTR_WAKEUP_ID
CS_NWK_LOGICAL_CHANNEL_ID
CS_NWK_PANID_ID

Definition at line 239 of file configServer.h.

Function Documentation

void CS_GetMemory | ( | CS_MemoryId_t | memoryId,
 |  | void ** | memoryPtr
 | ) |  |

Gets allocated memory specified by memory identifier.

Parameters:
[in] | memoryId | - memory area Id
[out] | memoryPtr | - pointer to the memory

void CS_Init ( void )

Inits the Config Server.

Config server gets values from defines and reads from persistence data server

void CS_PdsDefaultValue ( void )

Set persist default value.

void CS_ReadParameter | ( | CS_ParameterId_t | parameterId,
 |  | void * | parameterValue
 | ) |  |

Reads a parameter value specified by parameter identifier from Config Server.

Parameters:
[in] | parameterId | - ID of the parameter being read
[out] | parameterValue | - Value of the parameter being read

void CS_WriteParameter | ( | CS_ParameterId_t | parameterId,
 |  | void * | parameterValue
 | ) |  |

Writes a parameter value specified by parameter identifier to Config Server.

If the parameter is in persistense data server it also is saved there.

Parameters:
[in] | parameterId | - ID of the parameter being written
[in] | parameterValue | - Value of the parameter being written

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: configServer.h Source File

  • File List
  • Globals

configServer.h

Go to the documentation of this file.
00001 /*************************************************************************/
00016 #ifndef _CONFIGSERVER_H
00017 #define _CONFIGSERVER_H
00018
00019 #include <types.h>
00020 #include <avr/io.h>
00021 #include <avr/pgmspace.h>
00022
00023 /*****************************************************************************
00024   Defines
00025 *****************************************************************************/
00026 #ifndef CS_PROTOCOL_VERSION
00027 #define CS_PROTOCOL_VERSION                   0x02
00028 #endif
00029 #ifndef CS_STACK_PROFILE
00030 #define CS_STACK_PROFILE                      0x02
00031 #endif
00032 #ifndef CS_DEVICE_TYPE
00033 #define CS_DEVICE_TYPE                        DEVICE_TYPE_ROUTER
00034 #endif
00036
00037 #ifndef CS_NEIB_TABLE_SIZE
00038 #define CS_NEIB_TABLE_SIZE                    6
00039 #endif
00040 #ifndef CS_MAX_CHILDREN_AMOUNT
00041 #define CS_MAX_CHILDREN_AMOUNT                5
00042 #endif
00043 #ifndef CS_MAX_CHILDREN_ROUTER_AMOUNT
00044 #define CS_MAX_CHILDREN_ROUTER_AMOUNT         2
00045 #endif
00046 #ifndef CS_MAX_NETWORK_DEPTH
00047 #define CS_MAX_NETWORK_DEPTH                  5
00048 #endif
00049 #ifndef CS_ADDRESS_ASSIGNMENT_METHOD
00050 #define CS_ADDRESS_ASSIGNMENT_METHOD          2
00051 #endif
00052 #ifndef CS_AUTONETWORK
00053 #define CS_AUTONETWORK                        false
00054 #endif
00055 #ifndef CS_CHANNEL_MASK
00056 #define CS_CHANNEL_MASK                       0x00010000L
00057 #endif
00058 #ifndef CS_UID
00059 #define CS_UID                                0x0000000000000000LL
00060 #endif
00061 #ifndef CS_EXT_PANID
00062 #define CS_EXT_PANID                          CS_UID
00063 #endif
00064 #ifndef CS_NWK_EXT_PANID
00065 #define CS_NWK_EXT_PANID                      0LL
00066 #endif
00067 #ifndef CS_NWK_ADDR
00068 #define CS_NWK_ADDR                       0xFFFF
00069 #endif
00070 #ifndef CS_NWK_UNIQUE_ADDR
00071 #define CS_NWK_UNIQUE_ADDR                          false
00072 #endif
00074
00077 #ifndef CS_END_DEVICE_ACTIVE_PERIOD
00078 #define CS_END_DEVICE_ACTIVE_PERIOD           0L
00079 #endif
00081
00084 #ifndef CS_END_DEVICE_SLEEP_PERIOD
00085 #define CS_END_DEVICE_SLEEP_PERIOD            10000L
00086 #endif
00087
00088
00089 // Encryption time of maximum packet size in ms. Decryption time is equal to encryption time.
00090 #ifndef CS_ENCRYPTION_TIME
00091 #if defined(_SECURITY_)
00092   #ifdef _MAC_HW_AES_
00093     #define CS_ENCRYPTION_TIME 18     // HW encryption
00094   #else
00095     #define CS_ENCRYPTION_TIME 119    // SW encryption
00096   #endif
00097 #else
00098   #define CS_ENCRYPTION_TIME 0ul
00099 #endif
00100 #endif
00101
00102 // The time of transmission a packet with max lengh on air plus
00103 // the time of processing an incoming transit packet from receiving from air to sending to air (ms)
00104 #ifndef CS_MAX_HOP_TIME
00105 #define CS_MAX_HOP_TIME (4ul+7ul)
00106 #endif
00107
00108 #ifndef CS_ACK_TIMEOUT
00109 #define CS_ACK_TIMEOUT  (3ul * CS_MAX_NETWORK_DEPTH * (CS_MAX_HOP_TIME + (CS_ENCRYPTION_TIME * 2)))
00110 #endif
00111
00113
00114 #ifndef CS_INDIRECT_POLL_RATE
00115 #define CS_INDIRECT_POLL_RATE                 (CS_ACK_TIMEOUT >> 1)
00116 #endif
00117 #ifndef CS_RF_TX_POWER
00118 /* It was TX_PWR_3_0DBM. */
00119 #define CS_RF_TX_POWER                        3
00120 #endif
00121 #ifndef CS_SCAN_DURATION
00122 #define CS_SCAN_DURATION                      0x05
00123 #endif
00124
00126 #ifndef CS_PERMIT_DURATION
00127 #define CS_PERMIT_DURATION                    0xff
00128 #endif
00129 #ifndef CS_SOFT_RESET_REASON
00130 #define CS_SOFT_RESET_REASON                  0
00131 #endif
00132 #ifndef CS_NWK_USE_MULTICAST
00133 #define CS_NWK_USE_MULTICAST                  false
00134 #endif
00135 // by default in MAC = 7680L
00136 #ifndef CS_MAC_TRANSACTION_TIME
00137 #define CS_MAC_TRANSACTION_TIME               (CS_END_DEVICE_SLEEP_PERIOD + (CS_INDIRECT_POLL_RATE * 3))
00138 #endif
00139 #ifndef CS_DUPLICATE_REJECTION_TABLE_SIZE
00140 #define CS_DUPLICATE_REJECTION_TABLE_SIZE     10
00141 #endif
00142 #ifndef CS_APS_GROUP_TABLE_ENDPOINTS_AMOUNT
00143 #define CS_APS_GROUP_TABLE_ENDPOINTS_AMOUNT   1
00144 #endif
00145 #ifndef CS_APS_GROUP_TABLE_GROUPS_AMOUNT
00146 #define CS_APS_GROUP_TABLE_GROUPS_AMOUNT      1
00147 #endif
00148 #ifndef CS_ROUTE_TABLE_SIZE
00149 #define CS_ROUTE_TABLE_SIZE                   30
00150 #endif
00151 #ifndef CS_ADDRESS_MAP_TABLE_SIZE
00152 #define CS_ADDRESS_MAP_TABLE_SIZE             10
00153 #endif
00154 #ifndef CS_ROUTE_DISCOVERY_TABLE_SIZE
00155 #define CS_ROUTE_DISCOVERY_TABLE_SIZE         10
00156 #endif
00157 #ifndef CS_NWK_DATA_REQ_BUFFER_SIZE
00158 #define CS_NWK_DATA_REQ_BUFFER_SIZE           4
00159 #endif
00160 // Minimum value is 3
00161 #ifndef CS_NWK_DATA_IND_BUFFER_SIZE
00162 #define CS_NWK_DATA_IND_BUFFER_SIZE           5
00163 #endif
00164 #ifndef CS_APS_DATA_REQ_BUFFER_SIZE
00165 #define CS_APS_DATA_REQ_BUFFER_SIZE           6
00166 #endif
00167 #ifndef CS_APS_ACK_FRAME_BUFFER_SIZE
00168 #define CS_APS_ACK_FRAME_BUFFER_SIZE          5
00169 #endif
00170 #ifndef CS_MAC_FRAME_RX_BUFFER_SIZE
00171 #define CS_MAC_FRAME_RX_BUFFER_SIZE           1
00172 #endif
00173 #ifndef CS_APS_GROUP_TABLE_SIZEOF
00174 #define CS_APS_GROUP_TABLE_SIZEOF             (CS_APS_GROUP_TABLE_GROUPS_AMOUNT * \
00175                                               (sizeof(APS_GroupTableEntry_t) +    \
00176                                               ((CS_APS_GROUP_TABLE_ENDPOINTS_AMOUNT - 1) * sizeof(Endpoint_t))))
00177 #endif
00178
00179 #ifndef CS_DTR_WAKEUP
00180 #define CS_DTR_WAKEUP                         false
00181 #endif
00182
00183 /*****************************************************************************
00184   Security related defines
00185 *****************************************************************************/
00186 #ifdef _SECURITY_
00187 //Amount of Aps Security Manager buffers
00188 /*Should be no less than 2*/
00189 #ifndef CS_APS_SECURITY_BUFFERS_AMOUNT
00190 #define CS_APS_SECURITY_BUFFERS_AMOUNT          2
00191 #endif
00192 #ifndef CS_APS_SECURITY_TIMEOUT_PERIOD
00193 #define CS_APS_SECURITY_TIMEOUT_PERIOD        CS_ACK_TIMEOUT
00194 #endif
00195 #ifndef CS_APS_TRUST_CENTER_ADDRESS
00196 #define CS_APS_TRUST_CENTER_ADDRESS           0xAAAAAAAAAAAAAAAALL
00197 #endif
00198 #ifndef CS_ZDO_SECURITY_STATUS
00199 #define CS_ZDO_SECURITY_STATUS                PRECONFIGURED_NETWORK_KEY
00200 #endif
00201 #ifndef CS_NETWORK_KEY
00202 #define CS_NETWORK_KEY                {0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0}
00203 #endif
00204 #ifndef CS_SECURITY_LEVEL
00205 #define CS_SECURITY_LEVEL             0x05
00206 #endif
00207 #ifndef CS_SECURITY_ALL_FRAMES
00208 #define CS_SECURITY_ALL_FRAMES        true
00209 #endif
00210 #ifndef CS_MAX_TC_AUTHENTIC_PROCESS_AMOUNT
00211 #define CS_MAX_TC_AUTHENTIC_PROCESS_AMOUNT     1
00212 #endif
00213 #ifdef _TC_PERMISSION_TABLE_
00214   #ifndef CS_MAX_TC_ALLOWED_DEVICES_AMOUNT
00215   #define CS_MAX_TC_ALLOWED_DEVICES_AMOUNT    5
00216   #endif
00217 #endif
00218 #ifdef _HIGH_SECURITY_
00219 //Maximum amount of Key-Pair Descriptors
00220 #ifndef CS_APS_KEY_PAIR_DESCRIPTORS_AMOUNT
00221 #define CS_APS_KEY_PAIR_DESCRIPTORS_AMOUNT  2
00222 #endif
00223 #ifndef CS_MASTER_KEY
00224 #define CS_MASTER_KEY                 {0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0}
00225 #endif
00226 #ifndef CS_LINK_KEY
00227 #define CS_LINK_KEY                   {0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0}
00228 #endif
00229 #ifndef CS_MAX_TC_ESTABLISH_KEY_AMOUNT
00230 #define CS_MAX_TC_ESTABLISH_KEY_AMOUNT      1
00231 #endif
00232 #endif
00233
00234 #endif
00235
00239 typedef enum
00240 {
00241   CS_NEIB_TABLE_SIZE_ID,
00242   CS_MAX_CHILDREN_AMOUNT_ID,
00243   CS_MAX_CHILDREN_ROUTER_AMOUNT_ID,
00244   CS_MAX_NETWORK_DEPTH_ID,
00245   CS_ADDRESS_ASSIGNMENT_METHOD_ID,
00246   CS_NWK_DATA_REQ_BUFFER_SIZE_ID,
00247   CS_NWK_DATA_IND_BUFFER_SIZE_ID,
00248   CS_APS_DATA_REQ_BUFFER_SIZE_ID,
00249   CS_APS_ACK_FRAME_BUFFER_SIZE_ID,
00250   CS_PROTOCOL_VERSION_ID,
00251   CS_STACK_PROFILE_ID,
00252   CS_SCAN_DURATION_ID,
00253   CS_PERMIT_DURATION_ID,
00254   CS_NWK_EXT_PANID_ID,      // eeprom
00255   CS_EXT_PANID_ID,          // eeprom
00256   CS_NWK_ADDR_ID,           // eeprom
00257   CS_NWK_UNIQUE_ADDR_ID,    // bool // eeprom
00258   CS_CHANNEL_MASK_ID,       // eeprom
00259   CS_UID_ID,                // eeprom
00260   CS_INDIRECT_POLL_RATE_ID,
00261   CS_AUTONETWORK_ID,        // eeprom
00262   CS_DEVICE_TYPE_ID,        // eeprom
00263   CS_DUPLICATE_REJECTION_TABLE_SIZE_ID,
00264   CS_ACK_TIMEOUT_ID,
00265   CS_MAC_FRAME_RX_BUFFER_SIZE_ID,
00266   CS_APS_GROUP_TABLE_ENDPOINTS_AMOUNT_ID,
00267   CS_APS_GROUP_TABLE_GROUPS_AMOUNT_ID,
00268   CS_END_DEVICE_ACTIVE_PERIOD_ID,
00269   CS_END_DEVICE_SLEEP_PERIOD_ID,
00270   CS_RX_ON_WHEN_IDLE_ID,            // eeprom
00271   CS_RF_TX_POWER_ID,                // eeprom
00272   CS_SOFT_RESET_REASON_ID,          // eeprom
00273   CS_NWK_USE_MULTICAST_ID,
00274   CS_ROUTE_TABLE_SIZE_ID,
00275   CS_ADDRESS_MAP_TABLE_SIZE_ID,
00276   CS_ROUTE_DISCOVERY_TABLE_SIZE_ID,
00277   CS_MAC_TRANSACTION_TIME_ID,
00278   CS_DTR_WAKEUP_ID,                 // eeprom
00279   CS_NWK_LOGICAL_CHANNEL_ID,        // eeprom
00280   CS_NWK_PANID_ID,                  // eeprom
00281
00282 /***************************************************************************
00283     Security related ID's
00284 ***************************************************************************/
00285 #ifdef _SECURITY_
00286   CS_NETWORK_KEY_ID,                    // eeprom
00287   CS_SECURITY_LEVEL_ID,
00288   CS_SECURITY_ALL_FRAMES_ID,
00289   CS_APS_SECURITY_BUFFERS_AMOUNT_ID,
00290   CS_APS_SECURITY_TIMEOUT_PERIOD_ID,
00291   CS_APS_TRUST_CENTER_ADDRESS_ID,
00292   CS_ZDO_SECURITY_STATUS_ID,            // eeprom
00293   CS_MAX_TC_AUTHENTIC_PROCESS_AMOUNT_ID,
00294 #ifdef _TC_PERMISSION_TABLE_
00295   CS_MAX_TC_ALLOWED_DEVICES_AMOUNT_ID,
00296 #endif
00297 #ifdef _HIGH_SECURITY_
00298   CS_APS_KEY_PAIR_DESCRIPTORS_AMOUNT_ID,
00299   CS_LINK_KEY_ID,                       // eeprom
00300   CS_MASTER_KEY_ID,                     // eeprom
00301   CS_MAX_TC_ESTABLISH_KEY_AMOUNT_ID,
00302 #endif
00303 #endif
00304 } CS_ParameterId_t;
00305
00309 typedef enum
00310 {
00311   CS_NEIB_TABLE_ID,                   // eeprom
00312   CS_NWK_DATA_REQ_BUFFER_ID,
00313   CS_NWK_DATA_IND_BUFFER_ID,
00314   CS_APS_DATA_REQ_BUFFER_ID,
00315   CS_APS_ACK_FRAME_BUFFER_ID,
00316   CS_ASSOCIATE_RESPONSE_BUFFER_ID,
00317   CS_NWK_PAN_DESCRIPTOR_BUFFER_ID,
00318   CS_MAC_PAN_DESCRIPTOR_BUFFER_ID,
00319   CS_DUPLICATE_REJECTION_TABLE_ID,
00320   CS_MAC_FRAME_RX_BUFFER_ID,
00321   CS_APS_GROUP_TABLE_ID,            // eeprom
00322   CS_ROUTE_TABLE_ID,               // eeprom
00323   CS_ADDRESS_MAP_TABLE_ID,         // eeprom
00324   CS_ROUTE_DISCOVERY_TABLE_ID,
00325
00326   /***********************************************************************************
00327   Security related ID's
00328   *************************************************************************************/
00329 #if defined(_SECURITY_)
00330   CS_NWK_SECURITY_IB_ID,             // eeprom
00331   CS_APS_SECURITY_BUFFERS_ID,
00332   CS_TC_AUTHENTIC_PROCESS_BUFFER_ID,
00333 #ifdef _TC_PERMISSION_TABLE_
00334   CS_TC_PERMISSION_TABLE_ID,
00335 #endif
00336 #ifdef _HIGH_SECURITY_
00337   CS_APS_KEY_PAIR_DESCRIPTORS_ID,      // eeprom
00338   CS_TC_ESTABLISH_KEY_BUFFER_ID,
00339 #endif
00340 #endif
00341 } CS_MemoryId_t;
00342
00343
00344 /***********************************************************************************/
00349 extern void CS_Init(void);
00350
00351 /***********************************************************************************/
00357 extern void CS_GetMemory(CS_MemoryId_t memoryId, void **memoryPtr);
00358
00359 /************************************************************************************/
00365 extern void CS_ReadParameter(CS_ParameterId_t parameterId, void *parameterValue);
00366
00367 /***********************************************************************************/
00375 extern void CS_WriteParameter(CS_ParameterId_t parameterId, void *parameterValue);
00376
00377 /**************************************************************************/
00380 extern void CS_PdsDefaultValue(void);
00381
00382 #endif  //#ifndef _CONFIGSERVER_H
00383
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: eeprom.h File Reference

  • File List
  • Globals

eeprom.h File Reference

Provides access to EEPROM. More...

Go to the source code of this file.

Data Structures

struct | HAL_EepromParams_t
eeprom access control structure More...

Functions

int | HAL_ReadEeprom (HAL_EepromParams_t *params)
Reads a number of bytes defined by HAL_EepromParams_t from the EEPROM.
int | HAL_WriteEeprom (HAL_EepromParams_t *params, void(*writeDone)())
Writes a number of bytes defined by HAL_EepromParams_t to EEPROM. By writeDone parameter user can control if write operation will be asynchronous or synchronous.

Detailed Description

Provides access to EEPROM.

Definition in file eeprom.h.

Function Documentation

int HAL_ReadEeprom ( HAL_EepromParams_t * params )

Reads a number of bytes defined by HAL_EepromParams_t from the EEPROM.

Parameters:
[in] params - address of HAL_EepromParams_t defined by user.
Returns:
Number of bytes that were read from EEPROM - success,
-2 - the previous EEPROM request is not completed yet,
-1 - the number of bytes to read is too large.

int HAL_WriteEeprom | ( | HAL_EepromParams_t * | params,
 |  | void(*)() | writeDone
 | ) |  |

Writes a number of bytes defined by HAL_EepromParams_t to EEPROM. By writeDone parameter user can control if write operation will be asynchronous or synchronous.

Parameters:
[in] | params | - address of HAL_EepromParams_t defined by user.
[in] | writeDone | - address of callback. if writeDone is 0 write operation will be synchronous.
Returns:
Number of bytes that were written to EEPROM - success (synchronous operation),
0 - success (asynchronous operation),
-2 - the previous EEPROM request is not completed yet,
-1 - the number of bytes to read is too large.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: eeprom.h Source File

  • File List
  • Globals

eeprom.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #ifndef EEPROM_H_
00014 #define EEPROM_H_
00015
00016 // \cond
00017 #include <halEeprom.h>
00018
00019 #define EEPROM_DATA_MEMORY_SIZE 0x1000u
00020 // \endcond
00021
00022 /**************************************************************************/
00025 typedef struct
00026 {
00028   uint16_t address;
00030   uint8_t *data;
00032   uint16_t length;
00033 }HAL_EepromParams_t;
00034
00035 /**************************************************************************/
00044 int HAL_ReadEeprom(HAL_EepromParams_t *params);
00045
00046 /**************************************************************************/
00060 int HAL_WriteEeprom(HAL_EepromParams_t *params, void (*writeDone)());
00061
00062 #endif  /* EEPROM_H_ */
00063 // eof EEPROM.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: i2cPacket.h File Reference

  • File List
  • Globals

i2cPacket.h File Reference

Declaration of the i2cPacket interface. More...

#include <i2c.h>

Go to the source code of this file.

Functions

int | HAL_OpenI2cPacket (const HAL_i2cMode_t *i2cMode)
Opens resource.
field of i2cMode structure
i2cClockRate_t clockrate (set by user). Must be chosen from:
I2C_CLOCK_RATE_250 - 250 Kb/s clock rate
I2C_CLOCK_RATE_125 - 125 Kb/s clock rate
I2C_CLOCK_RATE_62 - 62.5 Kb/s clock rate
.
int | HAL_CloseI2cPacket ()
Closes resource.
int | HAL_WriteI2cPacket (uint8_t id, uint8_t length, const uint8_t *data, void(*f)(bool result))
Writes a series of bytes out to the TWI bus.
int | HAL_ReadI2cPacket (uint8_t id, uint8_t length, uint8_t *data, void(*f)(bool result))
Reads the series of bytes from the TWI bus.

Detailed Description

Declaration of the i2cPacket interface.

Definition in file i2cPacket.h.

Function Documentation

int HAL_CloseI2cPacket ( )

Closes resource.

Returns:
-1 - resource was not open.
0 - success.

int HAL_OpenI2cPacket ( const HAL_i2cMode_t * i2cMode )

Opens resource.
field of i2cMode structure
i2cClockRate_t clockrate (set by user). Must be chosen from:
I2C_CLOCK_RATE_250 - 250 Kb/s clock rate
I2C_CLOCK_RATE_125 - 125 Kb/s clock rate
I2C_CLOCK_RATE_62 - 62.5 Kb/s clock rate
.

Parameters:
[in] i2cMode - pointer to the mode structure.
Returns:
-1 - resource was already open.
0 - success.

int HAL_ReadI2cPacket | ( | uint8_t | id,
 |  | uint8_t | length,
 |  | uint8_t * | data,
 |  | void(*)(bool result) | f
 | ) |  |

Reads the series of bytes from the TWI bus.

Parameters:
[in] | id | - address of the i2c device on the bus
[in] | length | - number of bytes to be read from the bus.
[in] | data | - pointer to the data buffer
[in] | f | - pointer to the callback function
Returns:
0 - the bus is free and the request is accepted.
-1 - otherwise.

int HAL_WriteI2cPacket | ( | uint8_t | id,
 |  | uint8_t | length,
 |  | const uint8_t * | data,
 |  | void(*)(bool result) | f
 | ) |  |

Writes a series of bytes out to the TWI bus.

Parameters:
[in] | id | - address of the i2c device on the bus
[in] | length | - number of bytes to be written to the bus
[in] | data | - pointer to the data
[in] | f | - pointer to the callback function
Returns:
0 - the bus is free and the request is accepted.
-1 - otherwise.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: i2cPacket.h Source File

  • File List
  • Globals

i2cPacket.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #ifndef I2CPACKETM_H_
00014 #define I2CPACKETM_H_
00015
00016 // \cond
00017 #include <types.h>
00018 #include <i2c.h>
00019 // \endcond
00020
00021 /**************************************************************************/
00036 int HAL_OpenI2cPacket(const HAL_i2cMode_t *i2cMode);
00037
00038 /**************************************************************************/
00045 int HAL_CloseI2cPacket();
00046
00047 /**************************************************************************/
00062 int HAL_WriteI2cPacket(uint8_t id,
00063                        uint8_t length,
00064                        const uint8_t* data,
00065                        void (*f)(bool result));
00066
00067 /**************************************************************************/
00082 int HAL_ReadI2cPacket(uint8_t id,
00083                       uint8_t length,
00084                       uint8_t *data,
00085                       void (*f)(bool result));
00086
00087 #endif
00088 // eof i2cPacket.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: irq.h File Reference

  • File List
  • Globals

irq.h File Reference

Declaration of the IRQ interface. More...

Go to the source code of this file.

Functions

int | HAL_RegisterIrq (uint8_t irqNumber, HAL_irqMode_t irqMode, void(*f)(void))
Registers the user's irqNumber external interrupt.
int | HAL_EnableIrq (uint8_t irqNumber)
Enables the irqNumber interrupt.
int | HAL_DisableIrq (uint8_t irqNumber)
Disables the irqNumber interrupt.
int | HAL_UnregisterIrq (uint8_t irqNumber)
Unregisters the user's irqNumber interrupt.

Detailed Description

Declaration of the IRQ interface.

Definition in file irq.h.

Function Documentation

int HAL_DisableIrq ( uint8_t irqNumber )

Disables the irqNumber interrupt.

Parameters:
[in] irqNumber - IRQ number
Returns:
-1 - if irqNumber is out of range or has not been registered yet.
0 - otherwise.

int HAL_EnableIrq ( uint8_t irqNumber )

Enables the irqNumber interrupt.

Parameters:
[in] irqNumber - IRQ number
Returns:
-1 - if irqNumber is out of range or has not been registered yet.
0 - otherwise.

int HAL_RegisterIrq | ( | uint8_t | irqNumber,
 |  | HAL_irqMode_t | irqMode,
 |  | void(*)(void) | f
 | ) |  |

Registers the user's irqNumber external interrupt.

Parameters:
[in] irqNumber - IRQ number. Must be chosen from:
IRQ_6
IRQ_7
[in] irqMode - Controls the sort of interrupt. Must be chosen from:
IRQ_LOW_LEVEL // The low level generates an interrupt request.
IRQ_ANY_EDGE // Any edge generates an interrupt request.
IRQ_FALLING_EDGE // Falling edge generates an interrupt request.
IRQ_RISING_EDGE // Rising edge generates an interrupt request.
[in] f - user's interrupt handler
Returns:
-1 - if irqNumber is out of range or such interrupt has been already registered.
0 - otherwise.

int HAL_UnregisterIrq ( uint8_t irqNumber )

Unregisters the user's irqNumber interrupt.

Parameters:
[in] irqNumber - IRQ number
Returns:
-1 - if irqNumber is out of range or has not been registered yet.
0 - otherwise.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: irq.h Source File

  • File List
  • Globals

irq.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #ifndef IRQ_H_
00014 #define IRQ_H_
00015
00016 // \cond
00017 #include <halIrq.h>
00018 // \endcond
00019
00020 /**************************************************************************/
00041 int HAL_RegisterIrq(uint8_t irqNumber, HAL_irqMode_t irqMode, void (*f)(void));
00042
00043 /**************************************************************************/
00051 int HAL_EnableIrq(uint8_t irqNumber);
00052
00053 /**************************************************************************/
00061 int HAL_DisableIrq(uint8_t irqNumber);
00062
00063 /**************************************************************************/
00071 int HAL_UnregisterIrq(uint8_t irqNumber);
00072
00073 #endif
00074 //eof irq.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: leds.h File Reference

  • File List
  • Globals

leds.h File Reference

Declaration of leds interface. More...

#include <types.h>
#include <inttypes.h>

Go to the source code of this file.

Functions

result_t | BSP_OpenLeds (void)
Opens leds module to use.
result_t | BSP_CloseLeds (void)
Closes leds module.
void | BSP_OnLed (uint8_t id)
Turns on a led.
void | BSP_OffLed (uint8_t id)
Turns off a led.
void | BSP_ToggleLed (uint8_t id)
Switches the led state to the opposite.

Detailed Description

Declaration of leds interface.

Definition in file leds.h.

Function Documentation

result_t BSP_CloseLeds ( void )

Closes leds module.

Returns:
SUCCESS - always.

void BSP_OffLed ( uint8_t id )

Turns off a led.

Parameters:
[in] id - number of the led to proceed. Must be chosen from:
LED_RED
LED_GREEN
LED_YELLOW

void BSP_OnLed ( uint8_t id )

Turns on a led.

Parameters:
[in] id - number of the led to proceed. Must be chosen from:
LED_RED
LED_GREEN
LED_YELLOW

result_t BSP_OpenLeds ( void )

Opens leds module to use.

Returns:
SUCCESS - always.

void BSP_ToggleLed ( uint8_t id )

Switches the led state to the opposite.

Parameters:
[in] id - number of the led to proceed. Must be chosen from:
LED_RED
LED_GREEN
LED_YELLOW

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: leds.h Source File

  • File List
  • Globals

leds.h

Go to the documentation of this file.
00001 /*******************************************************************************/
00013 #ifndef LEDS_H
00014 #define LEDS_H
00015
00016 // \cond
00017 #include <gpio.h>
00018 #include <types.h>
00019 #include <inttypes.h>
00020
00021 #define LED_RED    0
00022 #define LED_GREEN  2
00023 #define LED_YELLOW 1
00024
00025 #ifndef _STK500
00026   #define halInitRedLed()       GPIO_0_make_out()
00027   #define halUnInitRedLed()     GPIO_0_make_in()
00028   #define halOnRedLed()         GPIO_0_set()
00029   #define halOffRedLed()        GPIO_0_clr()
00030   #define halReadRedLed()       GPIO_0_read()
00031   #define halToggleRedLed()     GPIO_0_toggle()
00032
00033   #define halInitYellowLed()    GPIO_1_make_out()
00034   #define halUnInitYellowLed()  GPIO_1_make_in()
00035   #define halOnYellowLed()      GPIO_1_set()
00036   #define halOffYellowLed()     GPIO_1_clr()
00037   #define halReadYellowLed()    GPIO_1_read()
00038   #define halToggleYellowLed()  GPIO_1_toggle()
00039
00040   #define halInitGreenLed()     GPIO_2_make_out()
00041   #define halUnInitGreenLed()   GPIO_2_make_in()
00042   #define halOnGreenLed()       GPIO_2_set()
00043   #define halOffGreenLed()      GPIO_2_clr()
00044   #define halReadGreenLed()     GPIO_2_read()
00045   #define halToggleGreenLed()   GPIO_2_toggle()
00046 #else
00047   #define halInitRedLed()       GPIO_9_make_out(); GPIO_9_set()
00048   #define halUnInitRedLed()     GPIO_9_make_in()
00049   #define halOnRedLed()         GPIO_9_clr()
00050   #define halOffRedLed()        GPIO_9_set()
00051   #define halReadRedLed()       GPIO_9_read()
00052   #define halToggleRedLed()     GPIO_9_toggle()
00053
00054   #define halInitYellowLed()    GPIO_10_make_out(); GPIO_10_set()
00055   #define halUnInitYellowLed()  GPIO_10_make_in()
00056   #define halOnYellowLed()      GPIO_10_clr()
00057   #define halOffYellowLed()     GPIO_10_set()
00058   #define halReadYellowLed()    GPIO_10_read()
00059   #define halToggleYellowLed()  GPIO_10_toggle()
00060
00061   #define halInitGreenLed()     GPIO_11_make_out(); GPIO_11_set()
00062   #define halUnInitGreenLed()   GPIO_11_make_in()
00063   #define halOnGreenLed()       GPIO_11_clr()
00064   #define halOffGreenLed()      GPIO_11_set()
00065   #define halReadGreenLed()     GPIO_11_read()
00066   #define halToggleGreenLed()   GPIO_11_toggle()
00067 #endif //_STK500
00068 // \endcond
00069
00070 /************************************************************/
00075 result_t BSP_OpenLeds(void);
00076
00077 /************************************************************/
00082 result_t BSP_CloseLeds(void);
00083
00084 /************************************************************/
00092 void BSP_OnLed(uint8_t id);
00093
00094 /************************************************************/
00102 void BSP_OffLed(uint8_t id);
00103
00104 /************************************************************/
00112 void BSP_ToggleLed(uint8_t id);
00113
00114 #endif /*LEDS_H*/
00115 // eof leds.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: pdsDataServer.h File Reference

  • File List
  • Globals

pdsDataServer.h File Reference

The header file describes the interface of Persistence Data Server. More...

#include <configServer.h>

Go to the source code of this file.

Enumerations

enum PDS_DataServerState_t {
PDS_SUCCESS, PDS_EEPROM_ERROR, PDS_CRC_ERROR, PDS_INVALID_REQUEST,
PDS_EEPROM_BUSY
}

Functions

PDS_DataServerState_t | PDS_Init (void)
Reads all parameters from EEPROM to Config Server memory.
PDS_DataServerState_t | PDS_SetToDefault (void)
Writes default values of parameters to EEPROM.
PDS_DataServerState_t | PDS_ReadUserData (uint16_t offset, uint8_t *data, uint16_t length)
Reads data from user area of EEPROM.
PDS_DataServerState_t | PDS_WriteUserData (uint16_t offset, uint8_t *data, uint16_t length, void(*callback)(void))
Writes data to user area of EEPROM.

Detailed Description

The header file describes the interface of Persistence Data Server.

Definition in file pdsDataServer.h.

Enumeration Type Documentation

enum PDS_DataServerState_t

Enumerator:
PDS_SUCCESS
  • Command completed successfully
PDS_EEPROM_ERROR
  • EEPROM error occured
PDS_CRC_ERROR
  • Wrong CRC
PDS_INVALID_REQUEST
  • Some parameters are wrong
PDS_EEPROM_BUSY
  • EEPROM is busy

Definition at line 27 of file pdsDataServer.h.

Function Documentation

PDS_DataServerState_t PDS_Init ( void )

Reads all parameters from EEPROM to Config Server memory.

Reads all parameters from EEPROM to Config Server memory and also checks CRC of EEPROM stack parameters. In case of wrong CRC ConfigServer should reset EEPROM stack parameters to default values.

Returns:
- PDS state as a result of initiation.

PDS_DataServerState_t PDS_ReadUserData | ( | uint16_t | offset,
 |  | uint8_t * | data,
 |  | uint16_t | length
 | ) |  |

Reads data from user area of EEPROM.

Parameters:
[in] | offset | - data offset
[in] | data | - pointer to user data area
[in] | length | - data length
Returns:
- PDS state as a result of data reading operation

PDS_DataServerState_t PDS_SetToDefault ( void )

Writes default values of parameters to EEPROM.

Returns:
- PDS state as a result of setting parameters to default state

PDS_DataServerState_t PDS_WriteUserData | ( | uint16_t | offset,
 |  | uint8_t * | data,
 |  | uint16_t | length,
 |  | void(*)(void) | callback
 | ) |  |

Writes data to user area of EEPROM.

Parameters:
[in] | offset | - data offset
[in] | data | - pointer to user data area
[in] | length | - data length
Returns:
- PDS state as a result of data writing operation

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: pdsDataServer.h Source File

  • File List
  • Globals

pdsDataServer.h

Go to the documentation of this file.
00001 /***************************************************************************/
00013 #ifndef _PERSISTDATASERVER_H
00014 #define _PERSISTDATASERVER_H
00015
00016 /******************************************************************************
00017                    Includes section
00018 ******************************************************************************/
00019 #include <configServer.h>
00020
00021 /******************************************************************************
00022                    Types section
00023 ******************************************************************************/
00024 /*
00025 Result PDS state after a command call
00026 */
00027 typedef enum
00028 {
00029   PDS_SUCCESS,
00030   PDS_EEPROM_ERROR,
00031   PDS_CRC_ERROR,
00032   PDS_INVALID_REQUEST,
00033   PDS_EEPROM_BUSY
00034 } PDS_DataServerState_t;
00035
00036
00037 /***************************************************************************/
00046 PDS_DataServerState_t PDS_Init(void);
00047
00048 /*****************************************************************************/
00053 PDS_DataServerState_t PDS_SetToDefault(void);
00054
00055 /*****************************************************************************/
00064 PDS_DataServerState_t PDS_ReadUserData(uint16_t offset, uint8_t *data, uint16_t length);
00065
00066 /****************************************************************************/
00075 PDS_DataServerState_t PDS_WriteUserData(uint16_t offset, uint8_t *data, uint16_t length, void (*callback)(void));
00076
00077 #endif  //#ifndef _PERSISTDATASERVER_H
00078
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: resetReason.h File Reference

  • File List
  • Globals

resetReason.h File Reference

Declaration of the reset reason interface. More...

Go to the source code of this file.

Functions

HAL_ResetReason_t | HAL_ReadResetReason ()
Returns the reset reason.
void | HAL_WarmReset (void)
Software reset.

Detailed Description

Declaration of the reset reason interface.

Definition in file resetReason.h.

Function Documentation

HAL_ResetReason_t HAL_ReadResetReason ( )

Returns the reset reason.

Returns:
The reason of reset. Must be chosen from:
POWER_ON_RESET
EXTERNAL_RESET
BROWN_OUT_RESET
WDT_RESET
JTAG_RESET
WARM_RESET

void HAL_WarmReset ( void )

Software reset.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: resetReason.h Source File

  • File List
  • Globals

resetReason.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #ifndef RESETREASON_H_
00014 #define RESETREASON_H_
00015
00016 // \cond
00017 // Possible reset reasons.
00018 typedef enum
00019 {
00020   POWER_ON_RESET  = 0x1,  // The supply voltage was below reset threshold.
00021   EXTERNAL_RESET  = 0x2,  // Low level was present on RESET pin.
00022   BROWN_OUT_RESET = 0x4,  // The supply voltage was below Brown-out reset threshold.
00023   WDT_RESET       = 0x8,  // Watch Dog Timer period expired.
00024   JTAG_RESET      = 0x10, // MCU was reset by JTAG.
00025   WARM_RESET      = 0x11  // MCU was reset by software.
00026 }HAL_ResetReason_t;
00027 // \endcond
00028
00029 /**************************************************************************/
00041 HAL_ResetReason_t HAL_ReadResetReason();
00042
00043 /**************************************************************************/
00046 void HAL_WarmReset(void);
00047
00048 #endif
00049 // resetReason.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: sensors.h File Reference

  • File List
  • Globals

sensors.h File Reference

Declarations of sensor types and sensors interface. More...

#include <pwrCtrl.h>
#include <lm73.h>
#include <tsl2550.h>
#include <battery.h>

Go to the source code of this file.

Functions

static result_t | BSP_OpenTemperatureSensor ()
Opens temperature sensor.
static result_t | BSP_CloseTemperatureSensor ()
Closes the temperature sensor.
static result_t | BSP_ReadTemperatureData (void(*f)(bool result, int16_t data))
Reads data from the temperature sensor.
static result_t | BSP_OpenLightSensor ()
Opens the light sensor.
static result_t | BSP_CloseLightSensor ()
Closes the light sensor.
static result_t | BSP_ReadLightData (void(*f)(bool result, int16_t data))
Reads data from the light sensor.
static result_t | BSP_OpenBatterySensor ()
Opens the battery sensor.
static result_t | BSP_CloseBatterySensor ()
Closes the battery sensor.
static result_t | BSP_ReadBatteryData (void(*callback)(uint8_t data))
Reads data from battery sensor.

Detailed Description

Declarations of sensor types and sensors interface.

Definition in file sensors.h.

Function Documentation

static result_t BSP_CloseBatterySensor ( ) [inline, static]

Closes the battery sensor.

Returns:
FAIL - sensor was not opened.
SUCCESS - otherwise.

Definition at line 151 of file sensors.h.

static result_t BSP_CloseLightSensor ( ) [inline, static]

Closes the light sensor.

Returns:
FAIL - if a hardware error has occured or there is uncompleted ReadData request.
SUCCESS - otherwise.

Definition at line 102 of file sensors.h.

static result_t BSP_CloseTemperatureSensor ( ) [inline, static]

Closes the temperature sensor.

Returns:
FAIL - if a hardware error has occured or there is uncompleted ReadData request.
SUCCESS - otherwise.

Definition at line 51 of file sensors.h.

static result_t BSP_OpenBatterySensor ( ) [inline, static]

Opens the battery sensor.

Returns:
FAIL - sensor has been already open.
SUCCESS - otherwise.

Definition at line 135 of file sensors.h.

static result_t BSP_OpenLightSensor ( ) [inline, static]

Opens the light sensor.

Returns:
FAIL - sensor has been already open.
SUCCESS - otherwise.

Definition at line 85 of file sensors.h.

static result_t BSP_OpenTemperatureSensor ( ) [inline, static]

Opens temperature sensor.

Returns:
FAIL - sensor has been already open.
SUCCESS - otherwise.

Definition at line 34 of file sensors.h.

static result_t BSP_ReadBatteryData ( void(*)(uint8_t data) callback ) [inline, static]

Reads data from battery sensor.

Parameters:
[in] data - sensor data.
Returns:
FAIL - previous request was not completed, or sensor was not opened.
SUCCESS - otherwise.

Definition at line 169 of file sensors.h.

static result_t BSP_ReadLightData ( void(*)(bool result, int16_t data) f ) [inline, static]

Reads data from the light sensor.

Parameters:
[in] | result | - the result of the requested operation. true - operation finished successfully, false - some error has occured.
[in] | data | - sensor data.
Returns:
FAIL - previous request was not completed.
SUCCESS - otherwise.

Definition at line 124 of file sensors.h.

static result_t BSP_ReadTemperatureData ( void(*)(bool result, int16_t data) f ) [inline, static]

Reads data from the temperature sensor.

Parameters:
[in] | result | - the result of the requested operation. true - operation finished successfully, false - some error has occured.
[in] | data | - sensor data.
Returns:
FAIL - previous request was not completed.
SUCCESS - otherwise.

Definition at line 73 of file sensors.h.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: sensors.h Source File

  • File List
  • Globals

sensors.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #ifndef SENSORS_H_
00014 #define SENSORS_H_
00015
00016 // \cond
00017 #include <types.h>
00018 #include <pwrCtrl.h>
00019 #include <lm73.h>
00020 #include <tsl2550.h>
00021 #include <battery.h>
00022
00023 #define SENSOR_LIGHT       1
00024 #define SENSOR_TEMPERATURE 2
00025 #define SENSOR_BATTERY     3
00026 #define SENSOR_LED         4
00027 // \endcond
00028
00029 /***************************************************************************/
00035 static inline result_t BSP_OpenTemperatureSensor()
00036 {
00037 result_t result;
00038   if ((result = openLm73()) == SUCCESS)
00039   {
00040     bspOnPeriphery(SENSOR_TEMPERATURE);
00041   }
00042   return result;
00043 }
00044
00045 /***************************************************************************/
00052 static inline result_t BSP_CloseTemperatureSensor()
00053 {
00054 result_t result;
00055   if ((result = closeLm73()) == SUCCESS)
00056   {
00057     bspOffPeriphery(SENSOR_TEMPERATURE);
00058   }
00059   return result;
00060 }
00061
00062 /**************************************************************************/
00074 static inline result_t BSP_ReadTemperatureData(void (*f)(bool result, int16_t data))
00075 {
00076   return readLm73Data(f);
00077 }
00078
00079
00080 /***************************************************************************/
00086 static inline result_t BSP_OpenLightSensor()
00087 {
00088 result_t result;
00089   if ((result = openTsl2550()) == SUCCESS)
00090   {
00091     bspOnPeriphery(SENSOR_LIGHT);
00092   }
00093   return result;
00094 }
00095
00096 /***************************************************************************/
00103 static inline result_t BSP_CloseLightSensor()
00104 {
00105 result_t result;
00106   if ((result = closeTsl2550()) == SUCCESS)
00107   {
00108     bspOffPeriphery(SENSOR_LIGHT);
00109   }
00110   return result;
00111 }
00112
00113 /**************************************************************************/
00125 static inline result_t BSP_ReadLightData(void (*f)(bool result, int16_t data))
00126 {
00127   return readTsl2550Data(f);
00128 }
00129
00130 /***************************************************************************/
00136 static inline result_t BSP_OpenBatterySensor()
00137 {
00138 result_t result;
00139   if ((result = openBattery()) == SUCCESS)
00140   {
00141     bspOnPeriphery(SENSOR_BATTERY);
00142   }
00143   return result;
00144 }
00145
00146 /***************************************************************************/
00152 static inline result_t BSP_CloseBatterySensor()
00153 {
00154 result_t result;
00155   if ((result = closeBattery()) == SUCCESS)
00156   {
00157     bspOffPeriphery(SENSOR_BATTERY);
00158   }
00159   return result;
00160 }
00161
00162 /**************************************************************************/
00170 static inline result_t BSP_ReadBatteryData(void (*callback)(uint8_t data))
00171 {
00172   return readBatteryData(callback);
00173 }
00174
00175 #endif/* SENSORS_H_ */
00176
00177 // eof sensors.h
00178
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: sleepTimer.h File Reference

  • File List
  • Globals

sleepTimer.h File Reference

Declarations of sleepTimer interface. More...

Go to the source code of this file.

Typedefs

typedef Timer_t | HAL_SleepTimer_t
fields of structure
uint32_t interval - timer firing interval (set by user)
TimerMode_t mode - timer work mode (set by user). Must be chosen from:
TIMER_REPEAT_MODE
TIMER_ONE_SHOT_MODE
void (*callback)() - pointer to the timer callback function (set by user)

Functions

uint32_t | HAL_ConvertToSleepInterval (uint32_t interval)
Converts an interval from milliseconds to sleep timer ticks.
int | HAL_StartSleepTimer (HAL_SleepTimer_t *sleepTimer)
Starts sleep timer.
int | HAL_StopSleepTimer (HAL_SleepTimer_t *sleepTimer)
Removes timer.

Detailed Description

Declarations of sleepTimer interface.

Definition in file sleepTimer.h.

Typedef Documentation

typedef Timer_t HAL_SleepTimer_t

fields of structure
uint32_t interval - timer firing interval (set by user)
TimerMode_t mode - timer work mode (set by user). Must be chosen from:
TIMER_REPEAT_MODE
TIMER_ONE_SHOT_MODE
void (*callback)() - pointer to the timer callback function (set by user)

Definition at line 24 of file sleepTimer.h.

Function Documentation

uint32_t HAL_ConvertToSleepInterval ( uint32_t interval )

Converts an interval from milliseconds to sleep timer ticks.

Parameters:
[in] interval - interval in milliseconds.
Returns:
interval in sleep timer ticks.

int HAL_StartSleepTimer ( HAL_SleepTimer_t * sleepTimer )

Starts sleep timer.

Parameters:
[in] interval - interval in ms.
Returns:
-1 - bad interval.
0 - otherwise.

int HAL_StopSleepTimer ( HAL_SleepTimer_t * sleepTimer )

Removes timer.

Parameters:
[in] sleepTimer - address of the timer to be removed from the list
Returns:
-1 - there is no such timer in the list.
0 - otherwise.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: sleepTimer.h Source File

  • File List
  • Globals

sleepTimer.h

Go to the documentation of this file.
00001 /******************************************************************************/
00012 #ifndef SLEEPTIMER_H_
00013 #define SLEEPTIMER_H_
00014
00015 // \cond
00016 #include <timer.h>
00017 // \endcond
00018
00025 typedef Timer_t HAL_SleepTimer_t;
00026
00027 /**************************************************************************/
00034 uint32_t HAL_ConvertToSleepInterval(uint32_t interval);
00035
00036 /**************************************************************************/
00044 int HAL_StartSleepTimer(HAL_SleepTimer_t *sleepTimer);
00045
00046 /**************************************************************************/
00054 int HAL_StopSleepTimer(HAL_SleepTimer_t *sleepTimer);
00055
00056 #endif
00057 // eof sleepTimer.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: sliders.h File Reference

  • File List
  • Globals

sliders.h File Reference

Interface of sliders. More...

Go to the source code of this file.

Functions

uint8_t BSP_ReadSliders ()
Reads the sliders.

Detailed Description

Interface of sliders.

Definition in file sliders.h.

Function Documentation

uint8_t BSP_ReadSliders ( )

Reads the sliders.

Returns:
state of 3 onboard DIP switches. User can use SLIDER0, SLIDER1, SLIDER2 constants to check state. Value 1 indicates that the corresponding slider is on.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: sliders.h Source File

  • File List
  • Globals

sliders.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #ifndef SLIDERS_H_
00014 #define SLIDERS_H_
00015
00016 // \cond
00017 #define SLIDER0 (1 << 0)
00018 #define SLIDER1 (1 << 1)
00019 #define SLIDER2 (1 << 2)
00020 // \endcond
00021
00022 /**************************************************************************/
00029 uint8_t BSP_ReadSliders();
00030
00031 #endif
00032 // eof sliders.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: spi.h File Reference

  • File List
  • Globals

spi.h File Reference

Declaration of USART SPI mode, hardware-independent module. More...

#include <halSpi.h>

Go to the source code of this file.

Functions

int | HAL_OpenSpi (HAL_SpiMode_t *spiMode, void(*callback)())
Opens USART in MSPI mode.
fields of HAL_SpiMode_t structure
SpiClockMode_t clockMode - spi clock mode (set by user). Must be chosen from:
SPI_CLOCK_MODE0
SPI_CLOCK_MODE1
SPI_CLOCK_MODE2
SPI_CLOCK_MODE3
SpiDataOrder_t dataOrder - spi data order (set by user). Must be chosen from:
SPI_DATA_MSB_FIRST
SPI_DATA_LSB_FIRST
SpiBaudRate_t baudRate - spi clock rate (set by user). Must be chosen from:
SPI_CLOCK_RATE_62
SPI_CLOCK_RATE_125
SPI_CLOCK_RATE_250
SPI_CLOCK_RATE_500
.
int | HAL_CloseSpi (void)
Releases the channel and pins.
int | HAL_WriteSpi (uint8_t *buffer, uint8_t length)
Writes a number of bytes to the SPI.
Callback function will be used to notify when the transmission is finished.
The data read are placed to the buffer.

Detailed Description

Declaration of USART SPI mode, hardware-independent module.

Definition in file spi.h.

Function Documentation

int HAL_CloseSpi ( void )

Releases the channel and pins.

Returns:
Returns 0 on success or -1 if channel was not opened.

int HAL_OpenSpi | ( | HAL_SpiMode_t * | spiMode,
 |  | void(*)() | callback
 | ) |  |

Opens USART in MSPI mode.
fields of HAL_SpiMode_t structure
SpiClockMode_t clockMode - spi clock mode (set by user). Must be chosen from:
SPI_CLOCK_MODE0
SPI_CLOCK_MODE1
SPI_CLOCK_MODE2
SPI_CLOCK_MODE3
SpiDataOrder_t dataOrder - spi data order (set by user). Must be chosen from:
SPI_DATA_MSB_FIRST
SPI_DATA_LSB_FIRST
SpiBaudRate_t baudRate - spi clock rate (set by user). Must be chosen from:
SPI_CLOCK_RATE_62
SPI_CLOCK_RATE_125
SPI_CLOCK_RATE_250
SPI_CLOCK_RATE_500
.

Parameters:
[in] spiMode - SPI parametrs (baud rate and frame format).
[in] callback - address of the function to notify the application when a transmission was completed. When the synchronous method is used, callback must be NULL.
Returns:
-1 - there are no free resources.
0 - SPI channel is ready.

int HAL_WriteSpi | ( | uint8_t * | buffer,
 |  | uint8_t | length
 | ) |  |

Writes a number of bytes to the SPI.
Callback function will be used to notify when the transmission is finished.
The data read are placed to the buffer.

Parameters:
[in] | buffer | - pointer to the application data buffer
[in] | length | - number of bytes to transfer
Returns:
-1 - spi module was not opened, or there is unsent data, or the pointer to data or the length are NULL;
0 - success;
Number of written bytes - success (synchronous mode).

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: spi.h Source File

  • File List
  • Globals

spi.h

Go to the documentation of this file.
00001 /****************************************************************************/
00012 #ifndef SPI_H_
00013 #define SPI_H_
00014
00015 #include <halSpi.h>
00016
00017 /**************************************************************************/
00044 int HAL_OpenSpi(HAL_SpiMode_t *spiMode, void (*callback)());
00045
00046 /**************************************************************************/
00051 int HAL_CloseSpi(void);
00052
00053 /**************************************************************************/
00067 int HAL_WriteSpi(uint8_t *buffer, uint8_t length);
00068
00069 #endif
00070 // eof spi.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: taskManager.h File Reference

  • File List
  • Globals

taskManager.h File Reference

The header file describes the public stack Task Manager interface. More...

#include <inttypes.h>
#include <types.h>
#include <atomic.h>

Go to the source code of this file.

Enumerations

enum SYS_TaskId_t {
MAC_PHY_HWD_TASK_ID = 1 << 0, HAL_TASK_ID = 1 << 1, MAC_HWI_TASK_ID = 1 << 2, NWK_TASK_ID = 1 << 3,
ZDO_TASK_ID = 1 << 4, APS_TASK_ID = 1 << 5, SSP_TASK_ID = 1 << 6, TC_TASK_ID = 1 << 7,
BSP_TASK_ID = 1 << 8, APL_TASK_ID = 1 << 9
}
The list of task ID. More...

Functions

void | HAL_TaskHandler (void)
This function is called for processing HAL task. Should be defined in HAL.
void | BSP_TaskHandler (void)
This function is called for processing BSP task. Should be defined in BSP.
void | MAC_PHY_HWD_TaskHandler (void)
This function is called for processing MAC_PHY_HWD task. Should be defined in MAC_PHY_HWD.
void | MAC_HWI_TaskHandler (void)
This function is called for processing MAC_HWI task. Should be defined in MAC_HWI.
void | NWK_TaskHandler (void)
This function is called for processing NWK task. Should be defined in NWK.
void | ZDO_TaskHandler (void)
This function is called for processing ZDO task. Should be defined in ZDO.
void | APS_TaskHandler (void)
This function is called for processing APS task. Should be defined in APS.
void | APL_TaskHandler (void)
void | SSP_TaskHandler (void)
This function is called for processing SSP task. Should be defined in SSP.
void | TC_TaskHandler (void)
This function is called for processing Trust Center task. Should be defined in Trust Center.
static void | SYS_PostTask (SYS_TaskId_t taskId)
Posts task to the stack Task Manager.
bool | SYS_RunTask ()
This function is called by an OS or from main() for processing the stack tasks.

Variables

volatile uint16_t | SYS_taskFlag

Detailed Description

The header file describes the public stack Task Manager interface.

The file describes public interface, task handlers and tasks IDs of Task Manager.

Definition in file taskManager.h.

Enumeration Type Documentation

enum SYS_TaskId_t

The list of task ID.

Enumerator:
MAC_PHY_HWD_TASK_ID
HAL_TASK_ID
MAC_HWI_TASK_ID
NWK_TASK_ID
ZDO_TASK_ID
APS_TASK_ID
SSP_TASK_ID
TC_TASK_ID
BSP_TASK_ID
APL_TASK_ID

Definition at line 22 of file taskManager.h.

Function Documentation

void APL_TaskHandler ( void )

This function is called for processing user application task. Should be defined in user application. Its very first call is intended just for setting parameters into the stack. For starting a network a new task should be posted.

void APS_TaskHandler ( void )

This function is called for processing APS task. Should be defined in APS.

void BSP_TaskHandler ( void )

This function is called for processing BSP task. Should be defined in BSP.

void HAL_TaskHandler ( void )

This function is called for processing HAL task. Should be defined in HAL.

void MAC_HWI_TaskHandler ( void )

This function is called for processing MAC_HWI task. Should be defined in MAC_HWI.

void MAC_PHY_HWD_TaskHandler ( void )

This function is called for processing MAC_PHY_HWD task. Should be defined in MAC_PHY_HWD.

void NWK_TaskHandler ( void )

This function is called for processing NWK task. Should be defined in NWK.

void SSP_TaskHandler ( void )

This function is called for processing SSP task. Should be defined in SSP.

static void SYS_PostTask ( SYS_TaskId_t taskId ) [inline, static]

Posts task to the stack Task Manager.

IDs of the tasks are listed in the SYS_TaskId enum. Each task has its own priority and is called only if there is no any task with higher priority. A handler is called when respective task can be run. Each task has its own task handler. Correspondence between tasks and handlers is listed below:
HAL - HAL_TaskHandler()
BSP - BSP_TaskHandler()
MAC_PHY_HWD - MAC_PHY_HWD_TaskHandler()
MAC_HWI - MAC_HWI_TaskHandler()
NWK - NWK_TaskHandler()
ZDO - ZDO_TaskHandler()
APS - APS_TaskHandler()
APL - APL_TaskHandler()

Parameters:
[in] taskId - ID of the posted task

Definition at line 79 of file taskManager.h.

References SYS_taskFlag.

bool SYS_RunTask ( )

This function is called by an OS or from main() for processing the stack tasks.

void TC_TaskHandler ( void )

This function is called for processing Trust Center task. Should be defined in Trust Center.

void ZDO_TaskHandler ( void )

This function is called for processing ZDO task. Should be defined in ZDO.

Variable Documentation

volatile uint16_t SYS_taskFlag

Referenced by SYS_PostTask().

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: taskManager.h Source File

  • File List
  • Globals

taskManager.h

Go to the documentation of this file.
00001 /*************************************************************************/
00015 #ifndef _TASKMANAGER_H
00016 #define _TASKMANAGER_H
00017 #include <inttypes.h>
00018 #include <types.h>
00019 #include <atomic.h>
00020
00022 typedef enum
00023 {
00024   MAC_PHY_HWD_TASK_ID = 1 << 0,
00025   HAL_TASK_ID         = 1 << 1,
00026   MAC_HWI_TASK_ID     = 1 << 2,
00027   NWK_TASK_ID         = 1 << 3,
00028   ZDO_TASK_ID         = 1 << 4,
00029   APS_TASK_ID         = 1 << 5,
00030   SSP_TASK_ID         = 1 << 6,
00031   TC_TASK_ID          = 1 << 7,
00032   BSP_TASK_ID         = 1 << 8,
00033   APL_TASK_ID         = 1 << 9
00034 } SYS_TaskId_t;
00035
00037 extern void HAL_TaskHandler(void);
00039 extern void BSP_TaskHandler(void);
00041 extern void MAC_PHY_HWD_TaskHandler(void);
00043 extern void MAC_HWI_TaskHandler(void);
00045 extern void NWK_TaskHandler(void);
00047 extern void ZDO_TaskHandler(void);
00049 extern void APS_TaskHandler(void);
00054 extern void APL_TaskHandler(void);
00056 extern void SSP_TaskHandler(void);
00058 extern void TC_TaskHandler(void);
00059
00060 extern volatile uint16_t SYS_taskFlag;
00061
00062 /**************************************************************************************/
00079 static inline void SYS_PostTask(SYS_TaskId_t taskId)
00080 {
00081   ATOMIC_SECTION_ENTER
00082    SYS_taskFlag |= taskId;
00083   ATOMIC_SECTION_LEAVE
00084 }
00085
00086 /**************************************************************************************/
00089 bool SYS_RunTask();
00090
00091 #endif
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: uart.h File Reference

  • File List
  • Globals

uart.h File Reference

Declaration of the uart interface. More...

Go to the source code of this file.

Data Structures

struct | HAL_UartDescriptor_t
Uart descriptor. More...

Functions

int | HAL_OpenUart (HAL_UartDescriptor_t *descriptor)
Registers uart's event handlers. Performs configuration of uart registers. Performs configuration of RTS, CTS and DTR pins.
int | HAL_CloseUart (HAL_UartDescriptor_t *descriptor)
Releases the uart channel and pins, if hardware flow control was used.
int | HAL_WriteUart (HAL_UartDescriptor_t *descriptor, uint8_t *buffer, uint8_t length)
Writes a number of bytes to uart channel. txCallback function will be used to notify when the transmission is finished. If hardware flow control is used for transmitting then RTS and DTR pins will be tested during transmission.
int | HAL_ReadUart (HAL_UartDescriptor_t *descriptor, uint8_t *buffer, uint8_t length)
Reads a number of bytes from uart and places them to the buffer.
int | HAL_OnUartCts (HAL_UartDescriptor_t *descriptor)
Forbids the host to transmit data. Only UART_CHANNEL_1 can be used for hardware flow control.
int | HAL_OffUartCts (HAL_UartDescriptor_t *descriptor)
Allows the host to transmit data. Only UART_CHANNEL_1 can be used for hardware flow control.
int | HAL_ReadUartRts (HAL_UartDescriptor_t *descriptor)
Reads RTS pin state.
int | HAL_ReadUartDtr (HAL_UartDescriptor_t *descriptor)
Reads DTR pin state.
int | HAL_IsTxEmpty (HAL_UartDescriptor_t *descriptor)
Checks the status of tx buffer.
void | HAL_EnableDtrWakeUp (void)
Enables DTR wake up.
void | HAL_DisableDtrWakeUp (void)
Disables DTR wake up.

Detailed Description

Declaration of the uart interface.

Definition in file uart.h.

Function Documentation

int HAL_CloseUart ( HAL_UartDescriptor_t * descriptor )

Releases the uart channel and pins, if hardware flow control was used.

Parameters:
[in] descriptor - pointer to HAL_UartDescriptor_t structure
Returns:
-1 - bad descriptor;
0 - success.

void HAL_DisableDtrWakeUp ( void )

Disables DTR wake up.

void HAL_EnableDtrWakeUp ( void )

Enables DTR wake up.

int HAL_IsTxEmpty ( HAL_UartDescriptor_t * descriptor )

Checks the status of tx buffer.

Parameters:
[in] descriptor - pointer to HAL_UartDescriptor_t structure;
Returns:
-1 - bad descriptor, no tx buffer;
1 - tx buffer is empty;
0 - tx buffer is not empty;

int HAL_OffUartCts ( HAL_UartDescriptor_t * descriptor )

Allows the host to transmit data. Only UART_CHANNEL_1 can be used for hardware flow control.

Parameters:
[in] descriptor - pointer to HAL_UartDescriptor_t structure;
Returns:
-1 - bad descriptor, bad uart, or unsupported mode;
0 - success.

int HAL_OnUartCts ( HAL_UartDescriptor_t * descriptor )

Forbids the host to transmit data. Only UART_CHANNEL_1 can be used for hardware flow control.

Parameters:
[in] descriptor - pointer to HAL_UartDescriptor_t structure;
Returns:
-1 - bad descriptor, bad uart, or unsupported mode;
0 - success.

int HAL_OpenUart ( HAL_UartDescriptor_t * descriptor )

Registers uart's event handlers. Performs configuration of uart registers. Performs configuration of RTS, CTS and DTR pins.

Parameters:
[in] descriptor - pointer to HAL_UartDescriptor_t structure
Returns:
Returns positive uart descriptor on success or -1 in cases:
  • bad uart channel;
  • not enough resources;

int HAL_ReadUart | ( | HAL_UartDescriptor_t * | descriptor,
 |  | uint8_t * | buffer,
 |  | uint8_t | length
 | ) |  |

Reads a number of bytes from uart and places them to the buffer.

Parameters:
[in] | descriptor | - pointer to HAL_UartDescriptor_t structure;
[in] | buffer | - pointer to the application buffer;
[in] | length | - number of bytes to be placed to the buffer;
Returns:
-1 - bad descriptor, or bad number of bytes to read;
Number of bytes placed to the buffer - success.

int HAL_ReadUartDtr ( HAL_UartDescriptor_t * descriptor )

Reads DTR pin state.

Parameters:
[in] descriptor - pointer to HAL_UartDescriptor_t structure;
Returns:
-1 - bad descriptor, bad uart, or unsupported mode;
0 - DTR is low level;
1 - DTR is high level;

int HAL_ReadUartRts ( HAL_UartDescriptor_t * descriptor )

Reads RTS pin state.

Parameters:
[in] descriptor - pointer to HAL_UartDescriptor_t structure;
Returns:
-1 - bad descriptor, bad uart, or unsupported mode;
0 - RTS is low level;
1 - RTS is high level;

int HAL_WriteUart | ( | HAL_UartDescriptor_t * | descriptor,
 |  | uint8_t * | buffer,
 |  | uint8_t | length
 | ) |  |

Writes a number of bytes to uart channel. txCallback function will be used to notify when the transmission is finished. If hardware flow control is used for transmitting then RTS and DTR pins will be tested during transmission.

Parameters:
[in] | descriptor | - pointer to HAL_UartDescriptor_t structure;
[in] | buffer | - pointer to the application data buffer;
[in] | length | - number of bytes to transfer;
Returns:
-1 - bad descriptor;
Number of bytes placed to the buffer - success.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: uart.h Source File

  • File List
  • Globals

uart.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #ifndef _UART_H
00014 #define _UART_H
00015
00016 /******************************************************************************
00017                    Includes section
00018 ******************************************************************************/
00019 // \cond
00020 #include <halUart.h>
00021
00022 /******************************************************************************
00023                    Define(s) section
00024 ******************************************************************************/
00025 #define UART_FLOW_CONTROL_NONE 0
00026 #define UART_FLOW_CONTROL_HARDWARE 1
00027 #define UART_DTR_CONTROL 2
00028 // this define is used only by HAL.
00029 #define USART_SPI_MODE 16
00030
00031 #ifndef NUM_USART_CHANNELS
00032 #define NUM_USART_CHANNELS 1 // Number of USART channels
00033 #endif
00034 // \endcond
00035
00036 /******************************************************************************
00037                    Types section
00038 ******************************************************************************/
00040 typedef struct
00041 {
00044   uint8_t tty;
00049   UartMode_t mode;
00060   UartBaudRate_t baudrate;
00066   UartData_t dataLength;
00071   UartParity_t parity;
00075   UartStopBits_t stopbits;
00079   UartSyncMode_t edge;
00081   UartClckMode_t syncMode;
00085   uint8_t *rxBuffer;
00087   uint16_t rxBufferLength;
00091   uint8_t *txBuffer;
00093   uint16_t txBufferLength;
00097   void (*rxCallback)(uint8_t);
00100   void (*txCallback)();
00102   uint8_t flowControl;
00103 } HAL_UartDescriptor_t;
00104
00105 /******************************************************************************
00106                    Prototypes section
00107 ******************************************************************************/
00108 /**************************************************************************/
00120 int HAL_OpenUart(HAL_UartDescriptor_t *descriptor);
00121
00122 /*************************************************************************/
00132 int HAL_CloseUart(HAL_UartDescriptor_t *descriptor);
00133
00134 /**************************************************************************/
00153 int HAL_WriteUart(HAL_UartDescriptor_t *descriptor, uint8_t *buffer, uint8_t length);
00154
00155 /*************************************************************************/
00171 int HAL_ReadUart(HAL_UartDescriptor_t *descriptor, uint8_t *buffer, uint8_t length);
00172
00173 /**************************************************************************/
00184 int HAL_OnUartCts(HAL_UartDescriptor_t *descriptor);
00185
00186 /**************************************************************************/
00197 int HAL_OffUartCts(HAL_UartDescriptor_t *descriptor);
00198
00199 /**************************************************************************/
00210 int HAL_ReadUartRts(HAL_UartDescriptor_t *descriptor);
00211
00212 /**************************************************************************/
00223 int HAL_ReadUartDtr(HAL_UartDescriptor_t *descriptor);
00224
00225 /**************************************************************************/
00236 int HAL_IsTxEmpty(HAL_UartDescriptor_t *descriptor);
00237
00238 /**************************************************************************/
00241 void HAL_EnableDtrWakeUp(void);
00242
00243 /**************************************************************************/
00246 void HAL_DisableDtrWakeUp(void);
00247
00248 #endif /* _UART_H */
00249 // eof uart.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: uid.h File Reference

  • File List
  • Globals

uid.h File Reference

Declaration of the UID interface. More...

#include <types.h>

Go to the source code of this file.

Functions

int HAL_ReadUid (uint64_t *id)
UID discovery.

Detailed Description

Declaration of the UID interface.

Definition in file uid.h.

Function Documentation

int HAL_ReadUid ( uint64_t * id )

UID discovery.

Parameters:
[in] id - UID buffer pointer.
Attention! Memory size must be equal to (Number of devices) * 8 bytes
Returns:
0 - if UID of DS2411 has been found successfully;
-1 - if some error occured during UID discovery.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: uid.h Source File

  • File List
  • Globals

uid.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #ifndef UID_H_
00014 #define UID_H_
00015
00016 // \cond
00017 #include <inttypes.h>
00018 #include <types.h>
00019 // \endcond
00020
00021 /************************************************************/
00030 int HAL_ReadUid(uint64_t *id);
00031
00032 #endif /* UID_H_ */
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: w1.h File Reference

  • File List
  • Globals

w1.h File Reference

Declaration of the 1-Wire interface. More...

Go to the source code of this file.

Functions

W1Status_t | HAL_SearchW1Device (uint8_t family, uint8_t *data, uint8_t count, uint8_t *actCount)
1-Wire search procedure with search ROM command only
W1Status_t | HAL_AlarmSearchW1Device (uint8_t family, uint8_t *data, uint8_t count, uint8_t *actCount)
1-Wire search procedure with alarm search command only
uint8_t | HAL_ResetW1 (void)
Resets all devices connected to the bus.
void | HAL_WriteW1 (uint8_t value)
Writes a single byte to the bus.
uint8_t | HAL_ReadW1 (void)
Reads a single byte from the bus.

Detailed Description

Declaration of the 1-Wire interface.

Definition in file w1.h.

Function Documentation

W1Status_t HAL_AlarmSearchW1Device | ( | uint8_t | family,
 |  | uint8_t * | data,
 |  | uint8_t | count,
 |  | uint8_t * | actCount
 | ) |  |

1-Wire search procedure with alarm search command only

Parameters:
[in] | family | - 8-bit family code.
[in] data - pointer of SRAM where the 8-bytes ROM codes returned by the devices are stored.
[in] | count | - number of devices we wish to find.
[in] | actCount | - number of devices actually found.
Returns:
W1_SUCCESS_STATUS - if at least one device has been found.
W1_NO_DEVICE_STATUS - if there are no any devices presented on the bus with specified family code.
W1_INVALID_CRC - if an invalid CRC has been read during the search and no devices with specified family code was found.

uint8_t HAL_ReadW1 ( void )

Reads a single byte from the bus.

Returns:
byte read from the bus.

uint8_t HAL_ResetW1 ( void )

Resets all devices connected to the bus.

Returns:
0 - there are some devices at the bus.
1 - there are no devices at the bus.

W1Status_t HAL_SearchW1Device | ( | uint8_t | family,
 |  | uint8_t * | data,
 |  | uint8_t | count,
 |  | uint8_t * | actCount
 | ) |  |

1-Wire search procedure with search ROM command only

Parameters:
[in] | family | - 8-bit family code.
[in] data - pointer of SRAM where the 8-bytes ROM codes returned by the devices are stored.
Attention! Memory size must be equal to (Number of devices) * 8 bytes
[in] | count | - number of devices we wish to find.
[in] | actCount | - number of devices actually found.
Returns:
W1_SUCCESS_STATUS - if at least one device has been found.
W1_NO_DEVICE_STATUS - if there are no any devices presented on the bus with specified family code.
W1_INVALID_CRC - if an invalid CRC has been read during the search and no devices with specified family code was found.

void HAL_WriteW1 ( uint8_t value )

Writes a single byte to the bus.

Parameters:
[in] value - byte to write.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: w1.h Source File

  • File List
  • Globals

w1.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #ifndef W1_H_
00014 #define W1_H_
00015
00016 // \cond
00017 #include <inttypes.h>
00018
00019 #define W1_ANY_FAMILY 0x00
00020 #define DS2411 0x01
00021
00022 // w1 status
00023 typedef enum
00024 {
00025   W1_NO_DEVICE_STATUS, // There is no device on the bus
00026   W1_SUCCESS_STATUS,   // At least one device is on the bus
00027   W1_INVALID_CRC       // Invalid CRC was read during the device search operation
00028 } W1Status_t;
00029 // \endcond
00030
00031 /*************************************************************************/
00050 W1Status_t HAL_SearchW1Device(uint8_t family,
00051                               uint8_t *data,
00052                               uint8_t count,
00053                               uint8_t *actCount);
00054
00055 /**************************************************************************/
00073 W1Status_t HAL_AlarmSearchW1Device(uint8_t family,
00074                                    uint8_t *data,
00075                                    uint8_t count,
00076                                    uint8_t *actCount);
00077
00078 /***************************************************************************/
00084 uint8_t HAL_ResetW1(void);
00085
00086 /***************************************************************************/
00091 void HAL_WriteW1(uint8_t value);
00092
00093 /***************************************************************************/
00098 uint8_t HAL_ReadW1(void);
00099
00100 // \cond
00101 /****************************************************************************
00102  Calculating 1-Wire 8-bit CRC
00103  Parameters:
00104    data   - data buffer pointer.
00105    length - data length.
00106  Returns:
00107    CRC value based on polynomial x<sup>8</sup> + x<sup>5</sup> + x<sup>4</sup> + 1
00108 ******************************************************************************/
00109 uint8_t halW1CRC(uint8_t *data, uint8_t length);
00110 // \endcond
00111
00112 #endif /* W1_H_ */
00113 // eof w1.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: wdtCtrl.h File Reference

  • File List
  • Globals

wdtCtrl.h File Reference

Declaration of the WDT interface. More...

#include <avr/wdt.h>

Go to the source code of this file.

Functions

void | HAL_StartWdt (HAL_WdtInterval_t interval)
Starts WDT within a given interval.
void | HAL_RegisterWdtCallback (void(*wdtCallback)())
Registers WDT fired callback.
static void | HAL_StopWdt (void)
Stops the WDT.
static void | HAL_ResetWdt (void)
Resets the WDT.

Detailed Description

Declaration of the WDT interface.

Definition in file wdtCtrl.h.

Function Documentation

void HAL_RegisterWdtCallback ( void(*)() wdtCallback )

Registers WDT fired callback.

Registered functions is called when WDT is fired. After returning from the registered function device is rebooted itself.

Parameters:
[in] wdtCallback - pointer to the callback function.

static void HAL_ResetWdt ( void ) [inline, static]

Resets the WDT.

Definition at line 73 of file wdtCtrl.h.

void HAL_StartWdt ( HAL_WdtInterval_t interval )

Starts WDT within a given interval.

Parameters:
[in] interval - interval. Must be chosen from:
WDT_INTERVAL_16 // 16 ms
WDT_INTERVAL_32 // 32 ms
WDT_INTERVAL_64 // 64 ms
WDT_INTERVAL_125 // 125 ms
WDT_INTERVAL_250 // 250 ms
WDT_INTERVAL_500 // 500 ms
WDT_INTERVAL_1000 // 1 second
WDT_INTERVAL_2000 // 2 seconds
WDT_INTERVAL_4000 // 4 seconds
WDT_INTERVAL_8000 // 8 seconds

static void HAL_StopWdt ( void ) [inline, static]

Stops the WDT.

Definition at line 65 of file wdtCtrl.h.

Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: wdtCtrl.h Source File

  • File List
  • Globals

wdtCtrl.h

Go to the documentation of this file.
00001 /******************************************************************************/
00013 #include <avr/wdt.h>
00014
00015 #ifndef HALWDTCTRL_H
00016 #define HALWDTCTRL_H
00017
00018 // \cond
00019 // WDT expiration interval
00020 typedef enum
00021 {
00022   WDT_INTERVAL_16 = 0, // 16 ms
00023   WDT_INTERVAL_32,     // 32 ms
00024   WDT_INTERVAL_64,     // 64 ms
00025   WDT_INTERVAL_125,    // 125 ms
00026   WDT_INTERVAL_250,    // 250 ms
00027   WDT_INTERVAL_500,    // 500 ms
00028   WDT_INTERVAL_1000,   // 1 second
00029   WDT_INTERVAL_2000,   // 2 seconds
00030   WDT_INTERVAL_4000,   // 4 seconds
00031   WDT_INTERVAL_8000    // 8 seconds
00032 }HAL_WdtInterval_t;
00033 // \endcond
00034
00035 /***************************************************************************/
00051 void HAL_StartWdt(HAL_WdtInterval_t interval);
00052
00053 /***************************************************************************/
00061 void HAL_RegisterWdtCallback(void (*wdtCallback)());
00062
00063 /*******************************************************************/
00066 static inline void HAL_StopWdt(void)
00067 {
00068   wdt_disable();
00069 }
00070
00071 /*******************************************************************/
00074 static inline void HAL_ResetWdt(void)
00075 {
00076   wdt_reset();
00077 }
00078
00079 #endif
00080
00081 // eof wdtCtrl.h
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: zdo.h File Reference

  • File List
  • Globals

zdo.h File Reference

The header file describes the public ZDO interface. More...

#include <macAddr.h>
#include <appFramework.h>
#include <aps.h>
#include <configServer.h>

Go to the source code of this file.

Data Structures

struct | ZDO_StartNetworkConf_t
Describes the parameters of the ZDO_StartNetworkConf() function. More...
struct | ZDO_StartNetworkReq_t
Describes the parameters of the ZDO_StartNetworkReq() function. More...
struct | ZDO_ResetNetworkConf_t
Desribes the parameters of the ZDO_ResetNetworkConf() function. More...
struct | ZDO_ResetNetworkReq_t
Describes the parameters of the ZDO_ResetNetworkReq() function. More...
struct | EDScan_t
struct | NetworkInf_t
struct | ZDO_MgmtNwkUpdateNotf_t
struct | ZDO_SleepConf_t
struct | ZDO_SleepReq_t
struct | ZDO_WakeUpConf_t
struct | ZDO_WakeUpReq_t
struct | ZDO_NwkAddrReq_t
struct | ZDO_IeeeAddrReq_t
struct | ZDO_NodeDescReq_t
struct | ZDO_PowerDescReq_t
struct | ZDO_ActiveEPReq_t
struct | ZDO_ComplexDescReq_t
struct | ZDO_UserDescReq_t
struct | ZDO_UserDescSetReq_t
struct | ZDO_SimpleDescReq_t
struct | ZDO_DeviceAnnceReq_t
struct | ZDO_SystemServerDiscoveryReq_t
struct | ZDO_MgmtLeaveReq_t
struct | ZDO_MgmtPermitJoiningReq_t
struct | ZDO_MgmtNwkUpdateReq_t
struct | ZDO_NwkAddrResp_t
struct | ZDO_IeeeAddrResp_t
struct | ZDO_NodeDescResp_t
struct | ZDO_PowerDescResp_t
struct | ZDO_ComplexDescResp_t
struct | ZDO_UserDescResp_t
struct | ZDO_UserDescConfResp_t
struct | ZDO_ActiveEPResp_t
struct | ZdpSimpleDescriptor_t
struct | ZDO_SimpleDescResp_t
struct | ZDO_SystemServerDiscoveryResp_t
struct | ZDO_ZdpRespFrame_t
struct | ZDO_ZdpReqFrame_t
struct | ZDO_ZdpFrame_t
struct | ZDO_ZdpResp_t
struct | ZDO_ZdpReq_t
struct | NodeAddr_t
struct | ZDO_GetLqiRssi_t
Describes the parameters of the ZDO_LqiRssiReq() function. More...
struct | ZDO_GetChildrenAddr_t
Describes the parameters of the ZDO_ChildrenAddrReq() function. More...
struct | ZDO_SetTxPowerConf_t
Describes the parameters of the ZDO_SetTxPowerConf() function. More...
struct | ZDO_SetTxPowerReq_t
Describes the parameters of the ZDO_SetTxPowerReq() function. More...
struct | ZDO_EndToEndAppKeyConf_t
struct | ZDO_EndToEndAppKeyReq_t

Enumerations

enum | NetLostReason_t { LEAVED_BY_PARENT, LINK_FAIL, LEAVE_REQ }
enum ZDO_Status_t {
ZDO_SUCCESS_STATUS = 0x00, ZDO_INVALID_PARAMETERS_STATUS = 0x01, ZDO_NOT_PERMITTED_STATUS = 0x03, ZDO_BUSY_STATUS = 0x04,
ZDO_NO_NETWORKS_STATUS = 0x05, ZDO_EXTPANID_ALREADY_EXIST_STATUS = 0x06, ZDO_FAIL_STATUS = 0x07, ZDO_AUTHENTICATION_SUCCESS_STATUS = 0x08,
ZDO_AUTHENTICATION_FAIL_STATUS = 0x09, ZDO_SECURITY_SUCCESS_STATUS = 0x0A, ZDO_SECURITY_FAIL_STATUS = 0x0B, ZDO_SECURITY_NOT_SUPPORTED_STATUS = 0x0C,
ZDO_CMD_COMPLETED_STATUS = 0x0D, ZDO_INVALID_REQUEST_STATUS = 0x80, ZDO_DEVICE_NOT_FOUND_STATUS = 0x81, ZDO_INVALID_EP_STATUS = 0x82,
ZDO_NOT_ACTIVE_STATUS = 0x83, ZDO_NOT_SUPPORTED_STATUS = 0x84, ZDO_TIMEOUT_STATUS = 0x85, ZDO_NO_MATCH_STATUS = 0x86,
ZDO_NO_ENTRY_STATUS = 0x88, ZDO_NO_DESCRIPTOR_STATUS = 0x89, ZDO_INSUFFICIENT_SPACE_STATUS = 0x8A, ZDO_RESPONSE_WAIT_TIMEOUT_STATUS = 0x8B,
ZDO_TABLE_FULL_STATUS = 0x8C, ZDO_NOT_AUTHORIZED_STATUS = 0x8D, ZDO_NWK_UPDATE_STATUS = 0x8E, ZDO_NETWORK_STARTED_STATUS = 0x8F,
ZDO_NETWORK_LOST_STATUS = 0x90, ZDO_REJOIN_STARTED_STATUS = 0x91, ZDO_NETWORK_LEFT_STATUS = 0x92
}
ZDO result status primitives. More...
enum | { SINGLE_RESPONSE_REQUESTTYPE = 0x00, EXTENDED_RESPONSE_REQUESTTYPE = 0x01 }
enum ZDO_ZdpClusterId_t {
NWK_ADDR_CLID = 0x0000, IEEE_ADDR_CLID = 0x0001, NODE_DESCRIPTOR_CLID = 0x0002, POWER_DESCRIPTOR_CLID = 0x0003,
SIMPLE_DESCRIPTOR_CLID = 0x0004, ACTIVE_ENDPOINTS_CLID = 0x0005, MATCH_DESCRIPTOR_CLID = 0x0006, COMPLEX_DESCRIPTOR_CLID = 0x0010,
USER_DESCRIPTOR_CLID = 0x0011, DISCOVERY_CASH_CLID = 0x0012, DEVICE_ANNCE_CLID = 0x0013, USER_DESC_CONF_CLID = 0x0014,
SYSTEM_SERVER_DISCOVERY_CLID = 0x0015, DISCOVERY_STORE_CLID = 0x0016, NODE_DESC_STORE_CLID = 0x0017, POWER_DESC_STORE_CLID = 0x0018,
ACTIVE_EP_STORE_CLID = 0x0019, SIMPLE_DESC_STORE_CLID = 0x001A, REMOVE_NODE_CACHE_CLID = 0x001B, FIND_NODE_CACHE_CLID = 0x001C,
EXTENDED_SIMPLE_DESC_CLID = 0x001D, EXTENDED_ACTIVE_EP_CLID = 0x001E, END_DEVICE_BIND_CLID = 0x0020, BIND_CLID = 0x0021,
UNBIND_CLID = 0x0022, BIND_REGISTER_CLID = 0x0023, REPLACE_DEVICE_CLID = 0x0024, STORE_BCKUP_BIND_ENTRY_CLID = 0x0025,
REMOVE_BCKUP_BIND_ENTRY_CLID = 0x0026, BACKUP_BIND_TABLE_CLID = 0x0027, RECOVER_BIND_TABLE_CLID = 0x0028, BACKUP_SOURCE_BIND_CLID = 0x0029,
RECOVER_SOURCE_BIND_CLID = 0x002A, MGMT_NWK_DISC_CLID = 0x0030, MGMT_LQI_CLID = 0x0031, MGMT_RTG_CLID = 0x0032,
MGMT_BIND_CLID = 0x0033, MGMT_LEAVE_CLID = 0x0034, MGMT_DIRECT_JOIN_CLID = 0x0035, MGMT_PERMIT_JOINING_CLID = 0x0036,
MGMT_CACHE_CLID = 0x0037, MGMT_NWK_UPDATE_CLID = 0x0038
}
The ZDP clusters ID list. More...
enum | AddrMode_t { SHORT_ADDR_MODE, EXT_ADDR_MODE }
enum | ZDO_NwkStatus_t { ZDO_IN_NETWORK_STATUS, ZDO_OUT_NETWORK_STATUS }
List of network status. More...

Functions

void | ZDO_StartNetworkReq (ZDO_StartNetworkReq_t *startingParams)
Starts network for coordinator and joins the network for router.
void | ZDO_ResetNetworkReq (ZDO_ResetNetworkReq_t *resetParams)
Resets the stack without any commands to the network.
void | ZDO_MgmtNwkUpdateNotf (ZDO_MgmtNwkUpdateNotf_t *nwkParams)
Indicates about network parameters update.
void | ZDO_SleepReq (ZDO_SleepReq_t *req)
Puts the device to sleep mode.
void | ZDO_SleepInd (void)
Indicates to an application that the stack is ready to sleep.
void | ZDO_SleepResp (void)
Responds to the stack that an application is ready to sleep.
void | ZDO_WakeUpInd (void)
Indicates to an application that the stack sleep timer has fired.
void | ZDO_WakeUpReq (ZDO_WakeUpReq_t *req)
Forces the stack to wake up from the sleep mode.
void | ZDO_ZdpReq (ZDO_ZdpReq_t *zdpReq)
void | ZDO_GetLqiRssi (ZDO_GetLqiRssi_t *lqiRssi)
Request of LQI and RSSI.
void | ZDO_GetParentAddr (NodeAddr_t *parentAddr)
Request of parent information.
void | ZDO_GetChildrenAddr (ZDO_GetChildrenAddr_t *childrenAddr)
Request of children information.
void | ZDO_SetTxPowerReq (ZDO_SetTxPowerReq_t *req)
Setting of tx power.
ZDO_NwkStatus_t ZDO_GetNwkStatus ()
Gets network status.

Detailed Description

The header file describes the public ZDO interface.

The file describes the public interface and types of ZDO

Definition in file zdo.h.

Enumeration Type Documentation

anonymous enum

Enumerator:
SINGLE_RESPONSE_REQUESTTYPE
EXTENDED_RESPONSE_REQUESTTYPE

Definition at line 104 of file zdo.h.

enum AddrMode_t

Enumerator:
SHORT_ADDR_MODE
EXT_ADDR_MODE

Definition at line 164 of file zdo.h.

enum NetLostReason_t

Enumerator:
LEAVED_BY_PARENT
LINK_FAIL
LEAVE_REQ

Definition at line 39 of file zdo.h.

enum ZDO_NwkStatus_t

List of network status.

Enumerator:
ZDO_IN_NETWORK_STATUS | device is in network
ZDO_OUT_NETWORK_STATUS | device is out of network

Definition at line 593 of file zdo.h.

enum ZDO_Status_t

ZDO result status primitives.

Enumerator:
ZDO_SUCCESS_STATUS | The primitive has finished successfully.
ZDO_INVALID_PARAMETERS_STATUS | Wrong parameters were put into primitive.
ZDO_NOT_PERMITTED_STATUS | Calling a primitive is not permited.
ZDO_BUSY_STATUS | ZDO layer is busy and cannot execute primitive.
ZDO_NO_NETWORKS_STATUS | No network was found.
ZDO_EXTPANID_ALREADY_EXIST_STATUS | There is a network with the same extended PANID.
ZDO_FAIL_STATUS | Unknown error.
ZDO_AUTHENTICATION_SUCCESS_STATUS
ZDO_AUTHENTICATION_FAIL_STATUS
ZDO_SECURITY_SUCCESS_STATUS
ZDO_SECURITY_FAIL_STATUS
ZDO_SECURITY_NOT_SUPPORTED_STATUS
ZDO_CMD_COMPLETED_STATUS
ZDO_INVALID_REQUEST_STATUS | ZDP request is invalid.
ZDO_DEVICE_NOT_FOUND_STATUS | The requested device has not been found.
ZDO_INVALID_EP_STATUS | Unsupported endpoint of 0x00 or between 0xF1 and 0xFF was requested.
ZDO_NOT_ACTIVE_STATUS | The requested endpoint has not been registered.
ZDO_NOT_SUPPORTED_STATUS | The requested optional feature is not supported.
ZDO_TIMEOUT_STATUS | A timeout has occured during the requested operation.
ZDO_NO_MATCH_STATUS | The end device bind request was unsuccessful due to a failure to match any suitable clusters.
ZDO_NO_ENTRY_STATUS | Unbind request was unsuccessful.
ZDO_NO_DESCRIPTOR_STATUS | A child descriptor was not available.
ZDO_INSUFFICIENT_SPACE_STATUS | The device does not have enough storage space.
ZDO_RESPONSE_WAIT_TIMEOUT_STATUS
ZDO_TABLE_FULL_STATUS | The device does not have enough table space.
ZDO_NOT_AUTHORIZED_STATUS | The request is not authorized from this device.
ZDO_NWK_UPDATE_STATUS | Network parameters has been updated.
ZDO_NETWORK_STARTED_STATUS
ZDO_NETWORK_LOST_STATUS
ZDO_REJOIN_STARTED_STATUS
ZDO_NETWORK_LEFT_STATUS

Definition at line 49 of file zdo.h.

enum ZDO_ZdpClusterId_t

The ZDP clusters ID list.

The ZDP cluster ID determines the type of ZDP request/confirm

Enumerator:
NWK_ADDR_CLID
IEEE_ADDR_CLID
NODE_DESCRIPTOR_CLID
POWER_DESCRIPTOR_CLID
SIMPLE_DESCRIPTOR_CLID
ACTIVE_ENDPOINTS_CLID
MATCH_DESCRIPTOR_CLID
COMPLEX_DESCRIPTOR_CLID
USER_DESCRIPTOR_CLID
DISCOVERY_CASH_CLID
DEVICE_ANNCE_CLID
USER_DESC_CONF_CLID
SYSTEM_SERVER_DISCOVERY_CLID
DISCOVERY_STORE_CLID
NODE_DESC_STORE_CLID
POWER_DESC_STORE_CLID
ACTIVE_EP_STORE_CLID
SIMPLE_DESC_STORE_CLID
REMOVE_NODE_CACHE_CLID
FIND_NODE_CACHE_CLID
EXTENDED_SIMPLE_DESC_CLID
EXTENDED_ACTIVE_EP_CLID
END_DEVICE_BIND_CLID
BIND_CLID
UNBIND_CLID
BIND_REGISTER_CLID
REPLACE_DEVICE_CLID
STORE_BCKUP_BIND_ENTRY_CLID
REMOVE_BCKUP_BIND_ENTRY_CLID
BACKUP_BIND_TABLE_CLID
RECOVER_BIND_TABLE_CLID
BACKUP_SOURCE_BIND_CLID
RECOVER_SOURCE_BIND_CLID
MGMT_NWK_DISC_CLID
MGMT_LQI_CLID
MGMT_RTG_CLID
MGMT_BIND_CLID
MGMT_LEAVE_CLID
MGMT_DIRECT_JOIN_CLID
MGMT_PERMIT_JOINING_CLID
MGMT_CACHE_CLID
MGMT_NWK_UPDATE_CLID

Definition at line 115 of file zdo.h.

Function Documentation

void ZDO_GetChildrenAddr ( ZDO_GetChildrenAddr_t * childrenAddr )

Request of children information.

This function requests children information of the node.

Parameters:
[in] req - Determines the parameters of the request.

void ZDO_GetLqiRssi ( ZDO_GetLqiRssi_t * lqiRssi )

Request of LQI and RSSI.

This function requests LQI and RSSI of an remote node.

Parameters:
[in] req - Determines the parameters of the request.

ZDO_NwkStatus_t ZDO_GetNwkStatus ( )

Gets network status.

This function returns network status.

Returns:
- network status

void ZDO_GetParentAddr ( NodeAddr_t * parentAddr )

Request of parent information.

This function requests parent information of the node.

Parameters:
[in] req - Determines the parameters of the request.

void ZDO_MgmtNwkUpdateNotf ( ZDO_MgmtNwkUpdateNotf_t * nwkParams )

Indicates about network parameters update.

The function should be defined by an application. It is called when the device has resolved address/panid conflict or rejoined the network

Parameters:
[out] nwkUpdateParams - Describes the reason of network update and new parameters.

void ZDO_ResetNetworkReq ( ZDO_ResetNetworkReq_t * resetParams )

Resets the stack without any commands to the network.

This function resets the stack to default state. No data is send to the network.

Parameters:
[in] resetParams - Determines the parameters of the request

void ZDO_SetTxPowerReq ( ZDO_SetTxPowerReq_t * req )

Setting of tx power.

This function sets tx power.

Parameters:
[in] req - Determines the parameters of the request.

void ZDO_SleepInd ( void )

Indicates to an application that the stack is ready to sleep.

After this function the stack is waiting for response. An application should stop and close all HW activities, sending data and commands to the stack and wait all confirmations from the stack, after which the application should call ZDO_SleepResp.

void ZDO_SleepReq ( ZDO_SleepReq_t * req )

Puts the device to sleep mode.

This function can be used only when the active period in Config Server is set to 0. The time of sleep period is determined by CS_END_DEVICE_SLEEP_PERIOD in Config Server.

Parameters:
[in] sleepParams - Determines the sleep parameters.

void ZDO_SleepResp ( void )

Responds to the stack that an application is ready to sleep.

The function should be called in response to ZDO_SleepInd. It can be called only after stopping all HW and stack activities. On receiving this function call, stack goes to sleep mode.

void ZDO_StartNetworkReq ( ZDO_StartNetworkReq_t * startingParams )

Starts network for coordinator and joins the network for router.

This function forms a network for coordinator and joins an existing network for router or end device.

Parameters:
[in] startingParams - Determines the network parameters for join and formation

void ZDO_WakeUpInd ( void )

Indicates to an application that the stack sleep timer has fired.

If the stack is in sleep mode, it wakes up and is ready to work. Application can continue its activities.

void ZDO_WakeUpReq ( ZDO_WakeUpReq_t * req )

Forces the stack to wake up from the sleep mode.

This function is used by an application when the sleep timer is not used and an application is woken up from sleep mode by an external interrupt.

Parameters:
[in] wakeUpParams - Determines the parameters of the wakeup request

void ZDO_ZdpReq ( ZDO_ZdpReq_t * zdpReq )


ZigBeeNet Stack Documentation: zdo.h Source File

  • File List
  • Globals

zdo.h

Go to the documentation of this file.
00001
00009 #ifndef _ZDO_H
00010 #define _ZDO_H
00011
00012 #include <macAddr.h>
00013 #include <appFramework.h>
00014 #include <aps.h>
00015 #include <configServer.h>
00016
00017 #define ZDP_REQUEST_MASK  0x7FFF
00018 #define ZDP_RESPONSE_MASK 0x8000
00019
00020 #ifdef _SECURITY_
00021 #define PRECONFIGURED_NETWORK_KEY 0
00022 #define PRECONFIGURED_TRUST_CENTER_LINK_KEY 1
00023 #define PRECONFIGURED_TRUST_CENTER_MASTER_KEY 2
00024 #define NOT_PRECONFIGURED 3
00025
00026 #ifndef ZDO_SECURITY_STATUS
00027 #define ZDO_SECURITY_STATUS NOT_PRECONFIGURED
00028 #endif //ZDO_SECURITY_STATUS
00029
00030
00031 #define ZDO_NONE_SECURITY_MODE     0
00032 #define ZDO_STANDARD_SECURITY_MODE 1
00033 #define ZDO_HIGH_SECURITY_MODE     2
00034 #endif//_SECURITY_
00035
00036 #define MAX_REQUESTED_CLUSTER_NUMBER 9
00037 #define MAX_ACTIVE_EP_NUMBER 3
00038
00039 typedef enum
00040 {
00041   LEAVED_BY_PARENT,
00042   LINK_FAIL,
00043   LEAVE_REQ
00044 } NetLostReason_t;
00045
00049 typedef enum
00050 {
00052   ZDO_SUCCESS_STATUS                = 0x00,
00054   ZDO_INVALID_PARAMETERS_STATUS     = 0x01,
00056   ZDO_NOT_PERMITTED_STATUS          = 0x03,
00058   ZDO_BUSY_STATUS                   = 0x04,
00060   ZDO_NO_NETWORKS_STATUS            = 0x05,
00062   ZDO_EXTPANID_ALREADY_EXIST_STATUS = 0x06,
00064   ZDO_FAIL_STATUS                   = 0x07,
00065   ZDO_AUTHENTICATION_SUCCESS_STATUS = 0x08,
00066   ZDO_AUTHENTICATION_FAIL_STATUS    = 0x09,
00067   ZDO_SECURITY_SUCCESS_STATUS       = 0x0A,
00068   ZDO_SECURITY_FAIL_STATUS          = 0x0B,
00069   ZDO_SECURITY_NOT_SUPPORTED_STATUS = 0x0C,
00070   ZDO_CMD_COMPLETED_STATUS          = 0x0D,
00072   ZDO_INVALID_REQUEST_STATUS        = 0x80,
00074   ZDO_DEVICE_NOT_FOUND_STATUS       = 0x81,
00076   ZDO_INVALID_EP_STATUS             = 0x82,
00078   ZDO_NOT_ACTIVE_STATUS             = 0x83,
00080   ZDO_NOT_SUPPORTED_STATUS          = 0x84,
00082   ZDO_TIMEOUT_STATUS                = 0x85,
00084   ZDO_NO_MATCH_STATUS               = 0x86,
00086   ZDO_NO_ENTRY_STATUS               = 0x88,
00088   ZDO_NO_DESCRIPTOR_STATUS          = 0x89,
00090   ZDO_INSUFFICIENT_SPACE_STATUS     = 0x8A,
00091   ZDO_RESPONSE_WAIT_TIMEOUT_STATUS  = 0x8B,
00093   ZDO_TABLE_FULL_STATUS             = 0x8C,
00095   ZDO_NOT_AUTHORIZED_STATUS         = 0x8D,
00097   ZDO_NWK_UPDATE_STATUS             = 0x8E,
00098   ZDO_NETWORK_STARTED_STATUS        = 0x8F,
00099   ZDO_NETWORK_LOST_STATUS           = 0x90,
00100   ZDO_REJOIN_STARTED_STATUS         = 0x91,
00101   ZDO_NETWORK_LEFT_STATUS              = 0x92,
00102 } ZDO_Status_t;
00103
00104 enum
00105 {
00106   SINGLE_RESPONSE_REQUESTTYPE   = 0x00,
00107   EXTENDED_RESPONSE_REQUESTTYPE = 0x01
00108 };
00109
00115 typedef enum
00116 {
00117 //Device and Service Discovery commands
00118   NWK_ADDR_CLID                = 0x0000,
00119   IEEE_ADDR_CLID               = 0x0001,
00120   NODE_DESCRIPTOR_CLID         = 0x0002,
00121   POWER_DESCRIPTOR_CLID        = 0x0003,
00122   SIMPLE_DESCRIPTOR_CLID       = 0x0004,
00123   ACTIVE_ENDPOINTS_CLID        = 0x0005,
00124   MATCH_DESCRIPTOR_CLID        = 0x0006,
00125   COMPLEX_DESCRIPTOR_CLID      = 0x0010,
00126   USER_DESCRIPTOR_CLID         = 0x0011,
00127   DISCOVERY_CASH_CLID          = 0x0012,
00128   DEVICE_ANNCE_CLID            = 0x0013,
00129   USER_DESC_CONF_CLID          = 0x0014,
00130   SYSTEM_SERVER_DISCOVERY_CLID = 0x0015,
00131   DISCOVERY_STORE_CLID         = 0x0016,
00132   NODE_DESC_STORE_CLID         = 0x0017,
00133   POWER_DESC_STORE_CLID        = 0x0018,
00134   ACTIVE_EP_STORE_CLID         = 0x0019,
00135   SIMPLE_DESC_STORE_CLID       = 0x001A,
00136   REMOVE_NODE_CACHE_CLID       = 0x001B,
00137   FIND_NODE_CACHE_CLID         = 0x001C,
00138   EXTENDED_SIMPLE_DESC_CLID    = 0x001D,
00139   EXTENDED_ACTIVE_EP_CLID      = 0x001E,
00140 // Bind client manager commands
00141   END_DEVICE_BIND_CLID         = 0x0020,
00142   BIND_CLID                    = 0x0021,
00143   UNBIND_CLID                  = 0x0022,
00144   BIND_REGISTER_CLID           = 0x0023,
00145   REPLACE_DEVICE_CLID          = 0x0024,
00146   STORE_BCKUP_BIND_ENTRY_CLID  = 0x0025,
00147   REMOVE_BCKUP_BIND_ENTRY_CLID = 0x0026,
00148   BACKUP_BIND_TABLE_CLID       = 0x0027,
00149   RECOVER_BIND_TABLE_CLID      = 0x0028,
00150   BACKUP_SOURCE_BIND_CLID      = 0x0029,
00151   RECOVER_SOURCE_BIND_CLID     = 0x002A,
00152 // Network Management Client Services commands
00153   MGMT_NWK_DISC_CLID           = 0x0030,
00154   MGMT_LQI_CLID                = 0x0031,
00155   MGMT_RTG_CLID                = 0x0032,
00156   MGMT_BIND_CLID               = 0x0033,
00157   MGMT_LEAVE_CLID              = 0x0034,
00158   MGMT_DIRECT_JOIN_CLID        = 0x0035,
00159   MGMT_PERMIT_JOINING_CLID     = 0x0036,
00160   MGMT_CACHE_CLID              = 0x0037,
00161   MGMT_NWK_UPDATE_CLID         = 0x0038
00162 } ZDO_ZdpClusterId_t;
00163
00164 typedef enum
00165 {
00166   SHORT_ADDR_MODE,
00167   EXT_ADDR_MODE
00168 } AddrMode_t;
00169
00170 /********************************************************************************/
00173 typedef struct
00174 {
00175   uint8_t       activeChannel;
00176   ShortAddr_t   shortAddr;
00177   PanId_t       PANId;
00178   uint64_t      extPANId;
00179   ShortAddr_t   parentAddr;
00180   ZDO_Status_t  status;
00181 } PACK ZDO_StartNetworkConf_t;
00182
00183 /********************************************************************************/
00186 typedef struct PACK
00187 {
00188   ZDO_StartNetworkConf_t confParams;
00189   void (*ZDO_StartNetworkConf)(ZDO_StartNetworkConf_t *conf);
00190 } ZDO_StartNetworkReq_t;
00191
00192 /********************************************************************************/
00195 typedef struct PACK
00196 {
00197   ZDO_Status_t  status;
00198 } ZDO_ResetNetworkConf_t;
00199
00200 /********************************************************************************/
00203 typedef struct PACK
00204 {
00205   ZDO_ResetNetworkConf_t confParams;
00206   void (*ZDO_ResetNetworkConf)(ZDO_ResetNetworkConf_t *conf);
00207 } ZDO_ResetNetworkReq_t;
00208
00209 typedef struct PACK
00210 {
00211   uint32_t        scannedChannels;
00212   uint16_t        totalTransmissions;
00213   uint16_t        transmissionsFailures;
00214   uint8_t         scannedChannelsListCount;
00215   uint8_t         energyValues[32];//TODO
00216 } EDScan_t;
00217
00218 typedef struct PACK
00219 {
00220   ShortAddr_t parentShortAddr;
00221   PanId_t     panId;
00222   uint8_t     currentChannel;
00223   ShortAddr_t shortAddr;
00224 } NetworkInf_t;
00225
00226 typedef struct PACK
00227 {
00228 //  ZDO_Status_t    status;
00229   uint8_t status;
00230   union
00231   {
00232     EDScan_t     scanResult;
00233     NetworkInf_t nwkUpdateInf;
00234   };
00235 } ZDO_MgmtNwkUpdateNotf_t;
00236
00237 typedef struct PACK
00238 {
00239   ZDO_Status_t status;
00240 } ZDO_SleepConf_t;
00241
00242 typedef struct PACK
00243 {
00244   ZDO_SleepConf_t confirm;
00245   void (*ZDO_SleepConf)(ZDO_SleepConf_t *conf);
00246 } PACK ZDO_SleepReq_t;
00247
00248 typedef struct PACK
00249 {
00250   ZDO_Status_t status;
00251 } PACK ZDO_WakeUpConf_t;
00252
00253 typedef struct PACK
00254 {
00255   ZDO_WakeUpConf_t confirm;
00256   void (*ZDO_WakeUpConf)(ZDO_WakeUpConf_t *conf);
00257 } PACK ZDO_WakeUpReq_t;
00258
00259 typedef struct PACK
00260 {
00261   ExtAddr_t ieeeAddrOfInterest;
00262   uint8_t   reqType;
00263   uint8_t   startIndex;
00264 } ZDO_NwkAddrReq_t;
00265
00266 typedef struct PACK
00267 {
00268   ShortAddr_t nwkAddrOfInterest;
00269   uint8_t reqType;
00270   uint8_t startIndex;
00271 } ZDO_IeeeAddrReq_t;
00272
00273 typedef struct PACK
00274 {
00275   ShortAddr_t nwkAddrOfInterest;
00276 } ZDO_NodeDescReq_t;
00277
00278 typedef struct PACK
00279 {
00280   ShortAddr_t nwkAddrOfInterest;
00281 } ZDO_PowerDescReq_t;
00282
00283 typedef struct PACK
00284 {
00285   ShortAddr_t nwkAddrOfInterest;
00286 } ZDO_ActiveEPReq_t;
00287
00288 typedef struct PACK
00289 {
00290   ShortAddr_t nwkAddrOfInterest;
00291 } ZDO_ComplexDescReq_t;
00292
00293 typedef struct PACK
00294 {
00295   ShortAddr_t nwkAddrOfInterest;
00296 } ZDO_UserDescReq_t;
00297
00298 typedef struct PACK
00299 {
00300   ShortAddr_t nwkAddrOfInterest;
00301 } ZDO_UserDescSetReq_t;
00302
00303 typedef struct PACK
00304 {
00305   ShortAddr_t nwkAddrOfInterest;
00306   Endpoint_t  endpoint;
00307 } ZDO_SimpleDescReq_t;
00308
00309 typedef struct PACK
00310 {
00311   ShortAddr_t nwkAddrLocal;
00312   ExtAddr_t   ieeeAddrLocal;
00313   uint8_t     macCapability;
00314 } ZDO_DeviceAnnceReq_t;
00315
00316 typedef struct PACK
00317 {
00318   uint16_t serverMask;
00319 } ZDO_SystemServerDiscoveryReq_t;
00320
00321 #ifdef _BINDING_
00322 typedef struct PACK
00323 {
00324   ShortAddr_t nwkAddrOfInterest;
00325   ProfileId_t profileId;
00326   uint8_t     numInClusters;
00327   ClusterId_t inClusterList[MAX_REQUESTED_CLUSTER_NUMBER];
00328   uint8_t     numOutClusters;
00329   ClusterId_t outClusterList[MAX_REQUESTED_CLUSTER_NUMBER];
00330 } ZDO_MatchDescReq_t;
00331 #endif // _BINDING_
00332
00333 typedef struct PACK
00334 {
00335   ExtAddr_t deviceAddr;
00336   uint8_t   reserved : 6;
00337   uint8_t   removeChildren : 1;
00338   uint8_t   rejoin : 1;
00339 } ZDO_MgmtLeaveReq_t;
00340
00341 typedef struct PACK
00342 {
00343   uint8_t permitDuration;
00344   uint8_t tcSignificance;
00345 } ZDO_MgmtPermitJoiningReq_t;
00346
00347 typedef struct PACK
00348 {
00349   uint32_t    scanChannels;
00350   uint8_t     scanDuration;
00351   union
00352   {
00353     uint8_t     scanCount;
00354     uint8_t     nwkUpdateId;
00355   };
00356   ShortAddr_t nwkManagerAddr;
00357 } ZDO_MgmtNwkUpdateReq_t;
00358
00359 typedef struct PACK
00360 {
00361   ExtAddr_t   ieeeAddrRemote;
00362   ShortAddr_t nwkAddrRemote;
00363   uint8_t     numAssocDev;
00364   uint8_t     startIndex;
00365   ShortAddr_t nwkAddrAssocDevList[CS_MAX_CHILDREN_AMOUNT];
00366 } ZDO_NwkAddrResp_t;
00367
00368 typedef struct PACK
00369 {
00370   ExtAddr_t   ieeeAddrRemote;
00371   ShortAddr_t nwkAddrRemote;
00372   uint8_t     numAssocDev;
00373   uint8_t     startIndex;
00374   ShortAddr_t nwkAddrAssocDevList[CS_MAX_CHILDREN_AMOUNT];
00375 } ZDO_IeeeAddrResp_t;
00376
00377 typedef struct PACK
00378 {
00379   ShortAddr_t      nwkAddrOfInterest;
00380   NodeDescriptor_t nodeDescriptor;
00381 } ZDO_NodeDescResp_t;
00382
00383 typedef struct PACK
00384 {
00385   ShortAddr_t       nwkAddrOfInterest;
00386   PowerDescriptor_t powerDescriptor;
00387 } ZDO_PowerDescResp_t;
00388
00389 typedef struct PACK
00390 {
00391   ShortAddr_t      nwkAddrOfInterest;
00392 } ZDO_ComplexDescResp_t;
00393
00394 typedef struct PACK
00395 {
00396   ShortAddr_t      nwkAddrOfInterest;
00397 } ZDO_UserDescResp_t;
00398
00399 typedef struct PACK
00400 {
00401   ShortAddr_t      nwkAddrOfInterest;
00402 } ZDO_UserDescConfResp_t;
00403
00404 typedef struct PACK
00405 {
00406   ShortAddr_t nwkAddrOfInterest;
00407   uint8_t     activeEPCount;
00408   uint8_t     activeEPList[MAX_ACTIVE_EP_NUMBER];
00409 } ZDO_ActiveEPResp_t;
00410
00411 typedef struct PACK
00412 {
00413   Endpoint_t   endpoint;
00414   ProfileId_t  AppProfileId;
00415   uint16_t     AppDeviceId;
00416   uint8_t      AppDeviceVersion : 4;
00417   uint8_t      Reserved         : 4;
00418   uint8_t      AppInClustersCount;
00419   ClusterId_t  AppInClustersList[MAX_REQUESTED_CLUSTER_NUMBER];
00420   uint8_t      AppOutClustersCount;
00421   ClusterId_t  AppOutClustersList[MAX_REQUESTED_CLUSTER_NUMBER];
00422
00423 } ZdpSimpleDescriptor_t;
00424
00425 typedef struct PACK
00426 {
00427   ShortAddr_t           nwkAddrOfInterest;
00428   uint8_t               length;
00429   ZdpSimpleDescriptor_t simpleDescriptor;
00430 } ZDO_SimpleDescResp_t;
00431
00432 typedef struct PACK
00433 {
00434   uint16_t      serverMask;
00435 } ZDO_SystemServerDiscoveryResp_t;
00436
00437 #ifdef _BINDING_
00438 typedef struct PACK
00439 {
00440   ShortAddr_t nwkAddrOfInterest;
00441   uint8_t     matchLength;
00442   uint8_t     matchList[MAX_REQUESTED_CLUSTER_NUMBER];
00443 } ZDO_MatchDescResp_t;
00444 #endif // _BINDING_
00445
00446 typedef struct PACK
00447 {
00448   uint8_t seqNum;
00449   // user part
00450   uint8_t status;
00451   union
00452   {
00453     ZDO_NwkAddrResp_t               nwkAddrResp;
00454     ZDO_IeeeAddrResp_t              ieeeAddrResp;
00455     ZDO_NodeDescResp_t              nodeDescResp;
00456     ZDO_PowerDescResp_t             powerDescResp;
00457     ZDO_SimpleDescResp_t            simpleDescResp;
00458     ZDO_ComplexDescResp_t           complexDescResp;
00459     ZDO_UserDescResp_t              userDescResp;
00460     ZDO_ActiveEPResp_t              activeEPResp;
00461     ZDO_UserDescConfResp_t          userDescConfResp;
00462     ZDO_SystemServerDiscoveryResp_t systemServerDiscoveryResp;
00463 #ifdef _BINDING_
00464     ZDO_MatchDescResp_t             matchDescResp;
00465 #endif // _BINDING_
00466     ZDO_MgmtNwkUpdateNotf_t         mgmtNwkUpdateNotf;
00467   };
00468 } ZDO_ZdpRespFrame_t;
00469
00470 typedef struct PACK
00471 {
00472   uint8_t seqNum;
00473   // user part
00474   union
00475   {
00476     ZDO_NwkAddrReq_t               nwkAddrReq;
00477     ZDO_IeeeAddrReq_t              ieeeAddrReq;
00478     ZDO_NodeDescReq_t              nodeDescReq;
00479     ZDO_PowerDescReq_t             powerDescReq;
00480     ZDO_SimpleDescReq_t            simpleDescReq;
00481     ZDO_DeviceAnnceReq_t           deviceAnnce;
00482     ZDO_ActiveEPReq_t              activeEPReq;
00483     ZDO_ComplexDescReq_t           complexDescReq;
00484     ZDO_UserDescReq_t              userDescReq;
00485     ZDO_UserDescSetReq_t           userDescSetReq;
00486     ZDO_SystemServerDiscoveryReq_t systemServerDiscoveryReq;
00487 #ifdef _BINDING_
00488     ZDO_MatchDescReq_t             matchDescReq;
00489 #endif // _BINDING_
00490     ZDO_MgmtLeaveReq_t             mgmtLeaveReq;
00491     ZDO_MgmtPermitJoiningReq_t     mgmtPermitJoiningReq;
00492     ZDO_MgmtNwkUpdateReq_t         mgmtNwkUpdateReq;
00493     ZDO_MgmtNwkUpdateNotf_t        mgmtNwkUpdateNotf;
00494   };
00495 } ZDO_ZdpReqFrame_t;
00496
00497 typedef struct PACK
00498 {
00499   // reserved
00500   uint8_t       header[APS_ASDU_OFFSET];
00501   union
00502   {
00503     ZDO_ZdpRespFrame_t respPayload;
00504     ZDO_ZdpReqFrame_t  reqPayload;
00505   };
00506 } ZDO_ZdpFrame_t;
00507
00508 typedef struct
00509 {
00510   AddrMode_t     srcAddrMode;
00511   union
00512   {
00513     ShortAddr_t  srcNwkAddr;
00514     ExtAddr_t    srcExtAddr;
00515   };
00516   ZDO_ZdpRespFrame_t respPayload;
00517 } ZDO_ZdpResp_t;
00518
00519 typedef struct PACK
00520 {
00521   // Service fields
00522   struct
00523   {
00524     void *next;
00525   } service;
00526
00527   // Address fields
00528   ZDO_ZdpClusterId_t reqCluster;
00529   AddrMode_t         dstAddrMode;
00530
00531   union
00532   {
00533     ShortAddr_t  dstNwkAddr;
00534     ExtAddr_t    dstExtAddr;
00535   };
00536
00537   // zdp frame for sending out
00538   ZDO_ZdpFrame_t req;
00539
00540   //Callback and Response
00541   void (*ZDO_ZdpResp)(ZDO_ZdpResp_t *zdpResp);
00542   ZDO_ZdpResp_t resp;
00543
00544 } ZDO_ZdpReq_t;
00545
00546 typedef struct PACK
00547 {
00548   ShortAddr_t shortAddr;
00549   ExtAddr_t   extAddr;
00550 } NodeAddr_t;
00551
00552 /********************************************************************************/
00555 typedef struct PACK
00556 {
00557   ShortAddr_t  nodeAddr;
00558   ZDO_Status_t status;
00559   uint8_t      lqi;
00560   uint8_t      rssi;
00561 } ZDO_GetLqiRssi_t;
00562
00563 /********************************************************************************/
00566 typedef struct
00567 {
00568   uint8_t childrenCount;
00569   NodeAddr_t *childrenTable;
00570 } ZDO_GetChildrenAddr_t;
00571
00572 /********************************************************************************/
00575 typedef struct
00576 {
00577   ZDO_Status_t status;
00578 } ZDO_SetTxPowerConf_t;
00579
00580 /********************************************************************************/
00583 typedef struct
00584 {
00585   uint8_t txPower;
00586   void (* ZDO_SetTxPowerConf)(ZDO_SetTxPowerConf_t *conf);
00587   ZDO_SetTxPowerConf_t confirm;
00588 } ZDO_SetTxPowerReq_t;
00589
00590 /********************************************************************************/
00593 typedef enum
00594 {
00595   ZDO_IN_NETWORK_STATUS,
00596   ZDO_OUT_NETWORK_STATUS
00597 } ZDO_NwkStatus_t;
00598
00599 typedef struct PACK
00600 {
00601   ZDO_Status_t status;
00602 } ZDO_EndToEndAppKeyConf_t;
00603
00604 typedef struct PACK
00605 {
00606   ExtAddr_t deviceAddr;
00607   void (*ZDO_EndToEndAppKeyConf)(ZDO_EndToEndAppKeyConf_t *conf);
00608   ZDO_EndToEndAppKeyConf_t confirm;
00609 } ZDO_EndToEndAppKeyReq_t;
00610
00611 /************************************************************************************
00612   Primitives declarations.
00613  ***********************************************************************************/
00614
00615 /*********************************************************************************/
00622 void ZDO_StartNetworkReq(ZDO_StartNetworkReq_t *startingParams);
00623
00624 /**********************************************************************************/
00631 void ZDO_ResetNetworkReq(ZDO_ResetNetworkReq_t *resetParams);
00632
00633 /**********************************************************************************/
00641 void ZDO_MgmtNwkUpdateNotf(ZDO_MgmtNwkUpdateNotf_t * nwkParams);
00642
00643 /*************************************************************************************/
00651 void ZDO_SleepReq(ZDO_SleepReq_t *req);
00652
00653 /**************************************************************************************/
00661 void ZDO_SleepInd(void);
00662
00663 /*************************************************************************************/
00670 void ZDO_SleepResp(void);
00671
00672 /*************************************************************************************/
00678 void ZDO_WakeUpInd(void);
00679
00680 /*************************************************************************************/
00688 void ZDO_WakeUpReq(ZDO_WakeUpReq_t *req);
00689
00690 void ZDO_ZdpReq(ZDO_ZdpReq_t *zdpReq);
00691
00692 /*************************************************************************************/
00699 void ZDO_GetLqiRssi(ZDO_GetLqiRssi_t *lqiRssi);
00700
00701 /*************************************************************************************/
00708 void ZDO_GetParentAddr(NodeAddr_t *parentAddr);
00709
00710 /*************************************************************************************/
00717 void ZDO_GetChildrenAddr(ZDO_GetChildrenAddr_t *childrenAddr);
00718
00719 /*************************************************************************************/
00726 void ZDO_SetTxPowerReq(ZDO_SetTxPowerReq_t *req);
00727
00728 /*************************************************************************************/
00735 ZDO_NwkStatus_t ZDO_GetNwkStatus();
00736
00737 #endif  /* _ZDO_H */
Generated on Wed Apr 9 17:48:40 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • ACTIVE_ENDPOINTS_CLID : zdo.h
  • ACTIVE_EP_STORE_CLID : zdo.h
  • AddrMode_t : zdo.h
  • APL_TASK_ID : taskManager.h
  • APL_TaskHandler() : taskManager.h
  • APS_AddrMode_t : aps.h
  • APS_AFFIX_LENGTH : aps.h
  • APS_AIB_BINDING_TABLE : aps.h
  • APS_AIB_CHANNEL_MASK : aps.h
  • APS_AIB_DESIGNATED_COORDINATOR : aps.h
  • APS_AIB_DEVICE_KEY_PAIR_SET : aps.h
  • APS_AIB_GROUP_TABLE : aps.h
  • APS_AIB_INTERFRAME_DELAY : aps.h
  • APS_AIB_NONMEMBER_RADIUS : aps.h
  • APS_AIB_PERMISSIONS_CONFIGURATION : aps.h
  • APS_AIB_SECURITY_TIME_OUT_PERIOD : aps.h
  • APS_AIB_TRUST_CENTER_ADDRESS : aps.h
  • APS_AIB_USE_EXTENDED_PANID : aps.h
  • APS_AIB_USE_INSECURE_JOIN : aps.h
  • APS_AibAttributeId_t : aps.h
  • APS_ASDU_OFFSET : aps.h
  • APS_ASDU_TOO_LONG_STATUS : aps.h
  • APS_BROADCAST_ENDPOINT : aps.h
  • APS_DEFRAG_DEFERRED_STATUS : aps.h
  • APS_DEFRAG_UNSUPPORTED_STATUS : aps.h
  • APS_EXT_ADDRESS : aps.h
  • APS_GetEndpointList() : aps.h
  • APS_GetReq() : aps.h
  • APS_ILLEGAL_REQUEST_STATUS : aps.h
  • APS_INVALID_BINDING_STATUS : aps.h
  • APS_INVALID_GROUP_STATUS : aps.h
  • APS_INVALID_PARAMETER_STATUS : aps.h
  • APS_MAX_ASDU_SIZE : aps.h
  • APS_MAX_DATA_FRAME_FOOTER_LENGTH : aps.h
  • APS_MAX_DATA_FRAME_HEADER_LENGTH : aps.h
  • APS_MAX_RESERVED_ENDPOINT : aps.h
  • APS_MAX_UNICAST_SHORT_ADDRESS : aps.h
  • APS_MAX_USER_ENDPOINT : aps.h
  • APS_MIN_RESERVED_ENDPOINT : aps.h
  • APS_MIN_USER_ENDPOINT : aps.h
  • APS_NO_ACK_STATUS : aps.h
  • APS_NO_ADDRESS : aps.h
  • APS_NO_BOUND_DEVICE_STATUS : aps.h
  • APS_NO_SHORT_ADDRESS_STATUS : aps.h
  • APS_NOT_INDICATED_STATUS : aps.h
  • APS_NOT_SUPPORTED_STATUS : aps.h
  • APS_RegisterEndpointReq() : aps.h
  • APS_ResumeEndpointIndication() : aps.h
  • APS_SECURED_LINK_KEY_STATUS : aps.h
  • APS_SECURED_NWK_KEY_STATUS : aps.h
  • APS_SECURITY_FAIL_STATUS : aps.h
  • APS_SetReq() : aps.h
  • APS_SHORT_ADDRESS : aps.h
  • APS_Status_t : aps.h
  • APS_StopEndpointIndication() : aps.h
  • APS_SUCCESS_STATUS : aps.h
  • APS_TABLE_FULL_STATUS : aps.h
  • APS_TASK_ID : taskManager.h
  • APS_TaskHandler() : taskManager.h
  • APS_UnregisterEndpointReq() : aps.h
  • APS_UNSECURED_STATUS : aps.h
  • APS_UNSUPPORTED_ATTRIBUTE_STATUS : aps.h
  • APS_ZDO_ENDPOINT : aps.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • LEAVE_REQ : zdo.h
  • LEAVED_BY_PARENT : zdo.h
  • LINK_FAIL : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • MAC_HWI_TASK_ID : taskManager.h
  • MAC_HWI_TaskHandler() : taskManager.h
  • MAC_PHY_HWD_TASK_ID : taskManager.h
  • MAC_PHY_HWD_TaskHandler() : taskManager.h
  • MATCH_DESCRIPTOR_CLID : zdo.h
  • MGMT_BIND_CLID : zdo.h
  • MGMT_CACHE_CLID : zdo.h
  • MGMT_DIRECT_JOIN_CLID : zdo.h
  • MGMT_LEAVE_CLID : zdo.h
  • MGMT_LQI_CLID : zdo.h
  • MGMT_NWK_DISC_CLID : zdo.h
  • MGMT_NWK_UPDATE_CLID : zdo.h
  • MGMT_PERMIT_JOINING_CLID : zdo.h
  • MGMT_RTG_CLID : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- n -

  • NetLostReason_t : zdo.h
  • NODE_DESC_STORE_CLID : zdo.h
  • NODE_DESCRIPTOR_CLID : zdo.h
  • NWK_ADDR_CLID : zdo.h
  • NWK_TASK_ID : taskManager.h
  • NWK_TaskHandler() : taskManager.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- z -

  • ZDO_AUTHENTICATION_FAIL_STATUS : zdo.h
  • ZDO_AUTHENTICATION_SUCCESS_STATUS : zdo.h
  • ZDO_BUSY_STATUS : zdo.h
  • ZDO_CMD_COMPLETED_STATUS : zdo.h
  • ZDO_DEVICE_NOT_FOUND_STATUS : zdo.h
  • ZDO_EXTPANID_ALREADY_EXIST_STATUS : zdo.h
  • ZDO_FAIL_STATUS : zdo.h
  • ZDO_GetChildrenAddr() : zdo.h
  • ZDO_GetLqiRssi() : zdo.h
  • ZDO_GetNwkStatus() : zdo.h
  • ZDO_GetParentAddr() : zdo.h
  • ZDO_IN_NETWORK_STATUS : zdo.h
  • ZDO_INSUFFICIENT_SPACE_STATUS : zdo.h
  • ZDO_INVALID_EP_STATUS : zdo.h
  • ZDO_INVALID_PARAMETERS_STATUS : zdo.h
  • ZDO_INVALID_REQUEST_STATUS : zdo.h
  • ZDO_MgmtNwkUpdateNotf() : zdo.h
  • ZDO_NETWORK_LEFT_STATUS : zdo.h
  • ZDO_NETWORK_LOST_STATUS : zdo.h
  • ZDO_NETWORK_STARTED_STATUS : zdo.h
  • ZDO_NO_DESCRIPTOR_STATUS : zdo.h
  • ZDO_NO_ENTRY_STATUS : zdo.h
  • ZDO_NO_MATCH_STATUS : zdo.h
  • ZDO_NO_NETWORKS_STATUS : zdo.h
  • ZDO_NOT_ACTIVE_STATUS : zdo.h
  • ZDO_NOT_AUTHORIZED_STATUS : zdo.h
  • ZDO_NOT_PERMITTED_STATUS : zdo.h
  • ZDO_NOT_SUPPORTED_STATUS : zdo.h
  • ZDO_NWK_UPDATE_STATUS : zdo.h
  • ZDO_NwkStatus_t : zdo.h
  • ZDO_OUT_NETWORK_STATUS : zdo.h
  • ZDO_REJOIN_STARTED_STATUS : zdo.h
  • ZDO_ResetNetworkReq() : zdo.h
  • ZDO_RESPONSE_WAIT_TIMEOUT_STATUS : zdo.h
  • ZDO_SECURITY_FAIL_STATUS : zdo.h
  • ZDO_SECURITY_NOT_SUPPORTED_STATUS : zdo.h
  • ZDO_SECURITY_SUCCESS_STATUS : zdo.h
  • ZDO_SetTxPowerReq() : zdo.h
  • ZDO_SleepInd() : zdo.h
  • ZDO_SleepReq() : zdo.h
  • ZDO_SleepResp() : zdo.h
  • ZDO_StartNetworkReq() : zdo.h
  • ZDO_Status_t : zdo.h
  • ZDO_SUCCESS_STATUS : zdo.h
  • ZDO_TABLE_FULL_STATUS : zdo.h
  • ZDO_TASK_ID : taskManager.h
  • ZDO_TaskHandler() : taskManager.h
  • ZDO_TIMEOUT_STATUS : zdo.h
  • ZDO_WakeUpInd() : zdo.h
  • ZDO_WakeUpReq() : zdo.h
  • ZDO_ZdpClusterId_t : zdo.h
  • ZDO_ZdpReq() : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- b -

  • BACKUP_BIND_TABLE_CLID : zdo.h
  • BACKUP_SOURCE_BIND_CLID : zdo.h
  • BIND_CLID : zdo.h
  • BIND_REGISTER_CLID : zdo.h
  • BSP_CloseBatterySensor() : sensors.h
  • BSP_CloseButtons() : buttons.h
  • BSP_CloseLeds() : leds.h
  • BSP_CloseLightSensor() : sensors.h
  • BSP_CloseTemperatureSensor() : sensors.h
  • BSP_OffLed() : leds.h
  • BSP_OnLed() : leds.h
  • BSP_OpenBatterySensor() : sensors.h
  • BSP_OpenButtons() : buttons.h
  • BSP_OpenLeds() : leds.h
  • BSP_OpenLightSensor() : sensors.h
  • BSP_OpenTemperatureSensor() : sensors.h
  • BSP_ReadBatteryData() : sensors.h
  • BSP_ReadButtonsState() : buttons.h
  • BSP_ReadLightData() : sensors.h
  • BSP_ReadSliders() : sliders.h
  • BSP_ReadTemperatureData() : sensors.h
  • BSP_TASK_ID : taskManager.h
  • BSP_TaskHandler() : taskManager.h
  • BSP_ToggleLed() : leds.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • COMPLEX_DESCRIPTOR_CLID : zdo.h
  • CS_ACK_TIMEOUT_ID : configServer.h
  • CS_ADDRESS_ASSIGNMENT_METHOD_ID : configServer.h
  • CS_ADDRESS_MAP_TABLE_ID : configServer.h
  • CS_ADDRESS_MAP_TABLE_SIZE_ID : configServer.h
  • CS_APS_ACK_FRAME_BUFFER_ID : configServer.h
  • CS_APS_ACK_FRAME_BUFFER_SIZE_ID : configServer.h
  • CS_APS_DATA_REQ_BUFFER_ID : configServer.h
  • CS_APS_DATA_REQ_BUFFER_SIZE_ID : configServer.h
  • CS_APS_GROUP_TABLE_ENDPOINTS_AMOUNT_ID : configServer.h
  • CS_APS_GROUP_TABLE_GROUPS_AMOUNT_ID : configServer.h
  • CS_APS_GROUP_TABLE_ID : configServer.h
  • CS_ASSOCIATE_RESPONSE_BUFFER_ID : configServer.h
  • CS_AUTONETWORK_ID : configServer.h
  • CS_CHANNEL_MASK_ID : configServer.h
  • CS_DEVICE_TYPE_ID : configServer.h
  • CS_DTR_WAKEUP_ID : configServer.h
  • CS_DUPLICATE_REJECTION_TABLE_ID : configServer.h
  • CS_DUPLICATE_REJECTION_TABLE_SIZE_ID : configServer.h
  • CS_END_DEVICE_ACTIVE_PERIOD_ID : configServer.h
  • CS_END_DEVICE_SLEEP_PERIOD_ID : configServer.h
  • CS_EXT_PANID_ID : configServer.h
  • CS_GetMemory() : configServer.h
  • CS_INDIRECT_POLL_RATE_ID : configServer.h
  • CS_Init() : configServer.h
  • CS_MAC_FRAME_RX_BUFFER_ID : configServer.h
  • CS_MAC_FRAME_RX_BUFFER_SIZE_ID : configServer.h
  • CS_MAC_PAN_DESCRIPTOR_BUFFER_ID : configServer.h
  • CS_MAC_TRANSACTION_TIME_ID : configServer.h
  • CS_MAX_CHILDREN_AMOUNT_ID : configServer.h
  • CS_MAX_CHILDREN_ROUTER_AMOUNT_ID : configServer.h
  • CS_MAX_NETWORK_DEPTH_ID : configServer.h
  • CS_MemoryId_t : configServer.h
  • CS_NEIB_TABLE_ID : configServer.h
  • CS_NEIB_TABLE_SIZE_ID : configServer.h
  • CS_NWK_ADDR_ID : configServer.h
  • CS_NWK_DATA_IND_BUFFER_ID : configServer.h
  • CS_NWK_DATA_IND_BUFFER_SIZE_ID : configServer.h
  • CS_NWK_DATA_REQ_BUFFER_ID : configServer.h
  • CS_NWK_DATA_REQ_BUFFER_SIZE_ID : configServer.h
  • CS_NWK_EXT_PANID_ID : configServer.h
  • CS_NWK_LOGICAL_CHANNEL_ID : configServer.h
  • CS_NWK_PAN_DESCRIPTOR_BUFFER_ID : configServer.h
  • CS_NWK_PANID_ID : configServer.h
  • CS_NWK_UNIQUE_ADDR_ID : configServer.h
  • CS_NWK_USE_MULTICAST_ID : configServer.h
  • CS_ParameterId_t : configServer.h
  • CS_PdsDefaultValue() : configServer.h
  • CS_PERMIT_DURATION_ID : configServer.h
  • CS_PROTOCOL_VERSION_ID : configServer.h
  • CS_ReadParameter() : configServer.h
  • CS_RF_TX_POWER_ID : configServer.h
  • CS_ROUTE_DISCOVERY_TABLE_ID : configServer.h
  • CS_ROUTE_DISCOVERY_TABLE_SIZE_ID : configServer.h
  • CS_ROUTE_TABLE_ID : configServer.h
  • CS_ROUTE_TABLE_SIZE_ID : configServer.h
  • CS_RX_ON_WHEN_IDLE_ID : configServer.h
  • CS_SCAN_DURATION_ID : configServer.h
  • CS_SOFT_RESET_REASON_ID : configServer.h
  • CS_STACK_PROFILE_ID : configServer.h
  • CS_UID_ID : configServer.h
  • CS_WriteParameter() : configServer.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- d -

  • DEVICE_ANNCE_CLID : zdo.h
  • DISCOVERY_CASH_CLID : zdo.h
  • DISCOVERY_STORE_CLID : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • END_DEVICE_BIND_CLID : zdo.h
  • EXT_ADDR_MODE : zdo.h
  • EXTENDED_ACTIVE_EP_CLID : zdo.h
  • EXTENDED_RESPONSE_REQUESTTYPE : zdo.h
  • EXTENDED_SIMPLE_DESC_CLID : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- f -

  • FIND_NODE_CACHE_CLID : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- h -

  • HAL_AlarmSearchW1Device() : w1.h
  • HAL_AppTimer_t : appTimer.h
  • HAL_CloseAdc() : adc.h
  • HAL_CloseI2cPacket() : i2cPacket.h
  • HAL_CloseSpi() : spi.h
  • HAL_CloseUart() : uart.h
  • HAL_ConvertToSleepInterval() : sleepTimer.h
  • HAL_DisableDtrWakeUp() : uart.h
  • HAL_DisableIrq() : irq.h
  • HAL_EnableDtrWakeUp() : uart.h
  • HAL_EnableIrq() : irq.h
  • HAL_GetSystemTime() : appTimer.h
  • HAL_IsTxEmpty() : uart.h
  • HAL_OffUartCts() : uart.h
  • HAL_OnUartCts() : uart.h
  • HAL_OpenAdc() : adc.h
  • HAL_OpenI2cPacket() : i2cPacket.h
  • HAL_OpenSpi() : spi.h
  • HAL_OpenUart() : uart.h
  • HAL_ReadAdc() : adc.h
  • HAL_ReadEeprom() : eeprom.h
  • HAL_ReadI2cPacket() : i2cPacket.h
  • HAL_ReadResetReason() : resetReason.h
  • HAL_ReadUart() : uart.h
  • HAL_ReadUartDtr() : uart.h
  • HAL_ReadUartRts() : uart.h
  • HAL_ReadUid() : uid.h
  • HAL_ReadW1() : w1.h
  • HAL_RegisterIrq() : irq.h
  • HAL_RegisterWdtCallback() : wdtCtrl.h
  • HAL_ResetW1() : w1.h
  • HAL_ResetWdt() : wdtCtrl.h
  • HAL_SearchW1Device() : w1.h
  • HAL_SleepTimer_t : sleepTimer.h
  • HAL_StartAppTimer() : appTimer.h
  • HAL_StartSleepTimer() : sleepTimer.h
  • HAL_StartWdt() : wdtCtrl.h
  • HAL_StopAppTimer() : appTimer.h
  • HAL_StopSleepTimer() : sleepTimer.h
  • HAL_StopWdt() : wdtCtrl.h
  • HAL_TASK_ID : taskManager.h
  • HAL_TaskHandler() : taskManager.h
  • HAL_UnregisterIrq() : irq.h
  • HAL_WarmReset() : resetReason.h
  • HAL_WriteEeprom() : eeprom.h
  • HAL_WriteI2cPacket() : i2cPacket.h
  • HAL_WriteSpi() : spi.h
  • HAL_WriteUart() : uart.h
  • HAL_WriteW1() : w1.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • IEEE_ADDR_CLID : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • PDS_CRC_ERROR : pdsDataServer.h
  • PDS_DataServerState_t : pdsDataServer.h
  • PDS_EEPROM_BUSY : pdsDataServer.h
  • PDS_EEPROM_ERROR : pdsDataServer.h
  • PDS_Init() : pdsDataServer.h
  • PDS_INVALID_REQUEST : pdsDataServer.h
  • PDS_ReadUserData() : pdsDataServer.h
  • PDS_SetToDefault() : pdsDataServer.h
  • PDS_SUCCESS : pdsDataServer.h
  • PDS_WriteUserData() : pdsDataServer.h
  • POWER_DESC_STORE_CLID : zdo.h
  • POWER_DESCRIPTOR_CLID : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- r -

  • RECOVER_BIND_TABLE_CLID : zdo.h
  • RECOVER_SOURCE_BIND_CLID : zdo.h
  • REMOVE_BCKUP_BIND_ENTRY_CLID : zdo.h
  • REMOVE_NODE_CACHE_CLID : zdo.h
  • REPLACE_DEVICE_CLID : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • SHORT_ADDR_MODE : zdo.h
  • SIMPLE_DESC_STORE_CLID : zdo.h
  • SIMPLE_DESCRIPTOR_CLID : zdo.h
  • SINGLE_RESPONSE_REQUESTTYPE : zdo.h
  • SSP_TASK_ID : taskManager.h
  • SSP_TaskHandler() : taskManager.h
  • STORE_BCKUP_BIND_ENTRY_CLID : zdo.h
  • SYS_PostTask() : taskManager.h
  • SYS_RunTask() : taskManager.h
  • SYS_taskFlag : taskManager.h
  • SYS_TaskId_t : taskManager.h
  • SYSTEM_SERVER_DISCOVERY_CLID : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • TC_TASK_ID : taskManager.h
  • TC_TaskHandler() : taskManager.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- u -

  • UNBIND_CLID : zdo.h
  • USER_DESC_CONF_CLID : zdo.h
  • USER_DESCRIPTOR_CLID : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • APS_AFFIX_LENGTH : aps.h
  • APS_ASDU_OFFSET : aps.h
  • APS_BROADCAST_ENDPOINT : aps.h
  • APS_MAX_ASDU_SIZE : aps.h
  • APS_MAX_DATA_FRAME_FOOTER_LENGTH : aps.h
  • APS_MAX_DATA_FRAME_HEADER_LENGTH : aps.h
  • APS_MAX_RESERVED_ENDPOINT : aps.h
  • APS_MAX_UNICAST_SHORT_ADDRESS : aps.h
  • APS_MAX_USER_ENDPOINT : aps.h
  • APS_MIN_RESERVED_ENDPOINT : aps.h
  • APS_MIN_USER_ENDPOINT : aps.h
  • APS_ZDO_ENDPOINT : aps.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • AddrMode_t : zdo.h
  • APS_AddrMode_t : aps.h
  • APS_AibAttributeId_t : aps.h
  • APS_Status_t : aps.h
  • CS_MemoryId_t : configServer.h
  • CS_ParameterId_t : configServer.h
  • NetLostReason_t : zdo.h
  • PDS_DataServerState_t : pdsDataServer.h
  • SYS_TaskId_t : taskManager.h
  • ZDO_NwkStatus_t : zdo.h
  • ZDO_Status_t : zdo.h
  • ZDO_ZdpClusterId_t : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • z

- a -

  • ACTIVE_ENDPOINTS_CLID : zdo.h
  • ACTIVE_EP_STORE_CLID : zdo.h
  • APL_TASK_ID : taskManager.h
  • APS_AIB_BINDING_TABLE : aps.h
  • APS_AIB_CHANNEL_MASK : aps.h
  • APS_AIB_DESIGNATED_COORDINATOR : aps.h
  • APS_AIB_DEVICE_KEY_PAIR_SET : aps.h
  • APS_AIB_GROUP_TABLE : aps.h
  • APS_AIB_INTERFRAME_DELAY : aps.h
  • APS_AIB_NONMEMBER_RADIUS : aps.h
  • APS_AIB_PERMISSIONS_CONFIGURATION : aps.h
  • APS_AIB_SECURITY_TIME_OUT_PERIOD : aps.h
  • APS_AIB_TRUST_CENTER_ADDRESS : aps.h
  • APS_AIB_USE_EXTENDED_PANID : aps.h
  • APS_AIB_USE_INSECURE_JOIN : aps.h
  • APS_ASDU_TOO_LONG_STATUS : aps.h
  • APS_DEFRAG_DEFERRED_STATUS : aps.h
  • APS_DEFRAG_UNSUPPORTED_STATUS : aps.h
  • APS_EXT_ADDRESS : aps.h
  • APS_ILLEGAL_REQUEST_STATUS : aps.h
  • APS_INVALID_BINDING_STATUS : aps.h
  • APS_INVALID_GROUP_STATUS : aps.h
  • APS_INVALID_PARAMETER_STATUS : aps.h
  • APS_NO_ACK_STATUS : aps.h
  • APS_NO_ADDRESS : aps.h
  • APS_NO_BOUND_DEVICE_STATUS : aps.h
  • APS_NO_SHORT_ADDRESS_STATUS : aps.h
  • APS_NOT_INDICATED_STATUS : aps.h
  • APS_NOT_SUPPORTED_STATUS : aps.h
  • APS_SECURED_LINK_KEY_STATUS : aps.h
  • APS_SECURED_NWK_KEY_STATUS : aps.h
  • APS_SECURITY_FAIL_STATUS : aps.h
  • APS_SHORT_ADDRESS : aps.h
  • APS_SUCCESS_STATUS : aps.h
  • APS_TABLE_FULL_STATUS : aps.h
  • APS_TASK_ID : taskManager.h
  • APS_UNSECURED_STATUS : aps.h
  • APS_UNSUPPORTED_ATTRIBUTE_STATUS : aps.h

- b -

  • BACKUP_BIND_TABLE_CLID : zdo.h
  • BACKUP_SOURCE_BIND_CLID : zdo.h
  • BIND_CLID : zdo.h
  • BIND_REGISTER_CLID : zdo.h
  • BSP_TASK_ID : taskManager.h

- c -

  • COMPLEX_DESCRIPTOR_CLID : zdo.h
  • CS_ACK_TIMEOUT_ID : configServer.h
  • CS_ADDRESS_ASSIGNMENT_METHOD_ID : configServer.h
  • CS_ADDRESS_MAP_TABLE_ID : configServer.h
  • CS_ADDRESS_MAP_TABLE_SIZE_ID : configServer.h
  • CS_APS_ACK_FRAME_BUFFER_ID : configServer.h
  • CS_APS_ACK_FRAME_BUFFER_SIZE_ID : configServer.h
  • CS_APS_DATA_REQ_BUFFER_ID : configServer.h
  • CS_APS_DATA_REQ_BUFFER_SIZE_ID : configServer.h
  • CS_APS_GROUP_TABLE_ENDPOINTS_AMOUNT_ID : configServer.h
  • CS_APS_GROUP_TABLE_GROUPS_AMOUNT_ID : configServer.h
  • CS_APS_GROUP_TABLE_ID : configServer.h
  • CS_ASSOCIATE_RESPONSE_BUFFER_ID : configServer.h
  • CS_AUTONETWORK_ID : configServer.h
  • CS_CHANNEL_MASK_ID : configServer.h
  • CS_DEVICE_TYPE_ID : configServer.h
  • CS_DTR_WAKEUP_ID : configServer.h
  • CS_DUPLICATE_REJECTION_TABLE_ID : configServer.h
  • CS_DUPLICATE_REJECTION_TABLE_SIZE_ID : configServer.h
  • CS_END_DEVICE_ACTIVE_PERIOD_ID : configServer.h
  • CS_END_DEVICE_SLEEP_PERIOD_ID : configServer.h
  • CS_EXT_PANID_ID : configServer.h
  • CS_INDIRECT_POLL_RATE_ID : configServer.h
  • CS_MAC_FRAME_RX_BUFFER_ID : configServer.h
  • CS_MAC_FRAME_RX_BUFFER_SIZE_ID : configServer.h
  • CS_MAC_PAN_DESCRIPTOR_BUFFER_ID : configServer.h
  • CS_MAC_TRANSACTION_TIME_ID : configServer.h
  • CS_MAX_CHILDREN_AMOUNT_ID : configServer.h
  • CS_MAX_CHILDREN_ROUTER_AMOUNT_ID : configServer.h
  • CS_MAX_NETWORK_DEPTH_ID : configServer.h
  • CS_NEIB_TABLE_ID : configServer.h
  • CS_NEIB_TABLE_SIZE_ID : configServer.h
  • CS_NWK_ADDR_ID : configServer.h
  • CS_NWK_DATA_IND_BUFFER_ID : configServer.h
  • CS_NWK_DATA_IND_BUFFER_SIZE_ID : configServer.h
  • CS_NWK_DATA_REQ_BUFFER_ID : configServer.h
  • CS_NWK_DATA_REQ_BUFFER_SIZE_ID : configServer.h
  • CS_NWK_EXT_PANID_ID : configServer.h
  • CS_NWK_LOGICAL_CHANNEL_ID : configServer.h
  • CS_NWK_PAN_DESCRIPTOR_BUFFER_ID : configServer.h
  • CS_NWK_PANID_ID : configServer.h
  • CS_NWK_UNIQUE_ADDR_ID : configServer.h
  • CS_NWK_USE_MULTICAST_ID : configServer.h
  • CS_PERMIT_DURATION_ID : configServer.h
  • CS_PROTOCOL_VERSION_ID : configServer.h
  • CS_RF_TX_POWER_ID : configServer.h
  • CS_ROUTE_DISCOVERY_TABLE_ID : configServer.h
  • CS_ROUTE_DISCOVERY_TABLE_SIZE_ID : configServer.h
  • CS_ROUTE_TABLE_ID : configServer.h
  • CS_ROUTE_TABLE_SIZE_ID : configServer.h
  • CS_RX_ON_WHEN_IDLE_ID : configServer.h
  • CS_SCAN_DURATION_ID : configServer.h
  • CS_SOFT_RESET_REASON_ID : configServer.h
  • CS_STACK_PROFILE_ID : configServer.h
  • CS_UID_ID : configServer.h

- d -

  • DEVICE_ANNCE_CLID : zdo.h
  • DISCOVERY_CASH_CLID : zdo.h
  • DISCOVERY_STORE_CLID : zdo.h

- e -

  • END_DEVICE_BIND_CLID : zdo.h
  • EXT_ADDR_MODE : zdo.h
  • EXTENDED_ACTIVE_EP_CLID : zdo.h
  • EXTENDED_RESPONSE_REQUESTTYPE : zdo.h
  • EXTENDED_SIMPLE_DESC_CLID : zdo.h

- f -

  • FIND_NODE_CACHE_CLID : zdo.h

- h -

  • HAL_TASK_ID : taskManager.h

- i -

  • IEEE_ADDR_CLID : zdo.h

- l -

  • LEAVE_REQ : zdo.h
  • LEAVED_BY_PARENT : zdo.h
  • LINK_FAIL : zdo.h

- m -

  • MAC_HWI_TASK_ID : taskManager.h
  • MAC_PHY_HWD_TASK_ID : taskManager.h
  • MATCH_DESCRIPTOR_CLID : zdo.h
  • MGMT_BIND_CLID : zdo.h
  • MGMT_CACHE_CLID : zdo.h
  • MGMT_DIRECT_JOIN_CLID : zdo.h
  • MGMT_LEAVE_CLID : zdo.h
  • MGMT_LQI_CLID : zdo.h
  • MGMT_NWK_DISC_CLID : zdo.h
  • MGMT_NWK_UPDATE_CLID : zdo.h
  • MGMT_PERMIT_JOINING_CLID : zdo.h
  • MGMT_RTG_CLID : zdo.h

- n -

  • NODE_DESC_STORE_CLID : zdo.h
  • NODE_DESCRIPTOR_CLID : zdo.h
  • NWK_ADDR_CLID : zdo.h
  • NWK_TASK_ID : taskManager.h

- p -

  • PDS_CRC_ERROR : pdsDataServer.h
  • PDS_EEPROM_BUSY : pdsDataServer.h
  • PDS_EEPROM_ERROR : pdsDataServer.h
  • PDS_INVALID_REQUEST : pdsDataServer.h
  • PDS_SUCCESS : pdsDataServer.h
  • POWER_DESC_STORE_CLID : zdo.h
  • POWER_DESCRIPTOR_CLID : zdo.h

- r -

  • RECOVER_BIND_TABLE_CLID : zdo.h
  • RECOVER_SOURCE_BIND_CLID : zdo.h
  • REMOVE_BCKUP_BIND_ENTRY_CLID : zdo.h
  • REMOVE_NODE_CACHE_CLID : zdo.h
  • REPLACE_DEVICE_CLID : zdo.h

- s -

  • SHORT_ADDR_MODE : zdo.h
  • SIMPLE_DESC_STORE_CLID : zdo.h
  • SIMPLE_DESCRIPTOR_CLID : zdo.h
  • SINGLE_RESPONSE_REQUESTTYPE : zdo.h
  • SSP_TASK_ID : taskManager.h
  • STORE_BCKUP_BIND_ENTRY_CLID : zdo.h
  • SYSTEM_SERVER_DISCOVERY_CLID : zdo.h

- t -

  • TC_TASK_ID : taskManager.h

- u -

  • UNBIND_CLID : zdo.h
  • USER_DESC_CONF_CLID : zdo.h
  • USER_DESCRIPTOR_CLID : zdo.h

- z -

  • ZDO_AUTHENTICATION_FAIL_STATUS : zdo.h
  • ZDO_AUTHENTICATION_SUCCESS_STATUS : zdo.h
  • ZDO_BUSY_STATUS : zdo.h
  • ZDO_CMD_COMPLETED_STATUS : zdo.h
  • ZDO_DEVICE_NOT_FOUND_STATUS : zdo.h
  • ZDO_EXTPANID_ALREADY_EXIST_STATUS : zdo.h
  • ZDO_FAIL_STATUS : zdo.h
  • ZDO_IN_NETWORK_STATUS : zdo.h
  • ZDO_INSUFFICIENT_SPACE_STATUS : zdo.h
  • ZDO_INVALID_EP_STATUS : zdo.h
  • ZDO_INVALID_PARAMETERS_STATUS : zdo.h
  • ZDO_INVALID_REQUEST_STATUS : zdo.h
  • ZDO_NETWORK_LEFT_STATUS : zdo.h
  • ZDO_NETWORK_LOST_STATUS : zdo.h
  • ZDO_NETWORK_STARTED_STATUS : zdo.h
  • ZDO_NO_DESCRIPTOR_STATUS : zdo.h
  • ZDO_NO_ENTRY_STATUS : zdo.h
  • ZDO_NO_MATCH_STATUS : zdo.h
  • ZDO_NO_NETWORKS_STATUS : zdo.h
  • ZDO_NOT_ACTIVE_STATUS : zdo.h
  • ZDO_NOT_AUTHORIZED_STATUS : zdo.h
  • ZDO_NOT_PERMITTED_STATUS : zdo.h
  • ZDO_NOT_SUPPORTED_STATUS : zdo.h
  • ZDO_NWK_UPDATE_STATUS : zdo.h
  • ZDO_OUT_NETWORK_STATUS : zdo.h
  • ZDO_REJOIN_STARTED_STATUS : zdo.h
  • ZDO_RESPONSE_WAIT_TIMEOUT_STATUS : zdo.h
  • ZDO_SECURITY_FAIL_STATUS : zdo.h
  • ZDO_SECURITY_NOT_SUPPORTED_STATUS : zdo.h
  • ZDO_SECURITY_SUCCESS_STATUS : zdo.h
  • ZDO_SUCCESS_STATUS : zdo.h
  • ZDO_TABLE_FULL_STATUS : zdo.h
  • ZDO_TASK_ID : taskManager.h
  • ZDO_TIMEOUT_STATUS : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • h
  • m
  • n
  • p
  • s
  • t
  • z

- a -

  • APL_TaskHandler() : taskManager.h
  • APS_GetEndpointList() : aps.h
  • APS_GetReq() : aps.h
  • APS_RegisterEndpointReq() : aps.h
  • APS_ResumeEndpointIndication() : aps.h
  • APS_SetReq() : aps.h
  • APS_StopEndpointIndication() : aps.h
  • APS_TaskHandler() : taskManager.h
  • APS_UnregisterEndpointReq() : aps.h

- b -

  • BSP_CloseBatterySensor() : sensors.h
  • BSP_CloseButtons() : buttons.h
  • BSP_CloseLeds() : leds.h
  • BSP_CloseLightSensor() : sensors.h
  • BSP_CloseTemperatureSensor() : sensors.h
  • BSP_OffLed() : leds.h
  • BSP_OnLed() : leds.h
  • BSP_OpenBatterySensor() : sensors.h
  • BSP_OpenButtons() : buttons.h
  • BSP_OpenLeds() : leds.h
  • BSP_OpenLightSensor() : sensors.h
  • BSP_OpenTemperatureSensor() : sensors.h
  • BSP_ReadBatteryData() : sensors.h
  • BSP_ReadButtonsState() : buttons.h
  • BSP_ReadLightData() : sensors.h
  • BSP_ReadSliders() : sliders.h
  • BSP_ReadTemperatureData() : sensors.h
  • BSP_TaskHandler() : taskManager.h
  • BSP_ToggleLed() : leds.h

- c -

  • CS_GetMemory() : configServer.h
  • CS_Init() : configServer.h
  • CS_PdsDefaultValue() : configServer.h
  • CS_ReadParameter() : configServer.h
  • CS_WriteParameter() : configServer.h

- h -

  • HAL_AlarmSearchW1Device() : w1.h
  • HAL_CloseAdc() : adc.h
  • HAL_CloseI2cPacket() : i2cPacket.h
  • HAL_CloseSpi() : spi.h
  • HAL_CloseUart() : uart.h
  • HAL_ConvertToSleepInterval() : sleepTimer.h
  • HAL_DisableDtrWakeUp() : uart.h
  • HAL_DisableIrq() : irq.h
  • HAL_EnableDtrWakeUp() : uart.h
  • HAL_EnableIrq() : irq.h
  • HAL_GetSystemTime() : appTimer.h
  • HAL_IsTxEmpty() : uart.h
  • HAL_OffUartCts() : uart.h
  • HAL_OnUartCts() : uart.h
  • HAL_OpenAdc() : adc.h
  • HAL_OpenI2cPacket() : i2cPacket.h
  • HAL_OpenSpi() : spi.h
  • HAL_OpenUart() : uart.h
  • HAL_ReadAdc() : adc.h
  • HAL_ReadEeprom() : eeprom.h
  • HAL_ReadI2cPacket() : i2cPacket.h
  • HAL_ReadResetReason() : resetReason.h
  • HAL_ReadUart() : uart.h
  • HAL_ReadUartDtr() : uart.h
  • HAL_ReadUartRts() : uart.h
  • HAL_ReadUid() : uid.h
  • HAL_ReadW1() : w1.h
  • HAL_RegisterIrq() : irq.h
  • HAL_RegisterWdtCallback() : wdtCtrl.h
  • HAL_ResetW1() : w1.h
  • HAL_ResetWdt() : wdtCtrl.h
  • HAL_SearchW1Device() : w1.h
  • HAL_StartAppTimer() : appTimer.h
  • HAL_StartSleepTimer() : sleepTimer.h
  • HAL_StartWdt() : wdtCtrl.h
  • HAL_StopAppTimer() : appTimer.h
  • HAL_StopSleepTimer() : sleepTimer.h
  • HAL_StopWdt() : wdtCtrl.h
  • HAL_TaskHandler() : taskManager.h
  • HAL_UnregisterIrq() : irq.h
  • HAL_WarmReset() : resetReason.h
  • HAL_WriteEeprom() : eeprom.h
  • HAL_WriteI2cPacket() : i2cPacket.h
  • HAL_WriteSpi() : spi.h
  • HAL_WriteUart() : uart.h
  • HAL_WriteW1() : w1.h

- m -

  • MAC_HWI_TaskHandler() : taskManager.h
  • MAC_PHY_HWD_TaskHandler() : taskManager.h

- n -

  • NWK_TaskHandler() : taskManager.h

- p -

  • PDS_Init() : pdsDataServer.h
  • PDS_ReadUserData() : pdsDataServer.h
  • PDS_SetToDefault() : pdsDataServer.h
  • PDS_WriteUserData() : pdsDataServer.h

- s -

  • SSP_TaskHandler() : taskManager.h
  • SYS_PostTask() : taskManager.h
  • SYS_RunTask() : taskManager.h

- t -

  • TC_TaskHandler() : taskManager.h

- z -

  • ZDO_GetChildrenAddr() : zdo.h
  • ZDO_GetLqiRssi() : zdo.h
  • ZDO_GetNwkStatus() : zdo.h
  • ZDO_GetParentAddr() : zdo.h
  • ZDO_MgmtNwkUpdateNotf() : zdo.h
  • ZDO_ResetNetworkReq() : zdo.h
  • ZDO_SetTxPowerReq() : zdo.h
  • ZDO_SleepInd() : zdo.h
  • ZDO_SleepReq() : zdo.h
  • ZDO_SleepResp() : zdo.h
  • ZDO_StartNetworkReq() : zdo.h
  • ZDO_TaskHandler() : taskManager.h
  • ZDO_WakeUpInd() : zdo.h
  • ZDO_WakeUpReq() : zdo.h
  • ZDO_ZdpReq() : zdo.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • HAL_AppTimer_t : appTimer.h
  • HAL_SleepTimer_t : sleepTimer.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • SYS_taskFlag : taskManager.h
Generated on Wed Apr 9 17:48:42 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


Blink Application

  • Functions Summary
  • Sample Applications
  • Blink
  • Lowpower
  • Peer2peer
  • Ping-pong
  • Throughput Test
  • ZigBeeNet Demo

Blink Application

This example introduces the simplest application that uses timer and LEDs. When started, the application makes all the MeshBean2's LEDs blink synchronously with certain period.

The frequency of blinking may be varied manually within certain range. Namely, it increases or decreases by a factor of two on pressing the SW1 or SW2 button on the MeshBean2 board, correspondingly. Minimum, maximum and initial period values (in milliseconds) are defined in Makefile.

It is not recommended to set the initial period outside the minimum..maximum range, or set the minimum value to less than 2. In these cases, the application may behave inconsistently. (The corresponding error checking was omitted intentionally in order to keep the application code as simple as possible.)

The source code and Makefile of Blink application are located at [ZBN]\Sample Applications\Blink directory.

Generated on Mon Dec 3 13:00:04 2007 for ZigBeeNet API by doxygen 1.5.1-p1


Low Power Application

  • Functions Summary
  • Sample Applications
  • Blink
  • Lowpower
  • Peer2peer
  • Ping-pong
  • Throughput Test
  • ZigBeeNet Demo

Low Power Networking Application

This sample shows how to collect data transmitted from low-power devices, employing the simplest power management strategy. At least 2 nodes are participating, but up to 7 end devices can be engaged. There must be one and only coordinator, and the rest of nodes must be configured as end devices.

For simple node identification, define unique logical addresses by DIP switches. When setting 8 possible DIP combinations, keep in mind that:

  • ON position corresponds to logical 1;
  • Third DIP switch defines the most significant bit for logical address;
  • Zero logical address corresponds to the coordinator, which must be unique.
Node | DIP switches
 | SW4:1 | SW4:2 | SW4:3
0 | OFF | OFF | OFF
1 | ON | OFF | OFF
2 | OFF | ON | OFF
3 | ON | ON | OFF
4 | OFF | OFF | ON
5 | ON | OFF | ON
6 | OFF | ON | ON
7 | ON | ON | ON

To start the application and to initiate the network push SW1 button on each node, starting with coordinator. Green LED is switched ON if the network is started successfully.

Coordinator organizes the network with its own 'unique' PAN ID which is determined by its MAC address (considering the 16 least significant bits). Besides, user can set PAN ID in flash memory or EEPROM. In order to join, end devices are scanning the network.

End device measures temperature each 10 seconds and sends data to coordinator if the absolute increment of the measured value exceeds 0.5°C. Flashing yellow LED is indicating that data are transmitting. After the transmission is completed, the end device falls asleep. Unconditionally, the current temperature value is also sent if SW2 button is pressed on an end device, regardless the current node mode (sleeping or active).

Coordinator never sleeps; it keeps sending the received temperature data to UART via USB (see connection settings).

In order to help understanding the application code easier, two different image files are supplied, intended for programming the coordinator and end device, correspondingly.

The source code and Makefile of Low Power Test application are located at [ZBN]\Sample Applications\LowPower directory.

Generated on Mon Dec 3 13:00:04 2007 for ZigBeeNet API by doxygen 1.5.1-p1


Peer-to-peer Application

  • Functions Summary
  • Sample Applications
  • Blink
  • Lowpower
  • Peer2peer
  • Ping-pong
  • Throughput Test
  • ZigBeeNet Demo

Peer-to-peer Application

This sample shows how to organize the simplest peer-to-peer link. A simple buffering strategy is employed to avoid byte-by-byte data transfer.

At least 2 nodes are participating. Up to 7 nodes can be engaged. In order to define the node logical addresses, set DIP switches as shown below. One of the nodes should be configured as coordinator (i.e. its logical address should be set to zero). All of the nodes which are connected over UART to their own USB ports (see connection settings), simply exchange over UART with data sent to them by their hosts. The nodes communicate strictly in pairs defined by their logical addresses as follows:

  • node 0 with node 1;
  • node 2 with node 3;
  • node 4 with node 5;
  • node 6 with node 7.
Node | DIP switches
 | SW4:1 | SW4:2 | SW4:3
0 | OFF | OFF | OFF
1 | ON | OFF | OFF
2 | OFF | ON | OFF
3 | ON | ON | OFF
4 | OFF | OFF | ON
5 | ON | OFF | ON
6 | OFF | ON | ON
7 | ON | ON | ON

The network organizes automatically on startup. You may connect two devices to a PC (or to different PCs, thus introducing a rough functional equivalent of an instant messenger), start two instances of HyperTerminal, type some message in one terminal window and observe it appearing in the another.

Pressing SW1 button on a node results in sending a single maximum-length frame filled with 0xDD byte.

LEDs indicate network activity as follows:

  • when a node is searching for the network, green LED is blinking;
  • green LED is ON when the node joins the network successfully;
  • red LED is flashing when the node is sending data;
  • yellow LED flashing indicates the node is receiving data.

The source code and Makefile of Peer-to-peer application are located at [ZBN]\Sample Applications\Peer2peer directory.

Generated on Mon Dec 3 13:00:04 2007 for ZigBeeNet API by doxygen 1.5.1-p1


Ping-Pong Application

  • Functions Summary
  • Sample Applications
  • Blink
  • Lowpower
  • Peer2peer
  • Ping-pong
  • Throughput Test
  • ZigBeeNet Demo

Ping-Pong Application

This example shows how to make the nodes to process multiple data requests. Each node is waiting for a wireless message, and then passes it to the next node. Up to 4 nodes can be engaged to form a circle.

Logical addresses of the nodes are defined by two first DIP switches, which can be set to 4 possible combinations. The third DIP switch turned ON determines the node closing the configured chain to form a circle. In configurations of 2, 3 or 4 nodes, this should be the 2nd, 3rd or 4th node, correspondingly. DIP switch configurations are presented below.

Network formation is initiated by pressing SW1 button on each node, starting with the coordinator (the node with zero logical address). When network is started successfully, green LED is ON. Yellow LED is blinking red during the process of data transfer (LED is on while data are transmitted, and LED is off after the transmission is completed).

Sending data is initiated by pressing SW2 button on any node. Once the third DIP switch on the chain-closing node is in ON position, data will be passed over circularly: 0→1→2→3→0→1... and so forth. You can press SW2 button on any other node once more, and then the next data block will pass through the nodes in the same direction. If data block fails to be delivered during any transaction (due to communication error, router's overload or some other reason) it gets out of data circulation in the network.

DIP switches settings

2 nodes participating
Node | DIP switches
 | SW4:1 | SW4:2 | SW4:3
0 | OFF | OFF | OFF
1 | ON | OFF | ON

3 nodes participating
Node | DIP switches
 | SW4:1 | SW4:2 | SW4:3
0 | OFF | OFF | OFF
1 | ON | OFF | OFF
2 | OFF | ON | ON

4 nodes participating
Node | DIP switches
 | SW4:1 | SW4:2 | SW4:3
0 | OFF | OFF | OFF
1 | ON | OFF | OFF
2 | OFF | ON | OFF
3 | ON | ON | ON

The source code and Makefile of Ping application are located at [ZBN]\Sample Applications\Ping directory.

Generated on Mon Dec 3 13:00:04 2007 for ZigBeeNet API by doxygen 1.5.1-p1


Throughput Test Application

  • Functions Summary
  • Sample Applications
  • Blink
  • Lowpower
  • Peer2peer
  • Ping-pong
  • Throughput Test
  • ZigBeeNet Demo

Throughput Test Application

This application measures the RF bandwith of MeshBean modules. To use the Throughput Test application, burn two devices with the same application image and configure them with DIP swithches (see the table below) as coordinator and router, correspondingly.
DIP switches |  |  | Role
1 | 2 | 3
ON | OFF | OFF | Coordinator
OFF | ON | OFF | Router

After burning, power up both the nodes, connect the coordinator node to a PC and start terminal software (see connection settings). The router node continually sends packets of data over the air. The coordinator keeps measuring the connection bandwidth on application level and sending its value to PC via UART once per second.

The state of the nodes (searching for network, being joined to network, sending data and receiving data) is indicated by the onboard LEDs in the following manner:

  • when a node is searching for the network, green LED is blinking;
  • green LED is ON when the node joins the network successfully;
  • yellow LED is flashing when the node is sending data (for router) or receiving data (for coordinator);
  • red LED is used only on coordinator and is flashing when sending measured value to UART.

The source code and Makefile of Throughput Test application are located at [ZBN]\Sample Applications\ThroughputTest directory.

Generated on Mon Dec 3 13:00:04 2007 for ZigBeeNet API by doxygen 1.5.1-p1


ZigBeeNet Demo Application

  • Functions Summary
  • Sample Applications
  • Blink
  • Lowpower
  • Peer2peer
  • Ping-pong
  • Throughput Test
  • ZigBeeNet Demo

ZigBeeNet Demo Application

Preface

The ZigBeeNet Demo application is intended to organize a wireless sensor network (WSN) composed of MeshNetics™ MeshBean2 boards. Each WSN node periodically reads the data of its on-board sensors (light, temperature and battery power) and sends them to coordinator, which in turn sends the data to the PC's COM port. A special GUI application named WSN Monitor running on the PC displays the network topology and sensor data in an easy-to-interpret graphical form.

Using the Boards

To start the ZigBeeNet Demo, do the following:

  1. Using DIP swithches (see the table below) configure one node as a coordinator, and the others as routers/end-devices.
    DIP switches | Role
    1 | 2 | 3
    ON | OFF | OFF | Coordinator
    OFF | ON | OFF | Router
    OFF | OFF | ON | End device
  2. Connect the coordinator node to a PC by USB or RS-232 cable.
  3. Power on the nodes to bring them to Standby state.
  4. Once the nodes are powered on, they start searching for network. Alternatively, if the CS_AUTONETWORK parameter defined in the Makefile has been changed to 0, the user has to press the SW1 button on each node, starting from the coordinator.
  5. Start WSN Monitor on the PC to which the coordinator is connected.

Coordinator organizes the wireless network automatically. The WSN activity may be observed in two ways, i.e. by on-board LEDs (see description in the table below) and via the WSN Monitor running on PC.
Node State | LED state
 | LED1 (Red) | LED2 (Yellow) | LED3 (Green)
Standby | blinking synchronously
Searching for network | blinking | OFF | OFF
Joined to network | ON |  |
+ receiving data |  | blinking |
+ sending data |  |  | blinking
Sleeping (end device only) | OFF | OFF | OFF

The source code and Makefile of ZigBeeNet Demo application are located at [ZBN]\Sample Applications\ZBNDemo directory.

WSN Monitor

WSN Monitor is a PC-based GUI diagnostic application for ZigBeeNet Demo that is used to display the network topology and other information about the network. Run WSNMonitorSetup.exe located at [ZBN]\Evaluation Tools\ZBNDemo (WSN Monitor)\ to install the program.

Take a look at the screenshot below. WSN Monitor displays the network tree in real time and updates it automatically as the nodes join or leave. The nodes are represented by icons with the node data tips. The links between the nodes are tipped with the link quality data. Sensor data for each node is recorded and may be visualized in graphs and in table at any time.

On startup, go to Tools, Settings, and select the proper communication port from the COM port list. Also, check that the Parse sensors as value is set to int-32, in order to read the sensors measurements correctly.

Use top-level program menu and toolbars to control the topology outlook.

Generated on Mon Dec 3 13:00:04 2007 for ZigBeeNet API by doxygen 1.5.1-p1


ZigBeeNet Stack Documentation: Alphabetical List

ZigBeeNet Stack Documentation Data Structure Index

A | E | H | N | Z

A
E
ZDO_EndToEndAppKeyConf_t ZDO_PowerDescReq_t ZDO_SystemServerDiscoveryResp_t
APS_Address_t EDScan_t ZDO_EndToEndAppKeyReq_t ZDO_PowerDescResp_t ZDO_UserDescConfResp_t
APS_AibAttribute_t
H
ZDO_GetChildrenAddr_t ZDO_ResetNetworkConf_t ZDO_UserDescReq_t
APS_AibPermissionsConfiguration_t HAL_EepromParams_t ZDO_GetLqiRssi_t ZDO_ResetNetworkReq_t ZDO_UserDescResp_t
APS_DataConf_t HAL_UartDescriptor_t ZDO_IeeeAddrReq_t ZDO_SetTxPowerConf_t ZDO_UserDescSetReq_t
APS_DataInd_t
N
ZDO_IeeeAddrResp_t ZDO_SetTxPowerReq_t ZDO_WakeUpConf_t
APS_DataReq_t NetworkInf_t ZDO_MgmtLeaveReq_t ZDO_SimpleDescReq_t ZDO_WakeUpReq_t
APS_GetConf_t NodeAddr_t ZDO_MgmtNwkUpdateNotf_t ZDO_SimpleDescResp_t ZDO_ZdpFrame_t
APS_GetReq_t
Z
ZDO_MgmtNwkUpdateReq_t ZDO_SleepConf_t ZDO_ZdpReq_t
APS_RegisterEndpointReq_t ZDO_ActiveEPReq_t ZDO_MgmtPermitJoiningReq_t ZDO_SleepReq_t ZDO_ZdpReqFrame_t
APS_SetConf_t ZDO_ActiveEPResp_t ZDO_NodeDescReq_t ZDO_StartNetworkConf_t ZDO_ZdpResp_t
APS_SetReq_t ZDO_ComplexDescReq_t ZDO_NodeDescResp_t ZDO_StartNetworkReq_t ZDO_ZdpRespFrame_t
APS_TxOptions_t ZDO_ComplexDescResp_t ZDO_NwkAddrReq_t ZDO_SystemServerDiscoveryReq_t ZdpSimpleDescriptor_t
APS_UnregisterEndpointReq_t ZDO_DeviceAnnceReq_t ZDO_NwkAddrResp_t

A | E | H | N | Z


ZigBeeNet Stack Documentation: Main Page

  • Functions Summary
  • Sample Applications

ZigBit Development Kit 2.0

ZigBeeNet Stack Documentation

ZigBeeNet API Functions

The ZigBeeNet API functions contained within this package fall into the categories related to the following layers:

  • APS (Application Support Sublayer)
  • ZDO (ZigBee device object)
  • Configuration server functions
  • Multitasking management functions
  • HAL (functions dealing with the hardware functionality of the ZigBit module)
  • BSP (functions that provide interface to the buttons and sensors of the MeshBean2 board)
Generated on Wed Jan 16 18:09:30 2008 for ZigBeeNet Stack Documentation by doxygen 1.5.1-p1


ZigBeeNet Sample Applications

Several demo programs are provided with the ZigBeeNet Software API in order to demonstrate how to develop user's applications. These demos include:

  • Blink application
  • Low power Networking application
  • Peer-to-peer data exchange application
  • Ping-pong application
  • Throughput Test application
  • ZBNDemo application

System requirements

The ZigBeeNet sample applications are intended to run on MeshBeans and other compatible platform devices.

System requirements for the PC used to compile applications and program the nodes are:
PC
CPU | Intel Pentium III or higher, 800 MHz
RAM | 128 MB
Hard disk free space | 50 MB
Software
Operating system | Windows2000/XP
USB driver | CP210x USB to UART Bridge VCP Driver
Java machine | Java Runtime Environment JRE 5.0 Update 8 (version 1.5.0)
Compiler | AVR GCC 4.1.2 compiler available within the WinAVR 20070525 package.

To upload the firmware to the boards, you may use either JTAGICE mkII emulator in conjunction with AVR Studio or the Serial Bootloader utility.

How to build

Source codes of all sample applications along with the corresponding Makefiles are given at [ZBN]\Sample Applications\. Hereafter, [ZBN] denotes the root folder for ZDK installation. The compiled firmware image files are also contained in the same directory. However, it is not necessary to retain these files, since you can rebuild them at any time.

To compile an application, run make utility from the directory where its Makefile is located. Otherwise, find the corresponding *.aps file in the same directory, open it with AVR Studio and just press Build\Rebuild All in the main menu. The *.hex and *.srec image files will be generated. Now you may upload one of the image files onto a MeshBean2 board.

Programming the Boards

The boards can be programmed in one of the two ways: either by Serial Bootloader utility, or under AVR Studio using JTAG emulator, for example, JTAGICE mkII from Atmel.

Fuse bits should be set to the following values (in hex representation): 0xFF, 0x9C, 0x62 (factory default) when using Serial Bootloader, or 0xFF, 0x9D, 0x62 when using JTAG.

To learn more, see the Serial Bootloader Application Note contained in this kit, or the ZigBit™ Development Kit 1.3 User's Guide, MeshNetics Doc., S-ZDK-451.

Connecting to PC

All sample applications except Blink imply some interaction with a PC (although they may be run as well without connecting to PC, when the only observation of the state and activities of the boards is performed by their LEDs). While ZBNDemo uses a special custom program named WSN Monitor, other programs need just a general-purpose terminal application. The connection parameters must be set as follows:
Parameter | Value
Data Rate | 38400 bps
Data Bits | 8
Parity | None
Stop Bits | 1
Flow Control | None

Security

By default, the NWK layer security implemented in ZigBeeNet stack is switched off. The compiled stack libraries are supplied in versions for coordinator, router, end device, and all devices. Each of them is presented in two variants: "Security ON" and "Security OFF", thus making a total of 8 libraries. The choice of a particular library to include when compiling an application is defined by the values of STACK_TYPE and SECURITY_MODE parameters in its Makefile.

To switch on the security in an application, one should perform the following changes in its Makefile: change the SECURITY_MODE value to STD_SECURITY, uncomment the line containing DCS_APS_SECURITY_TIMEOUT_PERIOD definition, and select one of the two following modes of operation:

  • DCS_ZDO_SECURITY_STATUS=0. All devices in a network must have the same preconfigured network key (DCS_NETWORK_KEY) defined in the Makefile.
  • DCS_ZDO_SECURITY_STATUS=3. One of the devices in a network (usually a coordinator) must be configured as Trust Center, i.e. to have DCS_UID equal to DCS_APS_TRUST_CENTER_ADDRESS and a network key (DCS_NETWORK_KEY) defined in the Makefile. All other devices in the network must be provided with DCS_APS_TRUST_CENTER_ADDRESS to be able to establish connection with the Trust Center, but must have neither DCS_NETWORK_KEY nor DCS_UID defined.
Generated on Mon Dec 3 13:00:04 2007 for ZigBeeNet API by doxygen 1.5.1-p1